LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-24-2008, 08:24 PM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Rep: Reputation: 36
cant ssh to a home server open a gprs connection using proxy


hello everyone,
i am trying to figure out y i can not ssh connect to my home server from the internet... the specific client connection is carried out using a gprs modem and i connect through my isp through an http proxy server...

ssh nass@myhomeserver.no-ip.org -p80
gets me the following error:
FATAL: failed to begin relaying via HTTP
ssh_exchange_identification: Connection closed by remote host

ehat is this? how should i tackle it?

route -n returns:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 0.0.0.0 255.255.255.255 UH 0 0 0
ppp0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0
ppp0

the nameservers belong to another ISP but it shouldnt really matter...

if i establish the connection using wvdial i get to have internet on firefox, but if i try to connect to ssh at home it fails to connect..

nslookup and dig fail to do name resolution too...
any ideas?
nass
 
Old 05-25-2008, 03:31 PM   #2
framp
Member
 
Registered: Apr 2003
Location: Stuttgart, BW Germany
Distribution: SuSE 10.3-11.0, Knoppix, Ubuntu 8.10, Fedora 10
Posts: 119
Blog Entries: 5

Rep: Reputation: 15
Quote:
Originally Posted by nass View Post
ssh_exchange_identification: Connection closed by remote host
Have a look into /var/log/messages on the ssh server. If you don't find any helpful messages increase the log level in /etc/ssh/sshd_conf and check the log file again.
 
Old 05-26-2008, 11:04 AM   #3
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
i don't think the attempt to establish an ssh connection ever reaches the openssh server (which btw is a slackware 11 machine)..

raising the LogLevel in the client side though (an ubuntu 8.04 laptop) gives this...:

Quote:
nass@starlight:~$ ssh nass@myhomeserver.no-ip.org -p80
debug2: ssh_connect: needpriv 0
debug1: Executing proxy command: exec connect-proxy -H 192.168.200.10:9401 synthnassizer.no-ip.org 80
debug1: permanently_drop_suid: 1000
debug1: identity file /home/nass/.ssh/identity type -1
debug1: identity file /home/nass/.ssh/id_rsa type -1
debug1: identity file /home/nass/.ssh/id_dsa type -1
FATAL: failed to begin relaying via HTTP.
ssh_exchange_identification: Connection closed by remote host
nass@starlight:~$
on the client side /var/log/messages doesn't give any additional info either...

in /etc/ssh/ssh_config on the client (ubuntu) side i have added support to connect through the mobile service provider proxy server
Quote:
ProxyCommand connect-proxy -H 192.168.200.10:9401 %h %p
if i try the connect-proxy command stand alone i get the following debug output:
Quote:
root@starlight:/etc/ssh# connect-proxy -d -R both -H wap@192.168.200.10:9401 myhomeserver.no-ip.org 80
DEBUG: No direct address are specified.
DEBUG: relay_method = HTTP (3)
DEBUG: relay_host=192.168.200.10
DEBUG: relay_port=9401
DEBUG: relay_user=wap
DEBUG: local_type=stdio
DEBUG: dest_host=synthnassizer.no-ip.org
DEBUG: dest_port=80
DEBUG: Program is $Revision: 1.96 $
DEBUG: resolving host by name: synthnassizer.no-ip.org
DEBUG: failed to resolve locally.
DEBUG: connecting to 192.168.200.10:9401
DEBUG: begin_http_relay()
DEBUG: >>> "CONNECT synthnassizer.no-ip.org:80 HTTP/1.0\r\n"
DEBUG: >>> "\r\n"
DEBUG: <<< "HTTP/1.1 403 Forbidden\r\n"
DEBUG: http proxy is not allowed.
FATAL: failed to begin relaying via HTTP.
root@starlight:/etc/ssh#
i strongly believe it has to do with the dns server queries... i have used a couple of valid nameservers in /etc/resolv.conf but they are from another internet service provider... and yet i have internet in firefox if i just enable proxy server through the connection settings...

the routing table looks like:
Quote:
root@starlight:/etc/ssh# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 10.6.6.6 0.0.0.0 UG 0 0 0 ppp0
root@starlight:/etc/ssh#

please notice that there can't be a problem with the ssh configurations, since whenever i am @ home, and connect this laptop to the internet through my home wifi, i obviously connect everywhere (without using the proxy command of course)...

hope this helps abit
nass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
openvpn fails to connect to its server over a gprs modem ppp connection nass Linux - Networking 0 05-07-2008 03:41 PM
How to enable 2 ssh server : one for /home and one for /home/theuser only? frenchn00b Linux - Server 14 05-06-2008 05:37 PM
ssh connection refused - trying to set up ssh server at home openSauce Linux - Server 10 10-18-2007 04:38 PM
Passwordless SSH with SSH commercial server and open ssh cereal83 Linux - General 7 04-18-2006 12:34 PM
SSH connection through companies proxy server rydl Linux - Networking 2 10-26-2005 09:08 AM


All times are GMT -5. The time now is 10:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration