LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't ping gateway (http://www.linuxquestions.org/questions/linux-networking-3/cant-ping-gateway-4175446047/)

seamore 01-17-2013 11:13 AM

Can't ping gateway
 
I recently reformated a linux box and replaced an older version of Slackware with v13.37. The pc is on a local network connected fine with the config. The new install cannot ping the gateway or other pcs on the subnet. The router is a Belkin wireless router. I'm using a fixed IP for the pc in question. When I try to ping the gateway I get "Destination Host Unreachable". I tried with DNS IPs, that did not work either. A second pc with Windows can ping the router. It has a fixed IP of 192.168.2.110.

Netconfig:

Hostname: UnixDev
IP: 192.168.2.9
Gateway: 192.168.2.1
Netmask: 255.255.255.0
Domain: Belkin
DNS: none (not needed)

Route:

Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.2.1 0.0.0.0 UG 1 0 0 eth0

Ser Olmy 01-17-2013 11:50 AM

"Destination host unreachable" for a local IP means no ARP replies are received.

Could you post the output of ethtool eth0 and route -n?

seamore 01-17-2013 12:58 PM

ethtool eth0:

Settings for eth0:

Supported ports: [ TP MII ]
Supported link nodes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: yes
Advertised link nodes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: yes
Speed 10Mb/s
Duplex: Half
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: no

route -n (commas added for clarity)

Destination, Gateway, Genmask, Flags, Metric, Ref, Use, Iface
192.168.2.0, 0.0.0.0, 255.255.255.0, U, 0, 0, 0, eth0
127.0.0.0, 0.0.0.0., 255.0.0.0, U, 0, 0, 0, l0
0.0.0.0, 192.168.2.1, 0.0.0.0, UG, 1, 0, 0, eth0

Ser Olmy 01-17-2013 02:28 PM

Quote:

Originally Posted by seamore (Post 4872379)
ethtool eth0:

Settings for eth0:

Supported ports: [ TP MII ]
Supported link nodes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: yes
Advertised link nodes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: yes
Speed 10Mb/s
Duplex: Half
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: no

There's your problem. Check all cabling and the link lights on the NIC and the switch/router.

seamore 01-17-2013 03:15 PM

I replaced the cable to the router, lights on NIC are on, rebooted the router. Problem persists.

This computer was communicating with the LAN before I installed the new Slack distribution.

Ser Olmy 01-17-2013 03:41 PM

Do you by any chance have more than one NIC? What does ifconfig -a say?

It could also be a driver issue. What make and model is your NIC? The output from lsmod and lspci -v could be helpful.

seamore 01-17-2013 04:17 PM

Thank you for your help. I think it must be that the network card is no longer supported. Its cheap & very old.
I have a relatively new wireless card which I will try and report back to this thread.

Again thanks.

seamore 01-26-2013 11:56 AM

Problem solved
 
It turns out the new Slack version no longer supports the old nic. When I replaced it with a newer nic, everything worked. Thanks again for the help I received.


All times are GMT -5. The time now is 11:44 PM.