LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't mount Debian Lenny NFS server volume in Slackware with write permission (http://www.linuxquestions.org/questions/linux-networking-3/cant-mount-debian-lenny-nfs-server-volume-in-slackware-with-write-permission-762793/)

glass931 10-18-2009 11:40 AM

Can't mount Debian Lenny NFS server volume in Slackware with write permission
 
I have no problem, as root user on Lenny NFS clients, mounting the volume exported by the Lenny NFS server. The server grants rw permission to root and the client has root rw permission for the exported volume.

I use the RIP (recovery is possible) recovery system from time to time, which is based on Slackware 12. Even though mtab shows the nfs volume with rw permission, I can not create or copy a file onto the volume. I can, however, modify a pre-existing file on the volume.

I've tried all the possible changes I can find. I note that the uid and gid for nobody is different, but am not sure if this is the problem or how I might fix it. It seems to me that the default user would not be a problem when dealing with root access.

Any assistance would be greatly appreciated.

jhwilliams 10-19-2009 04:10 AM

Check out the output of:
Code:

sudo rgrep -i nfs /var/log

glass931 10-19-2009 09:25 AM

NFS Problem
 
Quote:

Originally Posted by jhwilliams (Post 3724672)
Check out the output of:
Code:

sudo rgrep -i nfs /var/log/

As root I entered rgrep -i nfs /var/log/*, in order to query all the files in /var/log. I found the following:
/var/log/messages:Oct 17 09:04:34 RIPLinuX rpc.statd[1702]: statd running as root. chown /var/lib/nfs/sm to choose different user
/var/log/messages:Oct 17 09:40:17 hpn2 rpc.statd[1702]: statd running as root. chown /var/lib/nfs/sm to choose different user

I realized that I had two names for the machine in /etc/hosts, RIPLinuX and hpn2. The former is
the RIP system hostname and the latter is the lenny system hostname. This resulted, however, from some experimentation after the problem was first noted.

Thanks for the prompt reply.

jhwilliams 10-19-2009 11:19 AM

Quote:

Originally Posted by glass931 (Post 3724900)
As root I entered rgrep -i nfs /var/log/*, in order to query all the files in /var/log.

Just wanted to point out:

Code:

jameson@salmon:~$cat /usr/bin/rgrep
#!/bin/sh

exec grep -r "$@"

from grep(1):
Quote:

-R, -r, --recursive
Read all files under each directory, recursively; this is equivalent to the -d recurse option.


All times are GMT -5. The time now is 11:35 AM.