LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't disable IPv6 (http://www.linuxquestions.org/questions/linux-networking-3/cant-disable-ipv6-793606/)

bhamid 03-06-2010 08:17 AM

Can't disable IPv6
 
I followed the instructions in the Ubuntu help and support after reading that it might solve my slow internet (I've tried using OpenDNS servers) but when type in gksudo gedit /etc/modprobe.d/aliases and type in the password, a blank document comes up in gedit, and there is no file in the modprobe.d folder called alias.

Bhamid

camorri 03-06-2010 08:33 AM

When you make posts like this, would you please post the link to the procedure you used.

Just a guess, the aliases file doesn't exist, you can create one. Store the info requested, and restart TCP/IP.

You can try this, I found it with a google search.

Quote:

Debian / Ubuntu Linux

If you are using Debian/Ubuntu linux (thanks to beranger), open file /etc/modprobe.d/aliases
# vi /etc/modprobe.d/aliases
Find the line:
alias net-pf-10 ipv6

Replace with:
alias net-pf-10 off
alias ipv6 off
As above, create the aliases file.

tredegar 03-06-2010 09:58 AM

I am guessing that you have 'buntu 9.10
If so then this link is relevant, because ipv6 cannot now be disabled by blacklisting modules.

nimnull22 03-06-2010 11:43 AM

Have you try to add in blacklist:
Code:

install        ipv6          /bin/true
It works for OpenSuse, Fedora 12.

reed9 03-06-2010 01:17 PM

Note that files in /etc/modprobe.d should end in .conf. I'm not sure it's happened yet, but at some point, files there not ending in .conf will be ignored.

As said, you can create the file aliases. The name (other than the .conf) doesn't really matter, although I believe they are read in alphabetically order. Someone correct me if I'm wrong. You could also put it in /etc/modprobe.d/modprobe.conf or /etc/modprobe.d/blacklist.conf.

Adding the line install ipv6 /bin/true to a file in /etc/modprobe.d/ also works. The problem with a simple blacklist is that if another program later tries to load the module or an alias is called, it will still load. (Hence turning off the net-pf-10 alias.) /bin/true as the name suggests always returns a value of true, so the module is sent off into the ether but doesn't throw an error to whatever was trying to load the module.

win32sux 03-07-2010 09:53 PM

I do the modprobe blacklisting, but I'm on 8.10. I'm pretty sure this was built into the kernel in later releases (at least in Ubuntu 9.04), in which case this approach wouldn't work any more.

Try doing a:
Code:

sysctl -w net.ipv6.conf.all.disable_ipv6=1
Or add this to your kernel line:
Code:

ipv6.disable=1
Source: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/351656

Did this go back to being a module in Ubuntu 9.10?

IgnitedMind 04-05-2013 05:15 AM

unable to disable IPV6 on linux
 
1. I had already made following entries in ifcfg-eth0 :
IPv6INIT=NO
IPV6AUTOCONF=NO
2. Following entries were made in /etc/modprob.conf” :
alias net-pf-10 off
alias ipv6 off
3. These entries in /etc/sysconfig/network :
IPV6INIT=NO
NETWORKING_IPV6=NO
4. This line is added to /etc/modprobe.d/blaclist :
blacklist ipv6
5. Also I did one more in /etc/sysctl.conf :
6. `net.ipv6.conf.all.autoconf = 0`
7. `net.ipv6.conf.accept_ra = 0`

Still I am unable to disable IPV6 on linux, any thought please

John VV 04-26-2013 06:45 PM

posting in the correct section for your distro will help to get an answer

I highly dought that you are running the long dead Ubuntu 8.10

IgnitedMind 04-30-2013 12:54 AM

This thread is about disable IPV6 and i have the same issue hence posted it here. Do let me know if i have to put on some other section ?>

I am running linux 5.8.

John VV 04-30-2013 01:19 AM

linux 5.8 what

RHEL 5.8 ( the current is 5.9 in the old 5 series )
CentOS 5.8 -- it is unsupported ( only 5.9 in the old 5 series is supported)

the ubuntu instructions are very different than the old rhel5 instructions

is this a terminal ONLY install ?
-- the most common for rhel
or a desktop install ?
if desktop then What desktop ?
gnome,kde,xfce,.....

also be aware that the old 5 rhel/cent OS might not support new hardware .

for RHEL/CentOS
http://www.linuxquestions.org/questions/red-hat-31/
or in "network "
http://www.linuxquestions.org/questi...-networking-3/



Seeing as this is a network issue this forum

the instructions depend on if you are using a GUI or a terminal server install

for a home install using Gnome2
there are two programs in the old 5 series
"Network" and "NetworkManager"
"NetworkManager" was a bit experimental back then .
"NetworkManager" added wireless support

if #1 and #3 in the post above
-----
1. I had already made following entries in ifcfg-eth0 :
IPv6INIT=NO
IPV6AUTOCONF=NO
----
3. These entries in /etc/sysconfig/network :
IPV6INIT=NO
NETWORKING_IPV6=NO
-----
did not turn it off

then you will need to use the gui ( assuming that Gnome2 is used -- it is default)
click on the "network" icon -- should be in the bottom right tool bar
or in the top tool bar - System / preferences / Network

and from that gui tool turn it off in dhcp for "eth-0" for the cable connection
there should be a ipv6 tab next to the ipv4 tab

IgnitedMind 04-30-2013 02:13 AM

This is Oracle Linux 5.8 Virtual Machine installed on VM Box which is on window base machine.

I am using Oracle Linux 5.8 x64 as a guest OS on virtual machine under Oracle VirtualBox

Steps:

I have window I7
I have installed Virtual Box Manager on this.
I have installed Oracle Linux Virtual Machine. (Oracle Linux 5.8)

I have already done the step going to System / preferences / Network -> ipv6 tab next to the ipv4 tab. No changes in the result.


All times are GMT -5. The time now is 01:31 AM.