LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't acess directories shared by Samba in windows XP (http://www.linuxquestions.org/questions/linux-networking-3/cant-acess-directories-shared-by-samba-in-windows-xp-248863/)

vador 10-29-2004 04:11 PM

Can't acess directories shared by Samba in windows XP
 
HI all

I have configured samba via swat. I shared 2 folders and the printer both from my server running Debian. Then I went to windows XP and I could see the debian serve I saw the 2 directories and the printer. The printer is working fine :) but I can't acess the folders!! When I click in the folders to enter this error is shown in XP --> " \\BlindLock\/opt/MP3 is not acessible. You might not have permission to use this network resourc. Contact the administrator of this server to find out if you have acess permissions. The network path was not found"


Here is my smb.conf:

max log size = 1000
domain logons = Yes
dns proxy = No
panic action = /usr/share/samba/panic-action %d
invalid users = root
include = /etc/samba/dhcp.conf

[printers]
comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[/tmp]
comment = Temporary
path = /tmp

[Hp840c]
comment = Impressora
path = /tmp
read only = No
create mask = 0700
printable = Yes
printer name = Hp840c
oplocks = No
share modes = No

[/opt/MP3]
comment = MP3
path = /opt/MP3
valid users = vador
write list = @vador
guest ok = Yes




Cheers guys :)

LinuxRam 10-29-2004 04:16 PM

@vador

Change the permission of the directory in which u could not able to write. Find an option in swat as read only set it to no.




-Akshat

vador 10-29-2004 04:36 PM

I have done that but the same error continuous
:/

LinuxRam 10-29-2004 04:46 PM

@vador

Your mp3 share doen't show any read only option disabled.
Try changing the permission of shares to 777 for a while.


-Akshat

celejar 10-29-2004 05:06 PM

Samba on linux requires that the login be done with a username/password valid on the linux box. Do you use the same username/passwords on both boxes? If not you can set the username map option in smb.conf ('man smb.conf' for info on that.


All times are GMT -5. The time now is 06:42 AM.