LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-06-2004, 03:34 AM   #1
BlueFlame
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
Question Cant access network - Nautilus cannot contact the SMB master browser


Hi I'm new to linux, and have been trying to set up a network between a linux computer running Red Hat 9.0 and a XP computer (the network also has win95 computers).

The problem is, whenever I try to run "Network Servers" I get the error message:
Quote:
Cant't Display Location
----------------------
Couldn't display "smb:///", because Nautilus cannot contact the SMB master browser.
Check that an SMB server is running in the local network
I have looked "Server settings->Services", and for "smb" it says:
smbd (pid 2500) is running...
nmbd is stopped
(when i tell it to start nmbd still doesnt start)

Here's my smb.conf: (without the comments)

workgroup = mshome ;[I changed this]
server string = samba server
printcap name = /etc/printcap
load printers = yes
printing = cups
log file = /var/log/samba/%m.log
max log size = 0
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
pam password change = yes
obey pam restrictions = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
guest ok = yes
username map = /etc/samba/smbusers
dns proxy = no


How can I get onto the network and access the computers?
Must I have a SMB server?
(if I must, how do I set one up - can it be the linux machine?)

Thanks
 
Old 06-07-2004, 02:33 PM   #2
BlueFlame
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Does anyone know how to get past this problem?

Do you know of any other way to get the network working properly in Red Hat 9.0
(how do other people get their network working in Red Hat?)
 
Old 06-07-2004, 03:43 PM   #3
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 31
BlueFlame

I'm by no means a Samba expert but you must have nmbd running for samba to work, it's a bit like a small domain name server for your local network

First thing to try is your firewall if nmbd can't listen on your network it won't work

As you are using Redhat have you got your NIC listed in your security settings as a trusted device ? should be the top item System Settings->Security Level

Just as a test case if the above is already true disable the firewall then try to stop and restart smb

These are my first observations

Regards

Pete
 
Old 06-07-2004, 04:17 PM   #4
nightjar
Member
 
Registered: May 2002
Location: Argentina
Distribution: Mandrake 9.2
Posts: 177

Rep: Reputation: 30
It's a home network? Need you security or you're the only user?

I you don't need pass then set security = share in smb.conf
Put he same name of the workgroup in both boxes.
That the first
Then type as root /etc/init.d/smb start
Try to connect from windoze
From linux (as root) you must mount the windows partitions
smbmount //name_of_the _windoze_machine/c /mnt/name_of_a_dir_you_prefer/c
when prompt for the pass type again the root pass
Tell us if you find the solution
 
Old 06-08-2004, 01:02 AM   #5
BlueFlame
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the help guys

I found that the reason nmbd wasnt running was because the network wasnt active [this however wasnt the cause of my problem]

I enabled the WINS support options in the smb.conf file, as well as all the options that try to make the linux computer the master. Also the security settings seem to be OK.

Here's my new smb.conf
Quote:
workgroup = mshome
server string = samba server
printcap name = /etc/printcap
load printers = yes
printing = cups
log file = /var/log/samba/%m.log
max log size = 0
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
pam password change = yes
obey pam restrictions = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = yes
os level = 65
domain master = yes
preferred master = yes
domain logons = yes
wins support = yes
guest ok = yes
username map = /etc/samba/smbusers
dns proxy = no
I'm still having problems with the network though... I cant get my eth0 network to activate on start up, so smb doesnt start properly (it does start - but i get the same problem as before).
However I found that if I activate the network and restart smb (from system settings->server settings->services) then log off, and log back on - so that the network is running when I log in - everything works

If you know anything about how to get all this to activate on startup (I tried ticking that option in the network settings and it doesnt seem to work) please let me know

Thanks Again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows PC announcing itself as Master smb seanfitz Linux - Networking 2 04-08-2005 12:55 AM
Nautilus SMB access to WinXP rje_NC Slackware 0 02-25-2005 03:45 PM
smb and master browser Pedroski Linux - Networking 3 05-04-2004 10:43 AM
SMB Master Problems Also NRHBasher Linux - Networking 2 04-03-2004 12:13 AM
making smb shares viewable from smb client via web browser scottpioso General 3 11-10-2003 04:25 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration