LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Cannot retrieve metalink for repository: fedora with yum after Fedora 15 upgrade (http://www.linuxquestions.org/questions/linux-networking-3/cannot-retrieve-metalink-for-repository-fedora-with-yum-after-fedora-15-upgrade-894793/)

tron_thomas 07-31-2011 06:57 PM

Cannot retrieve metalink for repository: fedora with yum after Fedora 15 upgrade
 
I upgraded an Intel Core 2 Duo system to the 64-bit version of Fedora 15, and now yum will not work properly.

Quote:

yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again

yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
What can be done to resolve these issues so that yum can update the system?

corp769 07-31-2011 07:41 PM

Hello,

I have come across many users getting this error after upgrading. Have you checked your system wide proxy settings? That is the biggest issue when it comes to this error. Have a look here - http://forums.fedoraforum.org/showthread.php?t=224988 and here also - http://forums.fedoraforum.org/showthread.php?t=266923

Hope this helps!

Cheers,

Josh

tron_thomas 07-31-2011 11:27 PM

I think I already saw one of those posting when I researched the problem before posting. Niether one of them seem to mention how to change any proxy settings that I could tell. I don't believe I'm using a proxy server or anything like that, so I'm not sure that is my problem. If it is, I am not sure how someone is supposed to modify their settings and what changes they need to make.

corp769 08-01-2011 10:10 AM

Have a look at your yum.conf configuration within /etc/ and make sure that the proxy settings don't have anything different than the settings in the system wide proxy settings, located within your preferences.

tron_thomas 08-02-2011 12:12 AM

Here's the contents of my yum.conf file:

Quote:

[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3

# This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
# It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
I don't see anything about proxy settings, so I'm not sure what insight this offers to the problem.

corp769 08-02-2011 01:00 AM

After staring at your configuration, I think I know what the problem is.... See where it says "Cannot retrieve repository metadata (repomd.xml) for repository: fedora"? Well that's it right there - the fedora repository is "down"..... Can you post the contents of your fedora.repo file located within /etc/yum.repos.d/ for me?

tron_thomas 08-04-2011 12:34 AM

I'm not sure my problem is that the fedora repository is down. I have another Intel system I also upgraded to Fedora 15, and it looks like it can access the repository fine. This is the output I get on that system when I execute yum repolist:

Quote:

Loaded plugins: presto, refresh-packagekit
adobe-linux-i386 | 951 B 00:00
rpmfusion-free-updates | 2.7 kB 00:00
rpmfusion-free-updates/primary_db | 163 kB 00:01
rpmfusion-nonfree-updates | 2.7 kB 00:00
rpmfusion-nonfree-updates/primary_db | 59 kB 00:01
Could not get metalink https://mirrors.fedoraproject.org/me...-f15&arch=i386 error was
14: curl#6 - "Couldn't resolve host"
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated 18
fedora Fedora 15 - i386 19,365
rpmfusion-free RPM Fusion for Fedora 15 - Free 370
rpmfusion-free-updates RPM Fusion for Fedora 15 - Free - Updates 292
rpmfusion-nonfree RPM Fusion for Fedora 15 - Nonfree 160
rpmfusion-nonfree-updates RPM Fusion for Fedora 15 - Nonfree - Updates 145
updates Fedora 15 - i386 - Updates 3,535
repolist: 23,885
This is what I get when I execute yum repolist on the system with the problem:
Quote:

Loaded plugins: langpacks, presto, refresh-packagekit
rpmfusion-free-updates | 2.7 kB 00:00
rpmfusion-nonfree-updates | 2.7 kB 00:00
rpmfusion-nonfree-updates/primary_db | 50 kB 00:00
Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again
One difference is that the system that seems to works is 32-bit and the system with the problem is 64-bit. I don't know how significant that is. I checked and both machines have the same fedora.repo file, so I'm not sure there's any problem with that file. Here are the contents of the fedora.repo file:
Quote:

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

corp769 08-04-2011 11:53 AM

I wasn't meaning that it was actually down, just that your configuration might have been jacked. I did notice something else though.... Try manually switching mirrors before you go any further, I had a very similar problem a while back, and that was the fix to change mirrors.

tron_thomas 08-06-2011 05:11 PM

It looks like I was able to get things to work by added the following line to /etc/hosts:
80.239.156.215 mirrors.fedoraproject.org

corp769 08-06-2011 06:53 PM

Glad to hear you have resolved your issue. Please mark your thread as solved if you can, thanks!


All times are GMT -5. The time now is 05:09 PM.