LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-27-2009, 09:45 PM   #1
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Rep: Reputation: 16
Cannot connect to WEP encrypted network


Hey all,

I finally got my wireless going, and I am able to connect to unencrypted networks. However, my own home network is using WEP, and I'd like to figure out why I can connect to unencrypted networks and not WEP encrypted ones.

I started by using wicd, and through wicd I can connect to whatever unencrypted network happens to be around. The signal is very spotty and inconsistent, which might just be a proximity issue.

After trying and failing to connect to my WEP network through wicd, I decided to set it up manually via command line.

The distro I am using is BackTrack 4, which is based on Ubuntu. (Formerly is was based on Slackware.)

Here is what I've tried:

sudo ifconfig wlan0 inet 192.168.1.6 netmask 255.255.255.0 ssid "test" bssid 00:XX:XX:XX:XX:XX channel 10 wepkey 1234567 weptxkey 1 wepmode mixed
Code:
ssid: Unknown host
ifconfig `--help gives usage information.
"weptxkey 1 wepmode mixed" -- I'm not sure what these two options should be for myself, but I saw this in another forum as a suggestion for someone else with this problem to try.

iwconfig -wlan0
Code:
wlan0   802.11b/g link.. ESSID:"test"
Mode:Managed  Channel=6  Access Point: 00:XX:XX:XX:XX:XX
Bit Rate=11 Mb/s  Tx-Power=5 dBm
Retry:on Fragment thr:off
Link quality=85/100 Signal level=60 dBm  Noise level=15 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0  Missed beacon:0
sudo dhcpcd wlan0
Code:
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.XXX.XXX.XXX
(The XXX's above are not what the actual output was.)

I hope this information is helpful...
 
Old 07-28-2009, 05:23 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,441

Rep: Reputation: 103Reputation: 103
running a desktop, maybe Gnome? Would provide you with GUIs for that, rather simple.
WEP is not safe, btw.
 
Old 07-28-2009, 06:53 AM   #3
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Desktop environment is KDE. The GUI interface I tried using was wicd, but I couldn't get it to connect, hence the manual attempt to do it through command line.

Haha yeah, I know WEP isn't safe. It's my dad's network though, and there's no convincing him.
 
Old 07-28-2009, 07:51 AM   #4
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,441

Rep: Reputation: 103Reputation: 103
Did the GUI show the network as available?
 
Old 07-28-2009, 08:12 AM   #5
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Yes, it showed many of the networks surrounding my house as well, and I was even able to connect to an unencrypted one. For some reason it can't connect to my encrypted one.

Last edited by Innervision; 07-28-2009 at 08:15 AM.
 
Old 07-28-2009, 08:45 AM   #6
ap0calypse
Member
 
Registered: Jul 2009
Location: Austria
Distribution: Slackware
Posts: 38

Rep: Reputation: 16
Maybe you should use wpa_supplicant? It can handle WEP-networks too as far as I can remember ...
Just install it, edit /etc/wpa_supplicant.conf and start it like this:

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf &
dhcpcd wlan0 &


and it should work.

BTW:
I don't think that ifconfig has a param called "ssid"
You could use iwconfig to configure a WEP-enabled interface-connection too ...

Last edited by ap0calypse; 07-28-2009 at 08:47 AM.
 
Old 07-28-2009, 12:30 PM   #7
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Thanks ap0calypse, I'll give that a try.
 
Old 07-28-2009, 08:23 PM   #8
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Okay, so I tried:
sudo wpa_supplicant -i wlan0 -c /eta/wpa_supplicant/wpa_supplicant.conf &

Output:
Code:
[1] 5571
sudo dhcpcd wlan0 &

Output:
Code:
[2] 5956
sudo dhcpcd wlan0

Output:
Code:
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.XXX.XXX.XXX

[1]+ Stopped         sudo wpa_supplicant -i wlan0 -c /eta/wpa_supplicant/wpa_supplicant.conf
dhcpcd.sh: interface wlan0 has been configured with new IP=169.XXX.XXX.XXX
And then it fails to connect to the internet.

Last edited by Innervision; 07-28-2009 at 08:25 PM.
 
Old 07-29-2009, 01:52 AM   #9
ap0calypse
Member
 
Registered: Jul 2009
Location: Austria
Distribution: Slackware
Posts: 38

Rep: Reputation: 16
Quote:
Originally Posted by Innervision View Post
Okay, so I tried:
sudo wpa_supplicant -i wlan0 -c /eta/wpa_supplicant/wpa_supplicant.conf &

Output:
Code:
[1] 5571
sudo dhcpcd wlan0 &

Output:
Code:
[2] 5956
sudo dhcpcd wlan0

Output:
Code:
err, wlan0: timed out
warn, wlan0: using IPV4LL address 169.XXX.XXX.XXX

[1]+ Stopped         sudo wpa_supplicant -i wlan0 -c /eta/wpa_supplicant/wpa_supplicant.conf
dhcpcd.sh: interface wlan0 has been configured with new IP=169.XXX.XXX.XXX
And then it fails to connect to the internet.
At first, wait for the wpa_supplicant command to finish. If it isn't complete, the dhcp-request won't work anyway

By the way, I guess that your command didn't come back successfully because you had a typo in it ...
sudo wpa_supplicant -i wlan0 -c /eta/wpa_supplicant/wpa_supplicant.conf &

This should be /etc/ of course. You could simply run it in the foreground for error analysis by avoiding the "&" at the end.

Please try this wpa_supplicant command again without the "&" and tell me what happens.
 
Old 07-29-2009, 12:01 PM   #10
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
So I tried sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

And the output was a continuous loop of the following:

Code:
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
CTRL-EVENT-SCAN-RESULTS
Trying to associate with 00:1f:XX:XX:XX:XX (SSID='test' freq=2437 MHz)
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWGENIE]: Operation not supported
ioctl[SIOCSIWFREQ]: Operation not supported
Association request to the driver failed
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Authentication with 00:00:00:00:00:00 timed out.
 
Old 07-29-2009, 06:57 PM   #11
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Honestly it's kind of driving me crazy.
 
Old 07-30-2009, 01:42 AM   #12
ap0calypse
Member
 
Registered: Jul 2009
Location: Austria
Distribution: Slackware
Posts: 38

Rep: Reputation: 16
Which wireless chipset do you have? You will have to specify the driver for wpa_supplicant to work:

sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -D YOURDRIVER

where YOURDRIVER could be one of those:

hostap
hermes
madwifi
atmel
wext
ndiswrapper
broadcom
ipw
wired
roboswitch
bsd
ndis

Please take a look at the manpage -> man wpa_supplicant

You could alternatively try to configure it with iwconfig:

iwconfig wlan0 mode Managed
iwconfig wlan0 essid YOURSSID
iwconfig wlan0 key s:YOURPASSWORD



Have a look at the manpage of iwconfig. It maybe helps you out.

Last edited by ap0calypse; 07-30-2009 at 01:55 AM.
 
Old 08-20-2009, 12:35 PM   #13
sirbabyface
LQ Newbie
 
Registered: Aug 2009
Posts: 1

Rep: Reputation: 0
I'd similar problems.
I've a 4965N Intel wireless card on my laptop. So I need to install 2 things to make it work:

- udev
- microcode (ucode) with the firmware of my driver.

I've also to enable support to load user firmware on the kernel.

After this, I could connect to my wireless networks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem getting wep to connect to network bhert Linux - Wireless Networking 5 11-21-2007 10:41 PM
H:Problem in IPW2200 connect to WEP network Fortuner Slackware 5 09-23-2007 09:53 AM
Can't connect to my network using WEP hegomo Linux - Wireless Networking 3 08-02-2006 11:22 PM
Can't Connect To WEP Wireless Network MailleMan Linux - Wireless Networking 5 05-23-2006 06:06 AM
How to get on a 40 bit WEP encrypted wireless network with an Intersil Prism2 card? msouden Linux - Wireless Networking 1 11-03-2003 08:02 AM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration