LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-24-2004, 11:34 PM   #1
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Rep: Reputation: 0
Cannot activate network device


Cannot activate network device

I'm new in Linux. I got problems when try to connect to Internet.

I just installed Redhat 9. I have two Ethernet cards in the linux box, a NC100 and a built in VT6120. Both of them seems working fine (I can connect to another Win2000 box and ping each other). However, if configured as "Automatically obtain IP ... (dhcp)), both of them cannot be activated and got error "cannot activate network device eth0/1 (Determining IP information for eth0/1... failed)". By the way, when I start redhat-config-network I got errors like "Static routes file eth0 is invalid", actually I leave the "route" page empty.

If select "Statically set IP addresses" and set IP as 192.168.0.1 and subnet mask as 255.255.255.0, I'm able to activate them, but I cannot connect to my ISP (via cable modem Motorola SB5100) -- nothing wrong with my cable modem or ISP, I'm using it to post this very question.

The following is some detailed info:
ifconfig eth0:
eth0 Link encap:Ethernet Hwaddr 00:50:BF:EC:5C:53
UP BRADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1943 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX butes:116580 (113.8 Kb) TX bytes:2052 (2.0 Kb)
Interrupt:11 Base address:0x3c00

eth1 Link encap:Ethernet Hwaddr 00:07:95:FB:E14
inet addr:1.1.17.1 Bcast:1.1.17.255 Mask:255.255.255.0
UP BRADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:175 errors:0 dropped:0 overruns:0 frame:0
TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX butes:16405 (16.0 Kb) TX bytes:6259 (6.1 Kb)
Interrupt:5 Base address:0xd800


ifcfg-eth0:
ONBOOT=yes
USERCTL=no
PEERDNS=yes
TYPE=Tthernet
DEVICE=eth0
HWADDR=00:50:bf:ec:5c:53
BOOTPROTO=dhcp

ifcfg-eth1:
DEVICE=eth1
BOOTPROTO=none
HWADDR=00:07:95:fb:e1:d4
TYPE=Tthernet
ONBOOT=yes
USERCTL=no
PEERDNS=yes
NETMASK=255.255.255.0
IPADDR=1.1.17.1

there is no route file for eth0/1


__________________
 
Old 05-24-2004, 11:41 PM   #2
hallamigo
Member
 
Registered: Feb 2004
Location: Utah, USA
Distribution: Debian
Posts: 230

Rep: Reputation: 31
Do you have a router between your cable modem and Linux box? (I'm guessing that you do being that you're pinging other machines.)

192.168.0.1 should actually be your gateway (router) so you can't use that IP. Try the following for a static IP setup

IP: 192.168.0.123
Subnet mask: 255.255.255.0
Gateway: 192.168.0.1
DNS: 198.60.22.2

You can usually edit your settings by running netconfig as su.
 
Old 05-25-2004, 01:52 AM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
I presume you have a DHCP server on your LAN. If not, your internal LAN card will not come up as it will not have an IP Address.

Again, if you are planning to use this Liinux system as a Internet Gateway ( of sorts ), better you use a static IP.
 
Old 05-25-2004, 10:00 PM   #4
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
I did not have a router between my cable modem and Linux box. I also tried as what you said (using static IP), but for every web page it failed to resolve the host.
 
Old 05-25-2004, 10:09 PM   #5
hallamigo
Member
 
Registered: Feb 2004
Location: Utah, USA
Distribution: Debian
Posts: 230

Rep: Reputation: 31
Does your cable modem act as a router - for example, does it have more than one port and does it assign internal ips (192.168.x.x) to your computers. If it is just a modem and is not acting as a router then you would need to make your static ip the same as what the ISP is assigning you - something external.

By the way, post the make and model of your cable modem so we can get a better feel for what you're working with.
 
Old 05-25-2004, 10:18 PM   #6
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
I configured another Win2000 box connect to the cable modem with "DHCP" and run "ipconfig" got:

IP: 69.196.11.33
Mask: 255.255.252.0
Gateway: 69.196.8.1
DNS suffix: Mtnk.phub.net.cable.rogers.com
 
Old 05-25-2004, 10:20 PM   #7
hallamigo
Member
 
Registered: Feb 2004
Location: Utah, USA
Distribution: Debian
Posts: 230

Rep: Reputation: 31
How are you connecting multiple computers to the cable modem? Does it have more than one ethernet port on the back? Is it acting as a hub or router?
 
Old 05-25-2004, 10:25 PM   #8
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
I mean not at the same time. It has two ports - one is for USB. Only one can be connected at the same time.
 
Old 05-25-2004, 10:33 PM   #9
hallamigo
Member
 
Registered: Feb 2004
Location: Utah, USA
Distribution: Debian
Posts: 230

Rep: Reputation: 31
Ahhhh, then when you connect your Linux box you need to set it up with the same settings that your Windows box is using.

IP: 69.196.11.33
Mask: 255.255.252.0
Gateway: 69.196.8.1
DNS: 142.146.39.30

These may change depending on whether your ISP (rogers.com?) assigns dynamic ips when you turn off your cable modem and turn it back on. I got 142.146.39.30 as the DNS by pinging ns1.rogers.com. Use netconfig as su to set these changes (and then reboot - sorry, I don't know how to restart the eth0 without rebooting.)
 
Old 05-25-2004, 11:33 PM   #10
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
Yes, my ISP is rogers.com. But it still doesn't work (failed to resolve host)!
 
Old 05-26-2004, 12:45 AM   #11
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
I am not sure if this will apply to you too.

My ISP here in Bombay needs to be intimated about my linux system. Once they activated my account for linux access, I had no problems connecting.
 
Old 05-26-2004, 02:53 AM   #12
eightysixme
LQ Newbie
 
Registered: Nov 2003
Location: cedar rapids, iowa, usa
Distribution: mandrake 10 powerpack
Posts: 22

Rep: Reputation: 15
Windows and Linux File Shares **ADMIN. PLEASE FWD., IF NOT CORRECT CATEGORY**

I noticed your thread, and am having a local networking problem, too! I can browse and execute Linux files from my Win 2K box, but I cannot access my windows shares on the Linux side! As you'll see later in this post, i cannot ping my linux box, yet am able to access shares, but not write. My router (described later) has a firewall, and the settings are set to 'factory'.

From my Win 2K box, I have this info:

machinename/netbios_name=lordconti

workgroup=mdkgroup (the default for mandrake installs)

connection-specific settings (inside the loc. net connx sys tray icon) are represented in the image files included:

http:// file:/home/eightysixme/Deskt...operties 4.bmp http:// file:/home/eightysixme/Deskt...operties 1.bmp http:// file:/home/eightysixme/Deskt...operties 3.bmp

result of 'ipconfig /all <enter>' from terminal:

[IMG]file:/home/eightysixme/Desktop/Win Box Desk Capture.bmp[/IMG]

I have a D-Link I-604 router, and the firmware has been flashed up-to-date.

From my Linux box terminal output:

ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:5A:74:07:79
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::204:5aff:fe74:779/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22345 errors:0 dropped:0 overruns:0 frame:0
TX packets:15342 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13332492 (12.7 Mb) TX bytes:1178378 (1.1 Mb)
Interrupt:3 Base address:0xbc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5148 errors:0 dropped:0 overruns:0 frame:0
TX packets:5148 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:326554 (318.9 Kb) TX bytes:326554 (318.9 Kb)

Last edited by eightysixme; 05-26-2004 at 02:58 AM.
 
Old 05-26-2004, 08:26 PM   #13
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
I contact my ISP, they said technically they don't support Linux. However, it should be possible to make it working on Linux. Any new suggestion?
 
Old 05-26-2004, 09:45 PM   #14
faqs
LQ Newbie
 
Registered: May 2004
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 0
I contacted my ISP, and they said technically they do not support Linux and ask me to go to internet to find solution.
After that, I configured to use DHCP and try again, to my surprising, it's working now! I really do not know why, I suppose my ISP changed some settings for me.

Thanks all guys! especially ppuru and hallamigo. ppuru might pointed out the problem and hallamigo made many effects to help me solve the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 02:55 PM
Network card not working? Cannot activate network device eth0 lifeonitsown Linux - Networking 1 11-17-2005 06:30 AM
cannot activate network device oliwally Linux - Networking 7 07-26-2004 01:42 AM
Can't activate network device ozstar Linux - Networking 15 11-02-2003 05:10 AM
Cannot activate network device... denisec Linux - Networking 5 08-20-2003 09:28 PM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration