LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 04-26-2007, 09:01 PM   #1
xear
LQ Newbie
 
Registered: Apr 2007
Posts: 5

Rep: Reputation: 0
cannot access rsh but ssh is working just fine


hello everyone, I have a problem setting up a cluster using pvm, when I rsh the other computer it keeps on giving me "no route to host" message but when i do ssh its just doing fine. Anybody who has an answer on this would be of a great help. Thanks.
By the way i'm using Red Hat Linux Enterprise AS edition.

Thanks again
 
Old 04-27-2007, 02:06 PM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
It's probably not turned on in your xinetd.

You don't say which RHEL AS you have (1,2,3, 4 or 5).

From my RHEL AS 3 box in /etc/xinetd.d there is a file called "rlogin". This file contains:

Code:
# default: on
# description: rlogind is the server for the rlogin(1) program.  The server \
#       provides a remote login facility with authentication based on \
#       privileged port numbers from trusted hosts.
service login
{
        disable = no
        socket_type             = stream
        wait                    = no
        user                    = root
        log_on_success          += USERID
        log_on_failure          += USERID
        server                  = /usr/sbin/in.rlogind
}
You have to set the "disable = no" for it to actually listen for the connection. rsh requests are answered by rlogin.

Not sure why you're seeing "no route" unless you're also blocking the port (513) in firewall. You should get "permission denied" instead. You might try temporarily disabling iptables and SELinux to be sure neither of those is blocking it. Also if there is a firewall device (bridge/router) between the machines you'd need to verify it is n't blocking the port either.
 
Old 09-05-2007, 09:35 PM   #3
jogjayr
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 0
Similar Problem

I have a similar problem in that i can ssh but i can't rsh or rlogin to a remote computer. I'm setting up a cluster using LAM/MPI and Fedora 7. I can ssh from the client comp to the server. But when i try rlogin it says connection refused or connection reset by peer (it said this second one only once).
I've installed xinetd. But i have no way of telling wheteher it's running. rpcinfo -p doesn't show me xinetd running. All the xinetd related files have been set properly (i hope). What more do I need to do?
 
Old 09-06-2007, 10:22 AM   #4
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
If xinetd is running you'll see it simply by typing "ps -ef |grep xinetd".

To see if it is listening for the port you can try "telnet ip port" where IP is the IP address (you could use 127.0.0.1 for localhost if on the box you're checking) and port is the port associated with the service you want to check (see /etc/services for most "well known" port definitions).
 
Old 09-12-2007, 12:26 PM   #5
jogjayr
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 0
Thanks...i'll try it out...
 
Old 01-10-2008, 11:18 PM   #6
jogjayr
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 0
I know it's a long time since da last post...i was trying to use ssh instead of rsh in the meanwhile but that did not work out....

xinetd seems to be working...i checked using the command u told me to use...i tried telnet to port 514 (rsh) on the client...i'm getting a "No route to host" error...ssh is working
 
Old 02-19-2009, 09:10 AM   #7
mhtrinh
LQ Newbie
 
Registered: Jan 2006
Location: Avignon, France
Posts: 16

Rep: Reputation: 0
I encounter the same problem when I install my Fedora 9 i686 (don't have this problem on my Fedora 8)

The problem is iptables (firewall). Even it seems disabled in "setup" command, or in system-config-firewall, it is NOT !!!! I don't know if this is a bug ...

Here what I got :
Code:
# service iptables status
Table: filter
Chain INPUT (policy ACCEPT)
num  target     prot opt source               destination
1    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
2    ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0
3    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
4    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
5    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
num  target     prot opt source               destination
1    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
num  target     prot opt source               destination

# iptables -F

# service iptables status
Table: filter
Chain INPUT (policy ACCEPT)
num  target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
num  target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
num  target     prot opt source               destination

# iptables-save
# Generated by iptables-save v1.4.0 on Thu Feb 19 15:01:54 2009
*filter
:INPUT ACCEPT [770:71153]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [478:141916]
COMMIT
# Completed on Thu Feb 19 15:01:54 2009

# service iptables restart
iptables: Flushing firewall rules:                         [  OK  ]
iptables: Setting chains to policy ACCEPT: filter          [  OK  ]
iptables: Unloading modules:                               [  OK  ]
iptables: Applying firewall rules: 
                        [  OK  ]
# service iptables status
Table: filter
Chain INPUT (policy ACCEPT)
num  target     prot opt source               destination
1    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
2    ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0
3    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
4    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
5    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
num  target     prot opt source               destination
1    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
num  target     prot opt source               destination
I can telnet from other pc after "iptables -F". But it seems that the firewall is back each time the iptables service restart. The worst is that you don't see the firewall is activated with "usual" firewall config tool !!!

My solution for the moment is disabling the iptables service.

Hope this will help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rsh / ssh woes kevingpo Fedora 11 04-26-2007 07:46 AM
how to setup rsh or configure ssh properly cheeku Linux - Software 5 03-30-2006 08:47 AM
what is rsh and ssh ztdep Linux - Networking 2 07-17-2005 06:28 AM
rsh/ssh from Linux to Solaris sttaft Solaris / OpenSolaris 7 06-16-2004 07:14 AM
rsh access uerden Linux - General 2 02-05-2004 08:39 AM


All times are GMT -5. The time now is 03:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration