LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-04-2008, 10:46 AM   #1
chuck_cts
LQ Newbie
 
Registered: Apr 2008
Posts: 4

Rep: Reputation: 0
can send mails, can't recive them (mailscanner+postfix+dovecot)


Basicly I'm able to send mails from pine, squirrelmail and pocomail
But can't recive mail, all mail endup in postfix queue

here's what I get when trying to send local mail - same thing happens when mail is recived from some other mail server


Code:
Apr  4 16:45:29 johndoe postfix/pickup[11403]: CFC7B460132: uid=0 from=<root>
Apr  4 16:45:29 johndoe postfix/cleanup[11574]: CFC7B460132: hold: header Received: by filolog.fil.bg.ac.yu (Postfix, from userid 0)??id CFC7B460132; Fri,  4 Apr 2008 16:45:29 +0200 (CEST) from local; from=<root@fil.bg.ac.yu> to=<chuck@fil.bg.ac.yu>
Apr  4 16:45:29 johndoe postfix/cleanup[11574]: CFC7B460132: message-id=<20080404144529.CFC7B460132@filolog.fil.bg.ac.yu>
Apr  4 16:45:30 johndoe MailScanner[10828]: New Batch: Scanning 1 messages, 439 bytes
Apr  4 16:45:31 johndoe MailScanner[10828]: Spam Checks: Found 1 spam messages
Apr  4 16:45:31 johndoe MailScanner[10828]: Virus and Content Scanning: Starting
Apr  4 16:45:32 johndoe MailScanner[10828]: Requeue: CFC7B460132.D1015 to 085F646013C
Apr  4 16:45:32 johndoe MailScanner[10828]: Uninfected: Delivered 1 messages
Apr  4 16:45:32 johndoe postfix/qmgr[11404]: 085F646013C: from=<root@fil.bg.ac.yu>, size=713, nrcpt=1 (queue active)
Apr  4 16:45:32 johndoe postfix/local[11591]: warning: connect #1 to subsystem private/dovecot: No such file or directory
Apr  4 16:45:42 johndoe postfix/local[11591]: warning: connect #2 to subsystem private/dovecot: No such file or directory
Apr  4 16:45:52 johndoe postfix/local[11591]: warning: connect #3 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:02 johndoe postfix/local[11591]: warning: connect #4 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:12 johndoe postfix/local[11591]: warning: connect #5 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:22 johndoe postfix/local[11591]: warning: connect #6 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:32 johndoe postfix/local[11591]: warning: connect #7 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:42 johndoe postfix/local[11591]: warning: connect #8 to subsystem private/dovecot: No such file or directory
Apr  4 16:46:52 johndoe postfix/local[11591]: warning: connect #9 to subsystem private/dovecot: No such file or directory
Apr  4 16:47:02 johndoe postfix/local[11591]: warning: connect #10 to subsystem private/dovecot: No such file or directory
Apr  4 16:47:12 johndoe postfix/local[11591]: fatal: connect #11 to subsystem private/dovecot: No such file or directory
Apr  4 16:47:13 johndoe postfix/qmgr[11404]: warning: premature end-of-input on private/local socket while reading input attribute name
Apr  4 16:47:13 johndoe postfix/qmgr[11404]: warning: private/local socket: malformed response
Apr  4 16:47:13 johndoe postfix/qmgr[11404]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Apr  4 16:47:13 johndoe postfix/master[11400]: warning: process /usr/libexec/postfix/local pid 11591 exit status 1
Apr  4 16:47:13 johndoe postfix/master[11400]: warning: /usr/libexec/postfix/local: bad command startup -- throttling
Apr  4 16:47:13 johndoe postfix/qmgr[11404]: 085F646013C: to=<chuck@fil.bg.ac.yu>, relay=none, delay=104, status=deferred (delivery temporarily suspended: unknown mail transport error)
 
Old 04-04-2008, 02:07 PM   #2
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
It seems like you are using dovecot's lda to deliver mail but postfix cannot find the socket to deliver to.

Ensure that you postfix and dovecot configs match with the location of the socket.

If they do try restarting dovecot and see if the socket is created.
 
Old 04-05-2008, 08:10 AM   #3
chuck_cts
LQ Newbie
 
Registered: Apr 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I guess u're refering to setting up the mailbox_command, problem is that I don't have dovecot deliver anywhere (mailbox_command = /usr/libexec/dovecot/deliver - can't find it on hdd)

or it's something else you are refereing to?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure postfix with ClamAV MailScanner Dovecot Ilohamail shipon_97 Linux - Newbie 2 04-22-2010 01:51 PM
STRANGE:mailserver receives mails but is not able to send mails outside nics Linux - Server 1 05-04-2007 12:44 AM
My Postfix mailserver can't send out mails directly! gubak Linux - Networking 4 03-28-2006 07:09 PM
unable to send/recive msg thru thunderbird jabka Mandriva 0 10-18-2005 04:37 PM
How to make postfix send mails for virtual domains? Chowroc Linux - Networking 0 12-24-2004 04:39 AM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration