LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-02-2005, 12:42 PM   #1
johannlo
LQ Newbie
 
Registered: Jul 2005
Location: Melbourne, Australia
Distribution: Fedora
Posts: 16

Rep: Reputation: 0
Can map shared linux drive in XP but CANNOT SEE FILES


Hi all

Just another linux n00b running a fresh install of Fedora core 64. I'm trying to setup Samba to share files with my Windows XP home box and appear to have most of it sorted -

- I can see the linux box in my network neighbourhood
- I can ping bothways
- In XP command line, net /view \\<linuxbox> displays the shared folder on the linux box
- In linux terminal, smbstatus reveals the XP box as logged in
- accounts have been setup for read/write access (verified OK by logging in from Windows)
- same workgroup settings
- I can map the shared folder as a network drive in XP
- Firewalls have been disabled to rule them out

However.... I can't see anything in the shared folder even though there are files in it! If I try to write to it (I've given it write access for the account) it gives me an error saying its either full or write protected. Ditto if I go into the mapped drive in XP command line.

I've been banging my head on the wall for hours now so any advice would be much appreciated. I'm pretty sure that the basic network config is sound - I can ping and log on FFS so it must be something at a higher level. I just don't understand why it just doesn't appear to 'see' any content....

Cheers

Johann

Last edited by johannlo; 07-02-2005 at 12:54 PM.
 
Old 07-02-2005, 05:03 PM   #2
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
You know of course you have to set up Samba users separately (Linux "system" users are not automatically Samba users)? Just my two cents.
 
Old 07-03-2005, 05:37 AM   #3
johannlo
LQ Newbie
 
Registered: Jul 2005
Location: Melbourne, Australia
Distribution: Fedora
Posts: 16

Original Poster
Rep: Reputation: 0
Yes

- user "adm" created as linux user
- user "adm" (both unix and windows names) created as samba user
- <shared directory> set to allow read / write to all users and groups

hence... ???????

To make things worse, I tried duplicating the problem - created another samba share. This time, I couldn't even map to it on the windows side - gave me "share not found on this path" or something similar. However, this new share is
- browseable (you can even browse to it when mapping, but it returns the error above)
- comes up fine with "net view \\<linuxhost>"

?????? Starting to suspect its bloody windows side at fault here....

 
Old 07-03-2005, 06:33 AM   #4
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
To add Samba users you have to use smbpasswd utility.
Code:
smbpasswd -a user
Read 'man smbpasswd'.

Have you tried using swat? It may make life easyer, in particular first time.

Last edited by Emerson; 07-03-2005 at 06:38 AM.
 
Old 07-03-2005, 08:51 AM   #5
johannlo
LQ Newbie
 
Registered: Jul 2005
Location: Melbourne, Australia
Distribution: Fedora
Posts: 16

Original Poster
Rep: Reputation: 0
Yes I've created the user logons in both linux and samba. I did it via GNOME (in fedora core 4) but its definitely there - if you put in

smbpasswd -a username

I get a "duplicate password, password not changed" msg i.e. I've already set it.

Its very confusing as I can read and map, but I can't write or modify. All folders / files have global permissions set.... firewalls off on both machines...
\
Can't run swat as its not installed with this distro. I tried to manually install the swat rpm (its missing from the installation DVD iso) but its not the same version / architecture (I'm running fed core 4 for AMD64) and it says I'm missing some files. Pretty sure there's nothing too wrong with smb.conf anyway, I've tested it via replacing it with some simple scripts (from textbooks etc.) and I run into the exact same problem
 
Old 07-03-2005, 10:15 AM   #6
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Another tool to try is webmin. Or you can compile swat yourself. The sources should be available from your distro's repository.
 
Old 07-04-2005, 03:14 AM   #7
johannlo
LQ Newbie
 
Registered: Jul 2005
Location: Melbourne, Australia
Distribution: Fedora
Posts: 16

Original Poster
Rep: Reputation: 0
FIXED

FIXED!!!!! YAY!!!!

Problem is the SELinux security policy implemented as a new process in FC4 (hence explaining why none of the Samba docos I read mentioned it...)

Turned it off, all good!

I knew it wasn't my Samba config!!! (I've spent enough years reading txt config files in good old DOS to back my judgement w/ pseudo-code!)

Thanks anyway and take note if you ever use FC4.....

Cheers!
 
Old 08-01-2005, 10:23 AM   #8
MbowerARA
Member
 
Registered: Jan 2005
Location: Raleigh, NC
Distribution: Debian
Posts: 35
Blog Entries: 1

Rep: Reputation: 15
This is wierd....

I have checked all of those config files and the name was not in there, just localhost. I am guessing that it is still pulling the name from DNS. Is there a command to flush DNS or is this something that will work itself out when the DHCP renews? Thanks again!!
 
Old 11-16-2005, 12:02 PM   #9
karsteb
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Rep: Reputation: 0
OK, johannlo. Seems I have the same problem: Cannot see or create files using samba or ftp. Seems they just diappeared from the windows explorer view. How did you go about turning off the SELinux security policy?
 
Old 11-16-2005, 12:20 PM   #10
karsteb
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Rep: Reputation: 0
OK, I found something. Just ran the command setenforce 0 to disable SELinux enforcing temporarily and then turned it back with setenforce 1 after I finished my smb session.

Seems you also can do it permanently by editing /etc/selinux/config and change SELINUX=enforcing to SELINUX=permissive. Then reboot or something. Seems there may potentially be some mess to clean up if you disable it completely.

For more info, see http://fedora.redhat.com/docs/selinu...-securitylevel

Brgds Karsten Breivik
 
Old 11-16-2005, 04:42 PM   #11
johannlo
LQ Newbie
 
Registered: Jul 2005
Location: Melbourne, Australia
Distribution: Fedora
Posts: 16

Original Poster
Rep: Reputation: 0
Selinux....

Yes I have made no attempt to reconcile SELinux with samba - I'm just running a home network and I'm behind a router so with linux, iptables, + firewall on router (I know its pretty barebones) + NAT, I figure if someone can hack through that then they deserve to be in my little sh*tbox

To be honest my windoze box is much more vulnerable! (though its not running any listening services e.g. ftp or ssh).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Map network for shared folders. :King_58: Linux - Newbie 2 09-26-2004 03:41 PM
Linux map network drive across internet Linux6574 Linux - Networking 6 04-13-2004 12:01 AM
Seeing Shared FAt32 drive on Linux / XP deejayqf Linux - Networking 4 01-15-2004 11:11 AM
Shared drive Win - Linux nightowl Linux - Networking 2 11-20-2003 07:26 AM
How do I find my xp/linux shared drive? pizarro Linux - Newbie 1 11-02-2003 06:04 AM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration