LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can i tunnel http via ssh without setting up a http proxy? (http://www.linuxquestions.org/questions/linux-networking-3/can-i-tunnel-http-via-ssh-without-setting-up-a-http-proxy-777838/)

ginda 12-24-2009 03:21 AM

Can i tunnel http via ssh without setting up a http proxy?
 
Hi everyone - Happy holidays, merry xmas

I have tunnelled http port 80 via ssh to a linux box which is running a http proxy on port 80 which has worked for me in the past. But is there a way to do the same but instead of setting a http proxy cannot i not use the servers direct internet connection.

Thanks in advance again :_)

acid_kewpie 12-24-2009 03:30 AM

If I correctly understand your motivations, you just want to use the SOCKS functionality of SSH itself. connect using -D 1234 and then use that as the proxy address itself, and then anywhere you go to in your browser will automatically connect from the remote end.

ginda 12-24-2009 04:03 AM

Thanks for such a quick reply, i have tried what you said just using putty on a windows xp client and it doesnt seem to work. Please see my configuration below.

linux box connected to internet - 192.168.1.10
no firewalls or proxy server configured on this box


windows client - 192.168.1.5
Using putty i have created a connection to 192.168.1.10:22 then using the tunnel section in putty i have the below:
source port=8080
destination=192.168.1.10:8080
Local/Auto


I then config firefox to use manual socks proxy = 127.0.0.1 port 8080

With all the above i still cant get internet access? The linux box is directly connected to the internet.


Thanks in advance again :)

P.S I have just found out that the linux box is using ports 80 & 8080 to serve a proxy server to general internal users. Could this be affecting what i am trying to achieve if so what do you recommend for me to be able to use the servers direct internet connection.

ginda 12-24-2009 04:25 AM

It was my fault - I was not using dynamic port setting

Thanks again for all your help


All times are GMT -5. The time now is 09:22 AM.