LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-06-2005, 07:07 AM   #1
dimsh
Member
 
Registered: Aug 2005
Distribution: Debian, Ubuntu, Fedora
Posts: 74

Rep: Reputation: 15
Can't receive mail after setting up qmail server


Hi all,

I have installed qmail on a dedicated server running RHEL 3.2, also installing vpopmail and setup 1 virtual domain, with SMTP Auth.
It is actually QmailRock Toaster.

My problem is:
I can send emails anywere, but i can not receive emails from any other mail servers (HOTMAIL, YAHOO), although local users can exchange emails together .

Some issues:
all mails sent to local users are re-directed to postmaster email of the same virtual domain telling the the sender is anonymous@v-domain.

the server domain name is registered and bind to its IP, no web hosting is running on the server.

server domain name: host1.domain.com (current server registered domain)
and I did register a Virtual Domain using vpopmail as: host1.domain.com also ( the same as the real domain name)

no MX record is registered to this server.

SMTP server is listening to port other than 25

is there any thing I miss?
and is it a must to have an MX record registered to me to be able to use my mail server?

Last edited by dimsh; 09-06-2005 at 07:10 AM.
 
Old 09-06-2005, 12:38 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Re: Can't receive mail after setting up qmail server

Welcome to LQ.

Quote:
Originally posted by dimsh
SMTP server is listening to port other than 25
Then how are remote servers going to know where to deliver the mail?
 
Old 09-07-2005, 02:26 AM   #3
dimsh
Member
 
Registered: Aug 2005
Distribution: Debian, Ubuntu, Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
Thanks boss ross


After changing the port , all pending messages from yahoo, hotmail have been delivered instantly.

So I did not need MX record, right ?


Many thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qmail -- new accounts can't receive mail, but old accounts can b:z *BSD 1 07-13-2005 12:42 AM
qmail sends but doesn't receive mail ysg08 Linux - Networking 5 01-14-2005 03:01 PM
Qmail preblem, can't receive mail in Outlook... setactive Linux - Software 1 12-20-2003 01:15 AM
qmail fails to receive Outlook RTF mail smukec Linux - General 0 12-02-2003 11:24 AM
mail server fail to send out and receive, help!! littlelittle Linux - Networking 7 03-14-2002 10:26 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration