LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-21-2006, 05:32 PM   #1
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,031

Rep: Reputation: 160Reputation: 160
Can't Mount NFS as Non-Root?


hey all,

have googled and search these forums, but nothing quite matches.

If I try to mount nfs share as non-root, I get:

Code:
#  mount -v -t nfs 192.168.3.2:/ /mnt/tmp
mount: Unable to bindresvport TCP socket: errno 13 (Permission denied)
nfs bindresvport: Permission denied
I had been getting another error (can't quite remember, but ultimately it was illegal port), made some changes and now this error comes up.

Any ideas?

cheers,
 
Old 04-22-2006, 11:12 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
non root users can only mount shares defined in /etc/fstab. add an entry to fstab, and use the "noauto" option to have it not mounted automatically. you would then just run "mount /mnt/tmp" to mount it as any user.
 
Old 04-22-2006, 11:43 AM   #3
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
i think adding the user option will allow it to be accessible/mounted by your user too
 
Old 04-22-2006, 05:18 PM   #4
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,031

Original Poster
Rep: Reputation: 160Reputation: 160
this entry has always been in my fstab:
Code:
192.168.3.2:/		/mnt/nfs		nfs	rw,noauto,user,timeo=14,hard,intr 0 0
no success,

EDIT: my exports file:
Code:
/                              192.168.3.0/24(rw,insecure,sync)

cheers

Last edited by mrclisdue; 04-22-2006 at 05:22 PM.
 
Old 04-23-2006, 03:26 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
it'll be the command you are trying to use. by specifying the FULL mount command you are implying that fstab is ignored. if you only provide the mountpoint then fstab will be used correctly.
 
Old 04-23-2006, 04:08 AM   #6
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,031

Original Poster
Rep: Reputation: 160Reputation: 160
Code:
[laptop@main ~]$ mount /mnt/nfs
nfs bindresvport: Permission denied
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 8 09-22-2006 03:34 AM
Failed to mount the root directory via nfs banner Linux - Networking 2 04-01-2005 02:04 AM
Failed to mount the root directory via nfs banner Linux - Newbie 2 03-30-2005 01:57 PM
no-root user can not mount a remote nfs directory? xiamw Linux - General 3 12-16-2004 09:29 AM
NFS mount without root access rajatgarg Linux - Networking 2 01-23-2004 12:33 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration