LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-01-2003, 06:09 PM   #1
huseyin
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Rep: Reputation: 0
can't connect internet via cable modem after activating an ethernet card


I am using RH9 and not experienced in text mode commands.
What i do is to connect a WEBSTAR cable modem with USB to my pc then i use internet configuration tool. (select ethernet, allow automatic conf.)
Internet connectiżon works fine after this operation

but

when i install an ethernet card and activate it from the same menu, internet freezes.

What is wrong here?
 
Old 11-01-2003, 06:17 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
It is probably changing your default route - see if it changes by running "route -n" before and after activating the network card.
 
Old 11-02-2003, 06:57 AM   #3
anGeR
Member
 
Registered: Oct 2003
Distribution: Slackware 13.37
Posts: 40

Rep: Reputation: 15
Same problem for me. And when I execute route -n I see that the gateway is changed to default.
What should I do so the gateway remains unchanged after activating eth0 ?
 
Old 11-02-2003, 07:25 AM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
You can edit:
/etc/sysconfig/network

and set:
GATEWAYDEV=ethX

Where ethX is the device the default device.
 
Old 11-02-2003, 08:23 AM   #5
linuxJaver
Member
 
Registered: Jul 2003
Location: Jakartax, ID
Distribution: slack9.1+,9.1,rh9
Posts: 203

Rep: Reputation: 30
Hi ppl,

Apropo routing, I've question about it:

I've 2 nics, nic1 connected to cable modem, nic2 connected to a window me box.
From the window me Box I can ping to the linux box visa versa. But I can not browse the interner from within winMe box.

Q1: Wut should I put as gateway in winMe the IP of the nic2 or nic1 ?
Q2: Howto route in window me ?
 
Old 11-02-2003, 08:33 AM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
1) nic2
2) Don't worry about routing - you'll just need to set the gateway

You'll also need to setup ip forwarding and ip masquerading to share your connection. If you need help on this please start a new thread to let this one continue on topic for huseyin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to the internet with cable modem and SUSE 9.1 Hrothgar15 Linux - Networking 12 08-16-2005 12:23 AM
How to connect to the internet with cable modem and SUSE 9.1? Hrothgar15 Linux - Newbie 1 08-13-2005 10:09 PM
Cable modem and Ethernet card stonesino Linux - Newbie 2 03-13-2004 06:23 PM
Can't connect to internet via cable modem jaydoubleyou Linux - Newbie 2 09-16-2003 10:02 AM
Cannot connect to internet with cable modem debPandra Linux - Distributions 5 07-03-2002 11:37 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration