LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-28-2008, 10:57 AM   #1
fullout-blaine
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Rep: Reputation: 0
can't access computer on LAN from ubuntu laptop while wireless but works wired


The problem: I can't seem to access other computers on my home LAN with my ubuntu laptop while connected wirelessly but it works fine on a wired connection.

Note: I am however able to access the internet wirelessly.


My router: linksys WRT54G v8 (dhcp disabled) (wpa2 personal enabled)


I am trying to ssh into my ubuntu desktop from my ubuntu laptop. The desktop is wired to the router along with a mac (also wired).

I can ssh into the ubuntu deskop from the mac and the laptop when wired but not wirelessly. After a long pause the connection simply times out.

I have adjusted my desktop firewall to let both my wireless and wired ips for my laptop through.

laptop ifconfig output:

eth0 Link encap:Ethernet HWaddr **hidden**
inet addr:192.168.1.102 Bcast:192.168.1.255
Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

eth1 Link encap:Ethernet HWaddr **hidden**
inet addr:192.168.1.103 Bcast:192.168.1.255
Mask:255.255.255.0
inet6 addr: fe80::21c:bfff:fe8e:c358/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:228 errors:37 dropped:700 overruns:0 frame:0
TX packets:223 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:19356935 (18.4 MB) TX bytes:1554362 (1.4 MB)
Interrupt:18 Base address:0x8000 Memory:f8000000-f8000fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:35 errors:0 dropped:0 overruns:0 frame:0
TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2980 (2.9 KB) TX bytes:2980 (2.9 KB)

*************

eth0 is my wired connection
eth1 is my wireless connection


laptop route -n output:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 eth1
0.0.0.0 192.168.1.1 0.0.0.0 UG 100 0 0 eth0

**************

I've spent about 5 hours on this and I haven't gotten anywhere.

I'm not sure if it is a router setting or a problem with the laptop config and I'm out of ideas on where to look next.


Much thanks in advance.
 
Old 03-28-2008, 12:59 PM   #2
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Are you running a firewall program in ubuntu ? Perhaps the wireless (eth1) is in the list of interfaces with port 22 (ssh) blocked.

(Easiest way to check it is connect to internet via wireless and then visit grc.com and do a ShieldsUP! test. It will tell you which ports are closed and open.)
 
Old 03-28-2008, 02:50 PM   #3
fullout-blaine
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
biophysics,

Thanks for the response.

I am running firestarter on both the laptop and the desktop. I assume that you are referring to the laptop.

On the laptop I have the default policy that blocks all incoming traffic (except port 80, etc) and allows all outgoing traffic.

On the desktop (hosts the ssh server) I have opened port 22 only to my internal ip addresses for my mac machine, and both laptop (eth0 and eth1) interfaces.

Shields up shows all stealth from all my computers on a port scan (even if I disabled firestarter, the router contains a firewall that should block port 22 from the internet).

Correct me if I am wrong but I do not believe I have to open my incoming port 22 on the laptop so the laptop can act as an ssh client.

Ideas?
 
Old 03-28-2008, 05:44 PM   #4
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Quote:
Originally Posted by fullout-blaine View Post

Correct me if I am wrong but I do not believe I have to open my incoming port 22 on the laptop so the laptop can act as an ssh client.

Ideas?
Think you are correct.

May be connect with wireless and stop firestarter and try ssh-ing (and browsing to see if it works).
 
Old 03-30-2008, 09:59 AM   #5
fullout-blaine
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I disabled the firewall on the laptop (confirmed by iptables -L) and tried to ssh into the desktop using the wireless connection and got the following message:

Code:
ssh: connect to host 192.168.***.*** port 22: No route to host
I am still able to connect to the internet with this setup.

I turned the laptop firewall on and tried to ssh the desktop and it just times out without connecting.
 
Old 03-30-2008, 10:26 AM   #6
fullout-blaine
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
a clue!

I was looking around in my log files and found the following:

Code:
Mar 30 08:08:31 laptop kernel: [  462.828515] Unknown OutputIN= OUT=eth0 SRC=192.168.***.*** DST=192.168.***.*** LEN=44 TOS=0x00 PREC=0x00 TTL=64 ID=32350 DF PROTO=TCP SPT=33339 DPT=22 WINDOW=5840 RES=0x00 SYN URGP=0
While wirelessly connected, it appears that my laptop is trying to ssh into my desktop using my wired ip address.

Why would the laptop be using an inactive ip address and how do I change it to the active ip address?
 
Old 03-30-2008, 10:44 AM   #7
fullout-blaine
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
solved

Ok, I have solved it.

For those that might have a similar problem in the future, here is what I think was going on.

The network manager (system->administration->network) had both my wired and wireless network loading by default.

When trying to ssh into another computer on my network, the computer was choosing to use the ip address of the wired nic instead of the wireless nic address.

I caught the error by looking in my messages log (system->administration->system log->messages. When I attempted to ssh into another computer I noticed that the source address was the wired ip instead of the wireless ip.

To fix the problem, I set two profiles in my network manager. One for wireless only access and one for wired access. I set the wireless profile to the default and rebooted the computer (you could probably just restart the networking system but I don't know how to do that off the top of my head). After the reboot, sshing into a computer on the local network works.


My thanks to biophysics for the assistance.


Regards,

Blaine
 
  


Reply

Tags
networking, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gutsy wireless connection does not work/ wired works aio85 Linux - Newbie 5 01-14-2008 01:14 PM
Wired Linksys router - works...wireless-g no go. mynameshagop Linux - Newbie 11 01-11-2006 06:10 AM
how can I get a wired and wireless computer to talk to each other r_squared Linux - Wireless Networking 3 06-26-2005 11:17 AM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 05:37 AM
wired computer sniffing wireless router drkshadow Linux - Wireless Networking 0 11-24-2004 02:31 AM


All times are GMT -5. The time now is 07:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration