LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-19-2003, 03:34 PM   #1
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Rep: Reputation: 0
Unhappy Can't see WebServer from outside... Can see WebServer locally as http://localhost


I can't reach a domain on newly setup Redhat Linux webserver at my office

IBM Netfinity 3500
Dual P-II 266 CPU's
128mb RAM
9gb SCSI HD

Redhat Linux 7.1
Apache version 1.3.19

Anyone have any idea why I can't reach the domain:domainz.com-
I can browse to the default Apache web page on the local box at :
[localhost] and [127.0.0.1] and the static IP [36.116.72.105]

Note: I have a DSL Internet connection with 3 IP addresses (let's say 36.116.72.103, 104 and 105). I've switched some numbers around so the actual IP addresses are not shown to the whole world.

I go home and can't reach [domainz.com]. I can ping [36.116.72.105] just fine. I'm also running WebMin web based management software that listens on port 10000 and I can get to that login page by going to :

[domainz.com:10000]
Any ideas. I think it has something to do with DNS but I'm lost.

Goto [66.227.123.217/Network.gif] to see network layout

Supporting setup information already documented in this thread.
[threadid=75356]
 
Old 08-19-2003, 03:38 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
That domain resolves to:
202.46.160.52

I think you should ask your dns registrar to update the entry.
 
Old 08-19-2003, 03:50 PM   #3
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
I didn't put the real domain or IP's up on the forum

Note: I have a DSL Internet connection with 3 IP addresses (let's say 36.116.72.103, 104 and 105). I've switched some numbers around so the actual IP addresses are not shown to the whole world.
 
Old 08-19-2003, 03:51 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Do you have any firewalls running?
 
Old 08-19-2003, 03:53 PM   #5
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
Not that I know of. Default installation of RH 7.1
 
Old 08-19-2003, 03:53 PM   #6
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
Hope you don't mind, just sent you an email...
 
Old 08-19-2003, 04:00 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
no problem - got the e-mail. It looks like a firewall isse to me. RH 7.1 uses ipchains. Take a look to see if there are any firewall rules there:
ipchains -L

Also take a look on your router to make sure you have allowed port 80. You may want to check with your ISP to see if their terms of service permit you running a web server.
 
Old 08-19-2003, 04:10 PM   #8
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
I hope I can do these things remotely, I'm at home using the web based mgmt tool (WebMin). This box is not behind the router.

This is what I get:

> ipchains -L
Chain input (policy ACCEPT):
target prot opt source destination ports
ACCEPT udp ------ NS2.ij.net anywhere domain -> any
ACCEPT udp ------ aslan.ij.net anywhere domain -> any
ACCEPT udp ------ anywhere anywhere bootps:bootpc -> bootps:bootpc
ACCEPT udp ------ anywhere anywhere bootps:bootpc -> bootps:bootpc
ACCEPT all ------ anywhere anywhere n/a
REJECT tcp -y---- anywhere anywhere any -> 0:1023
REJECT tcp -y---- anywhere anywhere any -> nfs
REJECT udp ------ anywhere anywhere any -> 0:1023
REJECT udp ------ anywhere anywhere any -> nfs
REJECT tcp -y---- anywhere anywhere any -> x11:6009
REJECT tcp -y---- anywhere anywhere any -> xfs
Chain forward (policy ACCEPT):
Chain output (policy ACCEPT):
 
Old 08-19-2003, 04:12 PM   #9
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
browse to 66.227.123.217/Network.gif

You'll get an idea of the network setup...
 
Old 08-19-2003, 04:30 PM   #10
dmx9595
Member
 
Registered: Jun 2003
Location: Canada,Ontario
Distribution: Debian and Gentoo
Posts: 135

Rep: Reputation: 15
probably firewall..
run: redhat-config-securitylevel
and make sure WWW (http) has been opened. also if your behind a router firewall youll have to open the port there as well.. read your router documentation or ask your sysadmin.
 
Old 08-19-2003, 04:33 PM   #11
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
Linux box not behind router.

> redhat-config-securitylevel
sh: redhat-config-securitylevel: command not found
 
Old 08-19-2003, 04:41 PM   #12
dmx9595
Member
 
Registered: Jun 2003
Location: Canada,Ontario
Distribution: Debian and Gentoo
Posts: 135

Rep: Reputation: 15
redhat-config-securitylevel is a gui to config the redhat firewall ( must have and be in X)
lynx@Kv ~:$ whereis redhat-config-securitylevel
redhat-config-securitylevel: /usr/bin/redhat-config-securitylevel /usr/share/redhat-config-securitylevel
 
Old 08-19-2003, 04:48 PM   #13
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
friddick - it does look the firewall rules. Try flushing them:
ipchains -F
 
Old 08-19-2003, 06:27 PM   #14
friddick
LQ Newbie
 
Registered: Oct 2002
Location: Tampa, FL
Distribution: Redhat 7.1
Posts: 12

Original Poster
Rep: Reputation: 0
I flushed the firewall rules...

Now I can browse the default Apache web page

> ipchains -F
> ipchains -L
Chain input (policy ACCEPT):
Chain forward (policy ACCEPT):
Chain output (policy ACCEPT):

Thanks

Frank



Last edited by friddick; 08-19-2003 at 06:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache: http://localhost (work) http://ipaddress (not working) sarmad Linux - Newbie 7 02-05-2013 07:47 AM
My own webserver... TazG Linux - Networking 7 05-30-2007 07:00 AM
apache http://localhost/mysite ---> http://localhost/mysite/index.php how? ilnli Linux - General 8 06-04-2005 03:23 PM
Webserver qball15j Linux - Software 1 02-19-2004 10:18 PM
Setting up Apache HTTP Webserver darklord75 Linux - Networking 6 04-19-2003 05:13 PM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration