LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-20-2009, 08:59 AM   #1
libertinux
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Rep: Reputation: 0
Can't Access CUPS localhost:631???


Hi there,

I'm trying to configure one network printer fom my company, playing arround with cups, but not with good results!!!

I'm trying with FC10, but I can get some info from the printer through a win box ahere it is working fine. In short:

- I can ping its IP from the FC computer
- I know its published name
- I can ping the server where the printer is connected (from the Intranet!)

My first problem is that, when I try to issue:

http://127.0.0.1:631/
or
http://127.0.0.1:631/admin

I have The following error:

Quote:
Network Error (tcp_error)

A communication error occurred: "No route to host"
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time

AND the 127.0.0.1 turns into my ip local address, i.e, 172.xx.xx.xx!??


Please ley me have some HELP on this issue

THANKS
frank
 
Old 05-20-2009, 09:42 AM   #2
libertinux
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi again,

I already tried:

1) changing /etc/cups/cupsd.conf to Allow both localhost and my IP:

Quote:
<Location /admin>
Encryption Required
# Restrict access to the admin pages...
Order allow,deny
Allow From 127.0.0.1
Allow From 172.20.4.32
2) changing /etc/hosts.allow:

Quote:
#
# hosts.allow This file contains access rules which are used to
# allow or deny connections to network services that
# either use the tcp_wrappers library or that have been
# started through a tcp_wrappers-enabled xinetd.
#
# See 'man 5 hosts_options' and 'man 5 hosts_access'
# for information on rule syntax.
# See 'man tcpd' for information on tcp_wrappers
#
cupsd : 127.0.0.1 : ALLOW
cupsd : 172.20.4.32 : ALLOW
Without any results!!
Any more ideas??


TKX
frank
 
Old 05-20-2009, 11:45 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Is the cups daemon running?

To check: "ps -e|grep cups" in a terminal

If not, start the daemon using "cupsd" in a terminal (as root)

If this is the issue, you will then need to setup your init files to start the cups daemon.
 
Old 05-21-2009, 04:45 AM   #4
libertinux
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,

I think the deamon is running. The result of the command is:


Quote:
$ ps -e|grep cups
2471 ? 00:00:00 cupsd

Quote:
$ ps aux|grep cups
root 2471 0.0 0.5 10500 2548 ? Ss 10:15 0:00 cupsd
Please let me have some more ideas...

Thanks
frank
 
Old 05-21-2009, 04:54 AM   #5
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Are you doing this from a different machine? If so, you need to put

172.20.4.31:631 into your browser (or whatever the correct IP is)
 
Old 05-21-2009, 05:35 AM   #6
libertinux
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,

Thanks,

I did try to issue the local IP directly on firefox, both as a user and root (running firefox from a root terminal window). I did allow the local IP on the hosts.allow file (on a box above)


I also checked port 631 on localhost:

Quote:
$ nmap localhost

Starting Nmap 4.68 ( http://nmap.org ) at 2009-05-21 10:49 WEST
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1705 closed ports
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
80/tcp open http
111/tcp open rpcbind
139/tcp open netbios-ssn
443/tcp open https
445/tcp open microsoft-ds
631/tcp open ipp
3306/tcp open mysql
8000/tcp open http-alt

Nmap done: 1 IP address (1 host up) scanned in 0.257 seconds

Now I tried to remove the network cable from my computer and issue 127.0.0.1:631 , and the message "loading..." just stays there without any result. As soon as I connect the cable on the back of the computer, 127.0.0.1 is converted into my local IP and the Network Error message appears!!

Where is 127.0.0.1 converted into my local IP?
Am I right trying to have it running fist without any connection,i.e., 127.0.0.1:631 without cable? I beleive CUPS config is running locally, so it should work, right?



PLEASE some more ideas!!!

Thanks again
frank
 
Old 05-21-2009, 05:58 AM   #7
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
It shouldn't be really. What does "ifconfig" give you?
 
Old 05-21-2009, 06:47 AM   #8
linusali
LQ Newbie
 
Registered: Jul 2007
Location: Dubai
Distribution: Kubuntu - 9.04
Posts: 18

Rep: Reputation: 1
From the error message, I feel like you are behind a proxy, probably a bluecoat. Check your browser setting and remove the proxy setting or add 127.0.0.1 and localhost to the no-proxy list.

Quote:
Network Error (tcp_error)

A communication error occurred: "No route to host"
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time
 
Old 05-21-2009, 10:08 AM   #9
libertinux
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,


YES, I'm behind a proxy. This is a corporate computer from which I have access to the printer when I boot on Win, but not with FC10. Removing the proxy settings on the browser, I have access to CUPS configuration page!!

I'll try to configure the printer now!!


THANKS!!!
frank
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Access Cups Admin @ Http://localhost:631 Perps Suse/Novell 7 07-30-2006 06:30 AM
cups +localhost:631 trscookie Linux - Software 5 12-05-2005 07:15 AM
CUPS http://localhost:631/ LUB997 Linux - Software 1 09-26-2005 07:52 PM
CUPS Problem - can not access localhost:631 ch.keller Linux - Hardware 3 06-06-2005 05:56 PM
can't access http://localhost:631 (for cups printing) TheOneAndOnlySM Slackware 4 10-14-2003 08:01 PM


All times are GMT -5. The time now is 01:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration