LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-12-2003, 11:32 AM   #1
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Rep: Reputation: 0
browsing other http ports


I'm trying to see web sites on other http ports but I keep getting timeout errors. I don't think there's a firewall running on my computer (Suse 8.2) yet my xp computer on the same network has no problems. Any ideas? Thanks!

Eg: http://mysql.hotchilli.net:8080
 
Old 05-12-2003, 11:43 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Connection refused from my connection. Most likely that port is either blocked/not open, etc.

I would double check to see if you have a firewall of some sort. It certainly is acting like it unless you have some misconfiguration in your httpd.conf file for your web server.

Did you restart your webserver after making any changes, cause without the :8080 on the end I get the test page?
 
Old 05-12-2003, 11:57 AM   #3
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks...

It's odd you can't get there either. Our ISP runs the site (it's well looked after and serves people all the time) and there's not meant to be anything really on the default port, as you saw.

I have two PCs here on a LAN that's behind a firewall. Across that, to the Internet is where the web server is. The Windows PC next to me can get to the web server on 8080 fine (I just checked again now) which makes me think that there's no problems between the XP computer, the LAN firewall and the web server.

It's only when I use this Linux computer I can't get there..?
 
Old 05-12-2003, 12:40 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by Ian Fleeton
It's only when I use this Linux computer I can't get there..?
Well with that in place, come to think about it, most likely my work connection refuses it due to firewall.

When I connect using my home machine, it appears to be asking for a username and password. So I assume its connecting? There's something goofy on your Linux machine. Do you have a proxy server of some kind you need to specify for you Linux machine that your Windows machine uses on your LAN?
 
Old 05-13-2003, 05:20 AM   #5
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
what sort of error message do you get? I get the username/password prompt here as well so there there must be something in the way. does iptables -L -v report anything (you need to be root to run this).
 
Old 05-13-2003, 05:36 AM   #6
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for helping.

The login screen is what you are meant to see when you connect (it is mysqladmin).

I didn't set anything up specially on the Windows XP computer. LAN settings is set to not automatic, the proxy details are blank and unused. There's some info on importing LMHOSTS (ticked) and something about enabling NetBIOS over TCP/IP, both I don't know much about.

Through YAST I've set up the same no dhcp/subnet/gateway/dns details (except dif IP) for the network card.

linux:/home/ian # iptables -L -v
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Konqueror
http://mysql.hotchilli.net:8080
An error occured while loading http://mysql.hotchilli.net:8080:

Timeout on server
Connection was to mysql.hotchilli.net at port 8080

Mozilla: The operation timed out while trying to connect to mysql.hotchilli.net

Cheers!
 
Old 05-13-2003, 06:47 AM   #7
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
do you have any problems connecting to the 8080

when you say you set no details up for your network card do you mean it is not setup at all? or is it set to DHCP? or is it all set manually and if so are the settings the same as the XP machine.

it maybe also be your routing that is the problem. You don't have an entry for this adsress in your /etc/hosts do you? also check that the /etc/resolv.conf has the same nameserver settings are your XP machine.
 
Old 05-13-2003, 07:08 AM   #8
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
Sorry, I meant "no dhcp" as in static IP . I set the the details up manually. I cannot connect to http://mysql.hotchilli.net:8080 from my Linux comp. I can on the XP.

I can connect to http://mysql.hotchilli.net:80 (default) though on both. The settings are the same as far as I know.

For another test, it seems I can connect to http://webadmin.hotchilli.net:4718 as it forwards me to somewhere else on port 90, but that too ends up in a timeout. (If you do this you should go to a login page for a mail site.)

/etc/hosts does not contain anything for mysql.hotchilli.net
/etc/resolve.conf has the two correct nameservers followed by "search local"

I am having other network problems where I lose my connection. This happens randomly (every few hours) but the port thing is consistent.

Thanks.
 
Old 05-13-2003, 07:24 AM   #9
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
weird

I did get the mail site login after a short delay...

in mozilla you don't have anything setup under edit, preferences, advanced, proxies (i know this has been asked already just want to be sure)

I noticed that address returns pings so if you ping from both machines does ping report the same ip address (this is not an absolute test mind you, they may be running multiple ip's but it is a good start).

what happens if you try to telnet into these ports, do you get any response?

let us know
 
Old 05-13-2003, 07:27 AM   #10
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
i just tried telnet'ing to port 8080 and got rejected but 4718 worked so try that first (8080 maybe expecting some sort of authentification mechanism to be there which might explain why mozilla is having problems)
 
Old 05-13-2003, 07:49 AM   #11
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
Testing mysql.hotchilli.net (217.72.167.34) and webadmin.hotchilli.net (217.72.162.5)

Neither computers get ping responses (even the xp one which works for the web site) from either of those sites. XP gets the same IP addresses when pinging that my Linux computer does when I try the telnet connections.

The Linux comp telnets to port 80 fine but times out on 8080 for mysql.hotchilli.net. For webadmin.hotchilli.net it connects to 4718 fine but times out on port 90 (where the redirect was going to).

Mozilla has nothing set up for proxies.

It seems that 90 and 8080 do not work for Linux but 80 and 4718 do.
 
Old 05-13-2003, 07:55 AM   #12
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
If it helps... Mozilla 1.4a on Windows XP gets there.
I'm running Mozilla 1.4b on Linux. Cheers.
 
Old 05-13-2003, 05:55 PM   #13
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
when you got to 4718 at webadmin did you type anything, try typically GET and hit enter you should get some HTML back to say to typed something wrong. The jump to port 90 may be some sort of auth thing as well, I am not sure what though, the page isn't using SSL or anything so I am not sure, maybe try with a different browser (I am using Mozilla 1.2.1 fwiw) if you have one.

I tried with lynx and could not get through to port 8080, but I did get through to 4718.
 
Old 05-14-2003, 04:21 AM   #14
Ian Fleeton
LQ Newbie
 
Registered: May 2003
Location: Doncaster, UK
Distribution: Slackware 10
Posts: 20

Original Poster
Rep: Reputation: 0
Solved!! Thanks very much for your help and patience!

I switched the IP addresses around on the two computers and then it worked for the Linux and not for Win XP. Seems that the firewall on the LAN is allowing different ports for different IPs so I gotta give the tech guy a call. *phew*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache: http://localhost (work) http://ipaddress (not working) sarmad Linux - Newbie 7 02-05-2013 07:47 AM
Cannot Open Mail Server Ports 25, 110, and 220. Other Ports will open. Binxter Linux - Newbie 9 11-29-2007 02:03 AM
apache http://localhost/mysite ---> http://localhost/mysite/index.php how? ilnli Linux - General 8 06-04-2005 03:23 PM
"socks5" -> "http" proxy protocol, or ssh tunnel to sock5 ? I'm beyond http p vmicho Linux - Networking 2 12-16-2003 05:32 AM
How to seal all the ports except HTTP and FTP sevvice? mkgyl Linux - Security 14 10-27-2001 11:42 PM


All times are GMT -5. The time now is 04:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration