LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-21-2004, 10:05 PM   #1
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Rep: Reputation: 15
Broadcom BCM5788 NetXtreme


Hi, I have this gigabit card on my acer notebook, I was install gentoo and it didn't get my adapter to work so I decided to put Fedora Core 2 and unluckaly it didn't get it either, I'm just so frustrated and my head hurts, I install the broadcom.com driver for linux bcm5700 (it tries to use tg3) but it didn't work either, I just love Linux and with out internet, its practically worlthless. Can anyone help me? Thanks

ps. it does show up with lspci and it does detect the eth0 but tries to use tg3 and it just makes the computer really slow and never detects the dhcp.
 
Old 09-22-2004, 08:42 AM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hope this helps, it is from the info that came with the driver in distrib.txt.

Quote:
Remove tg3 Driver
=================

Many newer distributions and newer kernels may already contain and use the
tg3 driver by default for Broadcom BCM5700 series devices. While tg3 is a fully
functioning driver written by Red Hat, Broadcom recommends users to use
the bcm5700 driver written and tested by Broadcom.

1. Use ifconfig to bring down all interfaces used by tg3, then use `rmmod` to
remove the module if loaded. The following assumes eth0 and eth1 are both
Broadcom devices using the tg3 driver.

ifconfig eth0 down
ifconfig eth1 down
rmmod tg3

2. Now it may be necessary to manually edit your /etc/modules.conf file to
allow the bcm5700 driver to load at boot time instead of the tg3 driver. See
below.


Edit /etc/modules.conf
======================

If there is an alias entry in your /etc/modules.conf file referencing the
tg3 driver, make sure that you replace tg3 with bcm5700. Otherwise, add the
entry below if necessary.

Example:

alias eth0 bcm5700
good luck.
 
Old 09-22-2004, 09:42 AM   #3
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
I've done that and it didn't work, is there anyway to compleately remove it from the kernel, and I didn't do the patch part do you think its really nessesary? Thanks
 
Old 09-22-2004, 12:03 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Quote:
is there anyway to compleately remove it from the kernel
Yes you could recompile the kernel without support for that device.

Quote:
and I didn't do the patch part do you think its really nessesary
Not sure, but I don't think it would hurt. Did you remove the tg3 module before trying to insmod the bcm5700 module? Did you get any errors?
good luck.
 
Old 09-22-2004, 08:50 PM   #5
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
Yes I rmmod tg3 I think and when I modprobe bcm5700 it works, I even deleted my eth0 hardware and when I modprobe bcm5700 it automatically binds the eth0 and puts the right hardware but still dhcp doesn't work. World it help if I install the driver from source insted of the rpm? Please help.
 
Old 09-22-2004, 10:47 PM   #6
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
I compiled the broadcom driver from source and also the patch and it seem it worked fine (I was able to insmod) but as soon as I complied it in the kerner (<M>) and took tg3 away (< >) and rebooted I couldn't modprobe it or insmod anymore and error would occur

(Fatal: Error inserting bcm5700 (/lib/modules/2.6.5-1.358/kernel/drivers/net/bcm5700.ko): Unknown symbol in module, or unknown parameter (see dmesg)).

I open dmesg and this would come out at the end of the large file:

PCI: Setting latency timer of device 0000:00:11.5 to 64
Device not ready. Make sure there is a disc in the drive.
spurious 8259A interrupt: IRQ7
bcm5700: Unknown parameter 'irq'

Plese help me, I don't want to use M$ anymore
 
Old 09-23-2004, 07:50 AM   #7
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
What does your modules.conf look like? Have a look here

http://www.redhat.com/archives/fedor.../msg02945.html

http://www.redhat.com/archives/fedor.../msg03019.html

good luck.

Last edited by Peacedog; 09-23-2004 at 05:29 PM.
 
Old 09-23-2004, 08:20 PM   #8
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
I did find someting wrong in my /etc/modprobe.conf which I'm almost sure that its the same thing than modules.conf, but anyways, now I can modprobe bcm5700 but still when trying to get dhcp it slows/crashes and doesn't work. Why can this happen?
 
Old 09-24-2004, 06:43 AM   #9
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Have you tried bringing the interface down, then back up?

ifconfig eth0 down
ifconfig eth0 up

I'll google around for dhcp problems, meanwhile try my suggestion, as well as, try using a static ip. We need to see if the driver and card are functioning properly.
good luck.
 
Old 09-27-2004, 07:47 PM   #10
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
Yes I've tried does a million and one times and same thing happends I mean it seems that it works but the problem is in the dhcp.

when I do: dhclient eth0
this comes out:

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/eth0//00:c0:9f:42:2b:c3
Sending on LPF/eth0//00:c0:9f:42:2b:c3
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

After I do this the computer gets REALLY slow and all I can do is reboot. Hope this helps people to help me.
 
Old 09-28-2004, 07:20 AM   #11
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
With some googling I found this.

http://tldp.org/HOWTO/Linux+IPv6-HOW...s.html#AEN1281

Can you assign a static ip?
good luck.
 
Old 10-01-2004, 10:43 PM   #12
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
No It didn't work, I tried using a static ip at work and it seem that everything was fine but the computer got really slow and then I couldn't browse the internet or anything. I'll try at home.
 
Old 10-02-2004, 05:41 PM   #13
lramos85
Member
 
Registered: Sep 2003
Location: Riverside, Ca
Distribution: Gentoo, FC3
Posts: 125

Original Poster
Rep: Reputation: 15
I tried at home and it didn't work. I don't really understand the link you gave me, can you explain it a bit more, I'm sorry but thanks alot for all your help.
 
Old 10-02-2004, 06:18 PM   #14
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
The information I've been reading is suggesting you may have an ipv6 problem. The device from the output you've provided is sit0, which is an ipv6 to ipv4 tunnel. I can't explain that to you in depth, as I only just started reading some docs on it while googling your problem. It's just a hunch, but I believe if you remove the tunnel, your problems may be solved. The link is the best info I've seen on doing just that. Another option would be a kernel recompile, eliminating ipv6 all together. I didn't want to encourage you to do that since it may break other programs that may need it. Hope this all make sense.
good luck.
 
Old 10-02-2004, 09:43 PM   #15
netkepala
Member
 
Registered: Sep 2002
Distribution: Red Hat
Posts: 68

Rep: Reputation: 15
I can understand your problem as I was facing a similar problem. RH Linux refused to recognize the broadcom NIC. I did the following :-

1. recompile the kernel with the rpm file (make sure kernel development and development tools are installed under linux installation )

2. bring the eth down and rmmod tg3. did the alias thing under modules.conf

3. Apply the patches

Alternatively just get another NIC for your PC. Get a realtek compatible type (recognized by RH Linux ) which is quite cheap and good.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom NetXtreme Gigabit Ethernet +slack 10.0 lighter Linux - Hardware 1 10-15-2005 10:22 AM
IBM NetXtreme BCM5751F Ethernet card not found dabump Suse/Novell 0 09-13-2005 02:42 AM
broadcom wi-fi nasht Linux - Hardware 3 02-24-2005 03:10 PM
compatibility issues with NetXtreme GB adaptors? linuxspartan Red Hat 0 11-06-2004 01:53 AM
Broadcom on RH 9 danikonig Linux - Hardware 1 04-15-2003 08:13 AM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration