LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-31-2013, 08:32 AM   #1
mosawer
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Rep: Reputation: Disabled
bonding wierd issue


Hello networkers

I configured bonding in a Red Hat (5.5) HP server with 4 NICs ,I did everything fine :
1- /etc/modprobe.conf
:alias bond0 bonding
options bond0 mode=4 miimon=100

2- configured /etc/sysconfig/network-scripts/
:ifcfg-bond0
ifcfg-eth0 (SLAVE=yes , MASTER=bond0)
ifcfg-eth1 (SLAVE=yes , MASTER=bond0)
ifcfg-eth2 (SLAVE=yes , MASTER=bond0)
ifcfg-eth4 (SALVE=yes , MASTER=bond0)

the weird thing is : when I restart the server , at boot it shows that Bringing up interface bond0 is ..... [ok] , but after I login i find out that the server is not connected to the LAN at all (it can not ping any local machine nor other machine in the LAN can ping the server) , but after I restart the network service:
service network restart or
ifdown bond0
ifup bond0

the bond0 is working fine with no errors at all .

why cant bond0 just boot up normally like real interface and got connected immediate ?? why it needs restarting the network service ir put down and then up bond0 .


Please help , your help is highly highly appreciated .



Regards
Mosawer

Last edited by mosawer; 01-31-2013 at 08:41 AM. Reason: words misspelled
 
Old 01-31-2013, 09:23 PM   #2
KinnowGrower
Member
 
Registered: May 2008
Location: Toronto
Distribution: Centos && Debian
Posts: 341

Rep: Reputation: 34
Did the ifcfg-bond0 and file for each nic (ifcfg-ethx) contains the below listed line?
Code:
ONBOOT=yes
 
Old 01-31-2013, 09:55 PM   #3
mosawer
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Dear

Yes , they have this line .

Regards
Mosawer
 
Old 01-31-2013, 10:06 PM   #4
KinnowGrower
Member
 
Registered: May 2008
Location: Toronto
Distribution: Centos && Debian
Posts: 341

Rep: Reputation: 34
Then please show the contents of the files
 
Old 02-01-2013, 12:21 PM   #5
mosawer
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Sorry for delay , here is the contents of the files :

ifcfg-bond0:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
DEVICE=bond0
BOOTPROTO=static
ONBOOT=yes
USERCTL=no
IPADDR=192.168.1.1
NETMASK=255.255.255.0
NETWORK=192.168.1.0
----------------------------
ifcfg-eth0:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
DEVICE=eth0
BOOTPROTO=none
ONBOOT=ye
MASTER=bond0
SLAVE=yes
USERCTL=no
-----------------------------
ifcfg-eth1:
# NetXen Incorporated NX3031 Multifunction 1/10-Gigabit Server Adapter
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no
----------------------------
ifcfg-eth2:
# NetXen Incorporated NX3031 Multifunction 1/10-Gigabit Server Adapter
DEVICE=eth2
BOOTPROTO=none
MASTER=bond0
SLAVE=yes
ONBOOT=yes
USERCTL=no
--------------------------
ifcfg-eth3:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
DEVICE=eth3
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no
=============================
/etc/modprobe.conf:
alias eth0 netxen_nic
alias eth1 netxen_nic
alias eth2 netxen_nic
alias eth3 netxen_nic
alias scsi_hostadapter cciss
alias scsi_hostadapter1 ata_piix
alias bond0 bonding
options bond0 mode=4 miimon=100
###BEGINPP
include /etc/modprobe.conf.pp
###ENDPP
==============================

I hope that helps solve my problem ..

Regards
Mosawer
 
Old 02-01-2013, 07:39 PM   #6
KinnowGrower
Member
 
Registered: May 2008
Location: Toronto
Distribution: Centos && Debian
Posts: 341

Rep: Reputation: 34
Quote:
ifcfg-eth0:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
DEVICE=eth0
BOOTPROTO=none
ONBOOT=ye
MASTER=bond0
SLAVE=yes
USERCTL=no
I think the issue is same, that i have told you to check in my first post.
Code:
ONBOOT=ye
ye != yes

So replace ye with yes and try
 
Old 02-02-2013, 02:24 AM   #7
mosawer
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Chief

I dont think this is the cause because I tried many time , before the configuration I sent above I tried like this :
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
==============
#TYPE=Ethernet
DEVICE=eth0
BOOTPROTO=none
ONBOOT=no
STARTMODE=off
MASTER=bond0
SLAVE=yes
USERCTL=no
#IPV6INIT=no
#PEERDNS=yes
HWADDR=b4:b5:2f:5d:61:34
=====================
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
#TYPE=Ethernet
DEVICE=bond0
BOOTPROTO=static
ONBOOT=yes
STARTMODE=on
USERCTL=no
#IPV6INIT=no
#PEERDNS=yes
#HWADDR=b4:b5:2f:5d:61:34
IPADDR=159.159.9.2
NETMASK=255.255.255.0
NETWORK=159.159.9.0
==========================
I think this is the 20th time im restarting the server , eatch time i remove the ifcfg* files and create new ones ,. If this time I missed to type "yes" correctly I dont think I did the same mistake the 19th times earlier ...
I think it is something related to bonding of module ?? or May be the network service starting before the NIC kernel module was loaded ?

Please advise ...


Regards
Mosawer
 
Old 02-02-2013, 09:52 AM   #8
KinnowGrower
Member
 
Registered: May 2008
Location: Toronto
Distribution: Centos && Debian
Posts: 341

Rep: Reputation: 34
As far as I know, it seems bonding module is working fine. The only thing is some how NIC card/networking is not up automatically after boot. So to fix that one thing is ONBOOT=yes. Even in this file content
Quote:
Chief

I dont think this is the cause because I tried many time , before the configuration I sent above I tried like this :
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
==============
#TYPE=Ethernet
DEVICE=eth0
BOOTPROTO=none
ONBOOT=no
STARTMODE=off
MASTER=bond0
SLAVE=yes
USERCTL=no
#IPV6INIT=no
#PEERDNS=yes
HWADDR=b4:b5:2f:5d:61:34
=====================
ONBOOT=no

As far as my understanding, if NIC is not up after boot, bonding wont work. But when you start manually it works fine. So it seems bonding module is not an issue. It seems NIC card. You can also try to look into the output of dmesg or /var/log/syslog or /var/log/messages may be some error message about NIC/Bonding. It seems silly but check one more thing

The /etc/sysconfig/network file should contain the following line:
Code:
NETWORKING=yes
Hope it helps
 
Old 02-07-2013, 11:01 PM   #9
mosawer
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
All

I had to use this workaround since i had tested all the suggestions you gave me but problem still existed :

I created a script file named S10renetwork in /etc/rc.d/rc5.d & /etc/rc.d/rc3.d as the following :
----------------------------
#!/bin/bash
/sbin/service network restart
sleep 15
----------------------------
problem solved ...


Thanks all for you suggestions and cooperation
Mosawer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC Bonding in Linux issue aparna8877 Linux - General 2 02-02-2012 04:10 AM
bonding issue fernfrancis Linux - Newbie 5 06-16-2011 12:17 AM
RedHat 5.4 bonding issue mauleta Linux - Networking 3 08-06-2010 03:55 PM
Really, REALLY wierd networking issue... bengoodger Ubuntu 8 06-06-2005 06:41 PM
wierd Samba issue artman62 Linux - Networking 2 08-13-2002 07:59 PM


All times are GMT -5. The time now is 04:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration