LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-07-2012, 12:22 PM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Rep: Reputation: 83
bonding (active-backup): conversion takes too long (if any)


Hi!

I set up two nic interfaces to work as a active-backup bond interface.

The interface works normally however while doing some of the tests (brought down the port on the switch at the other end of the link that was connected to the bond's active interface) we realized that the server lost connection.... I had started tailing syslog and could see no messages on it related to the interface. Anyway, the port was brought up again (and the connection wasn't restored with that).

We started tcpdump on both interfaces and we noticed that we could see ARP queries coming out of the active interface and no traffic was comming in... but on the switch we could see the arp request _and_ the arp reply through the same port so it was the server the one that for whatever reason was not processing the packet.

Crappy stuff.

What could be wrong?

It's a ubuntu lenny server (amd64)
 
Old 12-07-2012, 12:23 PM   #2
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Trace from the switch
Code:
050474: Dec  4 22:29:33: IP ARP: rcvd req src 10.140.127.5 ccef.48ce.9539, dst 10.140.127.126 Vlan201
050475: Dec  4 22:29:33: IP ARP: sent rep src 10.140.127.126 0000.0c9f.f0c9,
                 dst 10.140.127.5 ccef.48ce.9539 Vlan201
 
Old 12-07-2012, 02:09 PM   #3
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
By the way, it's not conversion but convergence.
 
  


Reply

Tags
active-backup, bonding, ifenslave, lenny


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Bonding of for fault-tolerance (active-backup) vikas027 Linux - Networking 4 04-03-2013 12:02 PM
[SOLVED] Linux Channel Bonding: active-backup mode rajivdp Linux - Newbie 2 05-17-2011 06:05 AM
Port bonding won't use active-backup, keeps using round-robin jeriryan Linux - Networking 2 12-09-2010 12:39 PM
Bonding driver Issue: Dynamically changing mode (Active-Backup / Broadcast) Mallika-Gautam Linux - Networking 0 09-29-2010 08:41 AM
Do you need STP enabled to run active active bonding one CentOS4? ch19251 Linux - Networking 1 06-17-2009 09:30 AM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration