LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Bonded NICs at host OS (Ubuntu Server) bridged to virtual OS (UServ) in VMware server (http://www.linuxquestions.org/questions/linux-networking-3/bonded-nics-at-host-os-ubuntu-server-bridged-to-virtual-os-userv-in-vmware-server-741166/)

Xiiph 07-19-2009 07:39 AM

Bonded NICs at host OS (Ubuntu Server) bridged to virtual OS (UServ) in VMware server
 
Just something that struck me while working on our virtual servers today.

I have bonded 3 NICs at the host in Ubuntu Server 8.04 LTS. They are using mode 0 for Round-robin. Point is to increase the speed/performance of all the servers, but mainly the fileserver. The fileserver is a virtual server running Ubuntu Server 8.04 LTS on VMware Server 2.0.

1) I noticed the NIC in the slave OS reported link speed as 1000 and Im unable to change it as the NIC (virtual one) doesnt support it. Does this not really matter, as the NIC doesnt exist, and it will run at higher speeds anyway? Or do I have to remove the bond on the host, bridge all 3 interfaces from the host to the slave OS, and then make a bond in the slave OS?

2) While at it, does mode 0 only increase performance on data being sent from the host or does it also increase the available incoming bandwidth?
Been a bit confused regarding that.

Thanks for any help that can be provided!

/X

rexphilipk 10-21-2009 01:04 PM

i'm rex im new to linux server, would like to knw how to do bonding on ubuntu server 9


All times are GMT -5. The time now is 10:48 PM.