LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-25-2006, 01:34 PM   #1
lgs
LQ Newbie
 
Registered: Dec 2005
Location: Costa Rica
Distribution: Debian Etch 4.0 r3
Posts: 21

Rep: Reputation: 1
Bluetooth "pairing" problem on Debian Sarge


I am setting up a dialup networking over a bluetooth link between a Motorola V600 cell phone and Debian Sarge (kernel 2.6.8-2-386). I have done this before with Mandriva 2006LE, but I can't get it working on Debian.

I believe the bluez bluetooth stack is compiled into this kernel. Other necessary daemons (l2cap and usbcore) are loaded as modules and are shown with lsmod.

I have it ALMOST working. I can detect the phone by running "hcitool inq" on the command line. I can get the list of dialup networking services provided by the phone with "sdptool search DUN".

However, when I try to connect to the Internet using pppd (as root) and my chat script (the same one I use successfully in Mandriva), "pairing" between the phone and the computer fails.

On the telephone, I get the request to connect and am asked to enter the PIN. After I enter the PIN, the /usr/bin/bluepin "pin helper" program is supposed to put up a dialog box to ask me for the pairing PIN. It does not appear, so I cannot "pair" with the telephone.

I opened /etc/bluetooth/hcid.conf and specified /usr/bin/bluez-pin as the "PIN helper", with no results.

/usr/bin/bluepin is a python script. I can run it directly from the command line (as root). bluez-pin will also run from the command line either as root or regular user. At any rate, I run pppd for this connection as root.
 
Old 06-25-2006, 01:53 PM   #2
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
did you set the security level right?
Code:
security user;
 
Old 06-26-2006, 08:49 AM   #3
lgs
LQ Newbie
 
Registered: Dec 2005
Location: Costa Rica
Distribution: Debian Etch 4.0 r3
Posts: 21

Original Poster
Rep: Reputation: 1
Yes, the secirity level is set to "user" in my hcid.conf file.

The hcid.conf file looks like this:

Quote:
#
# HCI daemon configuration file.
#
# $Id: hcid.conf,v 1.7 2004/12/13 14:16:03 holtmann Exp $
#

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security user;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# PIN helper
pin_helper /usr/bin/bluepin;

# D-Bus PIN helper
dbus_pin_helper;
}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
name "%h-%d";

# Local device class
class 0x3e0100;
# class 0x100000;
# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
iscan enable; pscan enable;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
lp rswitch,hold,sniff,park;

# Authentication and Encryption (Security Mode 3)
#auth enable;
#encrypt enable;
}
rfcomm.conf looks like this:

Quote:
#
# RFCOMM configuration file.
#
# $Id: rfcomm.conf,v 1.1 2002/10/07 05:58:18 maxk Exp $
#

#
# Example:
#
rfcomm0 {
# # Automatically bind the device at startup
bind yes;
#
# # Bluetooth address of the device
device AC:BB:F5:9C:30:00;
#
# # RFCOMM channel for the connection
channel 1;
#
# # Description of the connection
comment "Motorola Phone";
}
 
Old 06-26-2006, 09:18 AM   #4
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
Try uncommenting "#auth enable;"
My hcid.conf look like:
Code:
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #   none - Security manager disabled
        #   auto - Use local PIN for incoming connections
        #   user - Always ask user for a PIN
        #
        security user;

        # Pairing mode
        #   none  - Pairing disabled
        #   multi - Allow pairing with already paired devices
        #   once  - Pair once and deny successive attempts
        pairing multi;

        # PIN helper
        pin_helper /usr/bin/pinwrapper;

        # D-Bus PIN helper
        #dbus_pin_helper;
}

# Default settings for HCI devices
device {
        # Local device name
        #   %d - device id
        #   %h - host name
        name "%h-%d";

        # Local device class
        class 0x3e0100;

        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;

        # Default link mode
        #   none   - no specific policy
        #   accept - always accept incoming connections
        #   master - become master on incoming connections,
        #            deny role switch on outgoing connections
        lm accept;

        # Default link policy
        #   none    - no specific policy
        #   rswitch - allow role switch
        #   hold    - allow hold mode
        #   sniff   - allow sniff mode
        #   park    - allow park mode
        lp rswitch,hold,sniff,park;

        # Authentication and Encryption (Security Mode 3)
        auth enable;
        #encrypt enable;
}
 
Old 06-26-2006, 10:11 PM   #5
lgs
LQ Newbie
 
Registered: Dec 2005
Location: Costa Rica
Distribution: Debian Etch 4.0 r3
Posts: 21

Original Poster
Rep: Reputation: 1
Thanks for the help, binary_y2k2.

Quote:
Try uncommenting "#auth enable;"
No good. When I do that the phone won't ask for the pairing pin, either. "auth enable" is commented out in my Mandriva 2006 setup, and it works.

This problem is extremely frustrating. Why should this break on Debian?
 
Old 06-26-2006, 10:37 PM   #6
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
I'm running Kubuntu (based on Debian) and that config works for me so I don't know why it's not working for you.
Have you tryed coppying the config from Mandriva? (You probably have)
You could try seeing if there are any packages that you need to install "apt-cache search bluetooth"
 
Old 06-27-2006, 10:17 AM   #7
lgs
LQ Newbie
 
Registered: Dec 2005
Location: Costa Rica
Distribution: Debian Etch 4.0 r3
Posts: 21

Original Poster
Rep: Reputation: 1
Yes, I copied the bluetooth config files directly over from Mandriva.

gprs is my main way to connect to the Internet. I am going to try Ubuntu, but I will also continue to look for the problem in Debian.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Debian Sarge release patches security, fixes "serious" problems LXer Syndicated Linux News 0 04-20-2006 05:03 AM
trouble with forcedeth driver (have nvidia nforce chipset) under debian "sarge" baldy1324 Linux - Networking 1 10-17-2005 08:06 AM
"Skin not found" problem from installing Mplayer in Debian/Sarge !!! Blue Jacket Linux - Software 2 10-05-2005 01:58 AM
Debian "sarge"/ NIC problem Franco81 Linux - Networking 1 07-31-2004 01:10 AM
Problem getting XFree86 4.3.0.1 running, debian "sarge" 2.6.6 kernel Motivez Linux - Software 9 06-08-2004 02:45 PM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration