LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-23-2010, 11:32 PM   #1
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
blacklist ipv6 not sticking


hey thanks for stopping by.

So, here is what I tried:

Since I had no aliase in /etc/modprobe.d/, I made one. I have also added entries to blacklist.conf ( even tried blacklist with out the .conf ), added entry to sysctl.conf, and added a no load to my grub.conf ( /etc/default/grub). I am still seeing ipv6 in netstat but not when i check lsmod. Below are my entries:

Code:
cat /etc/sysctl.conf | grep ipv6
#net.ipv6.conf.all.forwarding=1
net.ipv6.conf.all.accept_redirects = 0
net.ipv6.conf.all.accept_source_route = 0
net.ipv6.conf.all.disable_ipv6 = 1
Code:
cat /etc/modprobe.d/blacklist 
blacklist ipv6
install ipv6 /bin/true
Code:
cat /etc/modprobe.d/blacklist.conf | grep ipv6
blacklist ipv6
install ipv6 /bin/true
Code:
lsmod | grep ipv6
#
Code:
cat /etc/default/grub | grep DEFAULT
GRUB_DEFAULT=0
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"
Any ideas why I am still seeing service listing with ipv6?

thanks for the help
 
Old 08-24-2010, 12:26 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,595

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
it might help if you informed us as to what distro & version you are using
and is this a headless server ?
Gnome?
KDE?

if not headless
are you using "network" or " networkmanager" service ?
how are you connecting to the net ?
wired ? - dsl , cable , dial up ?
wireless ?


most distros have a gui setting for this
but with out knowing what you are using .........

and a text only solution varies

RHEL / centOS / fedora do things one way

suse dose it different
ubuntu ? i do not know
 
1 members found this post helpful.
Old 08-24-2010, 12:44 AM   #3
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Original Poster
Rep: Reputation: 51
sorry, I thought /etc/default/grub was a debian -ubuntu thing. Not a headless server. Just plain old ubuntu desktop running gnome ( does that really have anything to do with how ipv6 loads during boot). What I don't understand is how ipv6 can even load up if I have it blacklisted in the grub line. Any help would be appreciated.

Last edited by mrmnemo; 08-24-2010 at 12:50 AM.
 
Old 08-24-2010, 07:27 AM   #4
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
You didn't tell us which version of "ubuntu" you are running, but my guess is 10.04 because in this release handling of IPV6 was moved from a module, into the kernel.

So to disable it add ipv6.disable=1 to your kernel boot line at boot time, or do it in grub by setting the line
Code:
GRUB_CMDLINE_LINUX="ipv6.disable=1"
in /etc/default/grub and then runnning update-grub

Last edited by tredegar; 08-24-2010 at 07:28 AM.
 
1 members found this post helpful.
Old 08-24-2010, 09:35 AM   #5
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Original Poster
Rep: Reputation: 51
Hey thanks, Tredgar!! I forgot to update grub and initramfs. It worked!! Its funny how the little things make a all the difference in the world. I would have thanked you via the post; however, the link to do so is not showing up for me anymore.
 
Old 08-25-2010, 08:43 PM   #6
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Original Poster
Rep: Reputation: 51
Just wanted to close this up.

As per tredegar's advice, ran
Code:
sudo update-grub && update-initramfs -u

Worked great! I find it odd that blacklisting the module vie modprobe.d/blacklist.conf is not working though. I find it even odder that AFTER bnlacklisting via modprobe.d/blacklist.conf, running lsmod | grep ipv6 ( and getting no results ) that I still had services listening on ipv6. Coul;d anyone tell me why that is?

EDIT: Just re-read tredegar's post and notticed that ipv6 is now part of the kernel. Thanks again tredegar!!

Last edited by mrmnemo; 08-25-2010 at 08:44 PM.
 
  


Reply

Tags
blacklist


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BIND9 as forwarder, IPv6 queries from IPv6 forwarders Nonoo Linux - Server 1 11-23-2009 01:57 PM
Blacklist ipv6 to speed up internet connections. Mol_Bolom Linux - Networking 5 10-05-2009 07:26 PM
How to set IPv6 address on IPv6 router tlemons Linux - Networking 3 09-17-2007 01:25 PM
?Odd bug. modprobe.blacklist~ behaves as modprobe.blacklist arubin Slackware 1 11-05-2006 07:08 PM
Settings Not Sticking RySk8er30 Mandriva 4 03-28-2005 11:24 AM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration