LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-27-2007, 02:21 AM   #16
Stuart.Allsop
LQ Newbie
 
Registered: May 2007
Location: Santiago, Chile
Distribution: RH
Posts: 2

Rep: Reputation: 0

I had exactly the same problem, and I've been battling it for days, until I eventually hit on the solution... (I also posted this dame info in another thread here, regarding the same issue)

I tried everything: I checked all over the Internet, and found many people with the same problem, but few seem to have solved it, and when they do, they don't bother posting the solution!

I found several references to checking the named.conf and rndc.conf files, to make sure they refer to the same key, port and localhost.

I found several other references to checking that named really is listening on port 953.

But I found no references to what is ACTUALLY the problem in many cases: Even though the rndc.key matches in named.conf and rndc.conf, and named really is listening on port 953, none of that helps if iptables is blocking the communications!

In my case, the solution was simple (after beating my head against the wall for three days...)

Just tell iptables to allow your system to talk to itself on port 953!

Like this:

# iptables -I RH-Lokkit-0-50-INPUT -p tcp -s 127.0.0.1 -d 127.0.0.1 -j ACCEPT --dport 953

(In my case, I'm using a firewall configuration that sets up the table "RH-Lokkit-0-50-INPUT": it might be different in your case!!! )

The IP address “127.0.0.1” is, of course, the loopback address for the system itself, and usually has the name “localhost”.

Yeah, it seems rather stupid that you have to specifically allow localhost LOOPBACK address to talk to itself on port 953, but that's exactly what the problem was!

If you want to make this permanent, then find out from where iptables loads its default set of rules at boot time, and insert the following line in your iptables file:

-A RH-Lokkit-0-50-INPUT -p tcp -m tcp -s 127.0.0.1 -d 127.0.0.1 --dport 953 -j ACCEPT

This should probably go in probably from /etc/sysconfig/iptables, but if you are not sure then you can look in the init script that launches iptables, like this:

# more /etc/init.d/iptables

Look for a line that says something like "IPTABLES_CONFIG=/etc/sysconfig/iptables". That will tell you where it loads the default configuration from. That's the file you need to edit, and insert the line above at the appropriate point (before the first “REJECT” rule.

I sure hope this helps someone! I know I would have LOVED to have this info three days ago...
 
Old 07-25-2008, 05:03 PM   #17
b14tch31l
LQ Newbie
 
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
rndc: connect failed: ::1#953: connection refused

I recently migrated our primary named and mail server at work, from CentOS 4.6 to 5.2 and received the following error.

rndc: connect failed: ::1#953: connection refused

After reading this among other forums, I had no luck what I then decided to do was look at the old server and noticed the only line in the old servers /etc/hosts was something like

127.0.0.1 host.mydomain.com localhost.localdomain localhost

The new server only had
::1 localhost.localdomain localhost

Once I added the line from the old server and restarted named the problem was fixed. I figure rndc and named ask the localhost who it is and with only an IPv6 line in the hosts, it didn't know it was localhost 127.0.0.1, so had no pointer to bind to.

Thought this may help some of you guys.

Cheers,
 
Old 11-26-2008, 07:29 AM   #18
netweblogic
LQ Newbie
 
Registered: Aug 2008
Posts: 11

Rep: Reputation: 1
Hey Guys,

Thanks for all the suggestions... I think they may have helped.

However, that alond didn't do it. The kicker for me was a good ol' fashioned computer reboot haha!
 
Old 01-11-2010, 05:54 AM   #19
ysna
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
make sure this also

in the named.conf file this part should be there to overcome the problem with 953

controls {

inet 127.0.0.1 port 953
allow {127.0.0.1;} keys { "rndckey";};
};



you can also copy this from the rndc.conf
 
Old 01-02-2014, 07:19 AM   #20
Kinetic69
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
Wink

Did you try telnetting to localhost on port 953 to see if it will connect? Or checking your firewall ruleset?
I stuffed around with this for about 2 hours before I realized I needed to open the port with iptables
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS problem rndc: connect failed connection refused error suchi Linux - Networking 14 05-27-2007 11:51 AM
rndc: connect failed: connection refused jkmartha Linux - Software 0 06-20-2005 01:35 AM
DNS Problem - rndc: connect failed: connection refused krishvij Linux - Newbie 2 04-25-2005 07:40 AM
rndc: connect failed: connection refused Justalk Linux - Software 2 06-28-2004 03:45 PM
rndc: connect failed: connection refused Atroxic Linux - Networking 1 10-24-2003 01:01 PM


All times are GMT -5. The time now is 02:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration