LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-31-2009, 11:53 PM   #1
abhijit_mohanta
LQ Newbie
 
Registered: Apr 2008
Posts: 27

Rep: Reputation: 15
bind problem :bind domain not getting resolved


I have configured bind to create a domain.I see thet domain getting resolved for sometime and then it does not

[root@01hw186078 ~]# nslookup
> server 127.0.0.1
Default server: 127.0.0.1
Address: 127.0.0.1#53
> cdrdomain.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: cdrdomain.com
Address: 172.18.226.254
> cdrdomain.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: cdrdomain.com
Address: 172.18.226.254
> cdrdomain.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: cdrdomain.com
Address: 172.18.226.254
> cdrdomain
^C
[root@01hw186078 ~]# nslookup
> cdrdoamin
;; Got SERVFAIL reply from 172.18.18.152, trying next server
;; Got SERVFAIL reply from 172.18.18.113, trying next server
Server: 172.17.117.46
Address: 172.17.117.46#53

** server can't find cdrdoamin: SERVFAIL
>


you can see in the second nslookup name resolution fails
 
Old 09-01-2009, 12:21 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
It's normal as you're trying to resolve a domain with the named "cdrdoamin".
By the way nslookup is deprecated. You should better use dig.
 
Old 09-01-2009, 01:59 AM   #3
abhijit_mohanta
LQ Newbie
 
Registered: Apr 2008
Posts: 27

Original Poster
Rep: Reputation: 15
I am facing a new problem .I have disabled iptables ,selinux but still not able to access dns from other computers in network.
even- nc (my ip) 53 is not working but nc localhost 53 is working.
Hopefully a firewall problem.
Can anyone give any suggestions.
 
Old 09-01-2009, 02:15 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
If you have disabled iptables, then it's not a firewall problem. Check if named listens on your servers' public IP:
Code:
netstat -tunap|grep 53
 
Old 09-01-2009, 03:09 AM   #5
abhijit_mohanta
LQ Newbie
 
Registered: Apr 2008
Posts: 27

Original Poster
Rep: Reputation: 15
yes it's listening.thts why
nc localhost 53
is working
 
Old 09-01-2009, 03:15 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
localhost is not your public ip. And you didn't post the output of netstat...
 
Old 09-01-2009, 03:30 AM   #7
abhijit_mohanta
LQ Newbie
 
Registered: Apr 2008
Posts: 27

Original Poster
Rep: Reputation: 15
nc [my ip] 53 is also not working

netstat -tunap|grep 53
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 3758/named
tcp 0 0 192.168.122.1:53 0.0.0.0:* LISTEN 2383/dnsmasq
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 3758/named
tcp 0 0 172.18.226.254:36068 172.18.18.167:1533 ESTABLISHED 3495/pidgin
tcp 0 0 ::1:53 :::* LISTEN 3758/named
tcp 0 0 ::1:953 :::* LISTEN 3758/named
udp 0 0 127.0.0.1:53667 127.0.0.1:53667 ESTABLISHED 2257/postmaster
udp 0 0 127.0.0.1:53 0.0.0.0:* 3758/named
udp 0 0 192.168.122.1:53 0.0.0.0:* 2383/dnsmasq
udp 0 0 0.0.0.0:53603 0.0.0.0:* 3758/named
udp 0 0 0.0.0.0:5353 0.0.0.0:* 2343/avahi-daemon:
udp 0 0 :::53678 :::* 3758/named
udp 0 0 ::1:53 :::* 3758/named
udp 0 0 :::53477 :::*


I have hosted httpd service (apache on my computer).It could be accessed by other computers in network.But I m not able to find why bind is not exposed to the network even after disabling firewalls,selinux.

Last edited by abhijit_mohanta; 09-01-2009 at 03:32 AM.
 
Old 09-01-2009, 03:37 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,885

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
It looks like dnsmasq is running and listens on port 53. If you want to use bind you should disable dnsmasq and make sure it's not starting on boot.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind problem for one domain name crocodanser Linux - Networking 15 05-26-2009 04:00 PM
Bind problem: config files are missing after re-install bind 9.5 on Fedora Core 8 elvisious Linux - Software 1 07-15-2008 07:49 PM
DHCPD is updating BIND with <host>.<domain>.<domain>. diabelek Linux - Networking 15 10-11-2007 05:58 AM
Setup BIND for Local Domain and hosting domain ALInux Linux - Networking 4 12-19-2006 02:26 AM
Cant get entry in bind to work with domain.com instead of www.domain.com pxes351 Linux - Networking 12 05-09-2005 06:20 AM


All times are GMT -5. The time now is 08:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration