LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   BIND DNS resolution problems (http://www.linuxquestions.org/questions/linux-networking-3/bind-dns-resolution-problems-397782/)

dougz 12-30-2005 01:09 AM

BIND DNS resolution problems
 
Hi.

I need some help with BIND DNS resolution. I am running BIND DNS 9.2.4 configured straight out of the box with RHEL 4 on 2 servers that will provide name resolution services for our Internet customers.

Everything is working fine except when I query www/yahoo/com or www/microsoft/com. Those servers take anywhere from 2 to 4 seconds to query and can time out on occasion. There may be others but these are the ones that I know about.

I have another DNS box (Win2k3) on the network as well for my internal customers. www/yahoo/com and www/microsoft/com resolve instantaneously when using the MS DNS server. All of the servers are pointed to the same upstream DNS servers. If I use the upstream DNS servers, those domains resolve instantaneously as well.

I also noticed that if I try just yahoo.com or microsoft.com resolution is immediately. In addition, I have tried Firefox and IE for a browser and both behave identically when asked to fetch those websites. This problem occurs on both RH/BIND servers.

The RedHat support team suggested that I disable IPv6 on the boxes and then reboot. They walked me through the process and unfortunately the problem persists.

Note that the the / slashes in the URLs are not . due to a posting limitation for newbies to LinuxQuestions.org.

Any ideas?

Thanks in advance.

Regards,

Doug.

ankscorek 12-31-2005 01:35 AM

did u add this line in your
/etc/resolv.conf
nameserver 127.0.0.1<or your own ip address>

peter_robb 01-01-2006 12:58 PM

Try adding more debug info when you start bind..

From man bind..
-d debug-level
Set the daemon's debug level to debug-level. Debugging traces
from named become more verbose as the debug level increases.

-f Run the server in the foreground (i.e. do not daemonize).

-g Run the server in the foreground and force all logging to
stderr

firefox2501 01-02-2006 03:31 PM

Also check your forwarders line in your /etc/named.conf.

If that line does not point to the next upstream DNS server, then all of your requests are going directly to the root servers, which probably accounts for the delay in response time.

Format would be:
Code:

options {
        forwarders { <IP of Primary Upstream DNS>; <IP of Secondary Upstream DNS>; };
        }


Hope this helps


All times are GMT -5. The time now is 10:52 PM.