LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 12-20-2001, 06:33 PM   #1
Seneka
LQ Newbie
 
Registered: Dec 2001
Location: miami
Distribution: Redhat 7.2
Posts: 2

Rep: Reputation: 0
Question BIND DNS client problems --unknown host


hey guys. newbie here so sorry if this is a stupid question. searched through forums and couldnt find anything that helped.

I am running 3 linux boxes in a local lan. All 3 connected to a switch which is connected to a router out to the internet via dsl, with one static ip.

Now i set up a DNS server with BIND 9.1, that seems to work on the DNS box itself. On the DNS box i have the DNS server set to 127.0.0.1 and it can find all internet sites and ping hosts and ips. So all seems well. I can also ping the other boxes on my lan by their ips and also by their hostnames from this box only.

now on another machine in my lan, in this case my database server, i cannot ping hostnames either on the internet or on my local lan. i can ping IP addressess on both my local lan and on the internet.

My clients resolv.conf file has
nameserver 192.168.0.203 (local ip of my DNS linux Box). If i change this ip to my ISPs DNS all works well including netscape.

On my client box when i try to ping www.yahoo.com i get an unknown host error. Im guessing that it cannot find the DNS server although i dont know why.

Here are my conf and zone files from my DNS box.

------------------------------------------
named.conf
------------------------------------------

// generated by named-bootconf.pl

options {
directory "/var/named";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
//query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { any; } keys { gabe; };
};
zone "." IN {
type hint;
file "named.ca";
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "gabadoo.com" {
type master;
notify no;
file "zone/gabadoo.com";
};

zone "0.168.192.in-addr.arpa" {
type master;
notify no;
file "zone/0.168.192";
};

include "/etc/rndc.key";

-------------------------------------
resolve.conf
-------------------------------------

domain gabadoo.com
nameserver 127.0.0.1

-------------------------------------
zone/gabadoo.com
-------------------------------------

$TTL 1D
@ IN SOA dns.gabadoo.com. hostmaster.gabadoo.com. (
2001122001 ; serial, todays date + today's serial num
3600 ; refresh, seconds
900 ; retry, seconds
1209600 ; expire, seconds
43200 ; minimum, seconds
)

IN NS ns.gabadoo.com.
IN A 192.168.0.203
localhost IN A 127.0.0.1

dns IN A 192.168.0.203
ns IN A 192.168.0.203
data IN A 192.168.0.200

---------------------------------------
zone/0.168.192
---------------------------------------

$TTL 1D
@ IN SOA dns.gabadoo.com. hostmaster.gabadoo.com. (
2001122001 ; Serial
28800 ; Refresh
14400 ; Retry
3600000 ; Expire
43200 ; default_ttl
)

IN NS ns.gabadoo.com.

203 IN PTR ns.gabadoo.com.
200 IN PTR data.gabadoo.com.
203 IN PTR dns.gabadoo.com.

-----------------------------------------
var/log/messages (when named is started)
-----------------------------------------

Dec 20 18:30:33 root named[2223]: starting BIND 9.1.3
Dec 20 18:30:33 root named[2223]: using 1 CPU
Dec 20 18:30:33 root named[2225]: loading configuration from '/etc/named.conf'
Dec 20 18:30:33 root named[2225]: the default for the 'auth-nxdomain' option is now 'no'
Dec 20 18:30:34 root named[2225]: no IPv6 interfaces found
Dec 20 18:30:34 root named[2225]: listening on IPv4 interface lo, 127.0.0.1#53
Dec 20 18:30:34 root named[2225]: listening on IPv4 interface eth0, 192.168.0.203#53
Dec 20 18:30:34 root named[2225]: command channel listening on 127.0.0.1#953
Dec 20 18:30:34 root named[2225]: running

--------------------------------------------
--------------------------------------------

Thanks in advance for the help, i will try to be around this board as much as i can to help clear up any info u may need to help with the problem.
 
Old 12-21-2001, 06:57 AM   #2
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Rep: Reputation: 30
Did you have a look at your firewall? Make sure you opened up udp port 53 on your local interface/ip. Maybe do some kind of nslookup from your clients and then having a look at /var/log/messages will get you somewhat further..

To make sure BIND is listening on your local interface also do an

netstat -anlup

Steave.
 
Old 12-21-2001, 04:26 PM   #3
Seneka
LQ Newbie
 
Registered: Dec 2001
Location: miami
Distribution: Redhat 7.2
Posts: 2

Original Poster
Rep: Reputation: 0
tried netstat

when i ran netstat -anlup this is what i got:

--------------------------------------------


Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 0.0.0.0:32768 0.0.0.0:* 744/rpc.statd
udp 0 0 0.0.0.0:32770 0.0.0.0:* 1775/named
udp 0 0 0.0.0.0:920 0.0.0.0:* 744/rpc.statd
udp 0 0 192.168.0.203:53 0.0.0.0:* 1775/named
udp 0 0 127.0.0.1:53 0.0.0.0:* 1775/named
udp 0 0 0.0.0.0:111 0.0.0.0:* 716/portmap


Checked my firewall and it doesnt seem to be blocking any ports.
Again my DNS server works for the server machine only. i think i may have a problem with my reverse master zone. I dunno what to do though.
 
Old 12-24-2001, 09:48 AM   #4
xanthium
Member
 
Registered: Apr 2001
Location: Bombay ( INDIA )
Distribution: RedHat 7.x
Posts: 218

Rep: Reputation: 30
LO interface and ur DNS

Hi ,

First thing 127.0.0.1 is loopback interface and so make ur DNS service avilable on ur LAN network interface .

And YES you do need a reverse lookup table.


Regards,
Xanthium.
 
Old 12-28-2001, 04:36 PM   #5
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Rep: Reputation: 30
what about the controls part in your named.conf?
it says
Quote:
controls {
inet 127.0.0.1 allow { any; } keys { gabe; };
};
I would add a line saying
Code:
inet 192.168.0.0/24 allow {any; } keys {gabe; };
I guess this will grant access for any machine from the 192.168.0.0 subnet to your nameserver

Sorry for replying so late, but I haven't been home lately.

HTH Steave.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i m getting the error unknown host while im pinging with the host name gunjan thakkar Linux - General 2 12-14-2004 02:19 PM
Major DNS problems with BIND in freebsd 4.8 release jamminparidise *BSD 2 02-03-2004 10:42 AM
Unknown Host <Linuxmachinename> / Unable to ping by host name nishi_k_79 Linux - Networking 4 11-01-2003 02:24 PM
BIND and DNS Server Problems sicasal Linux - Software 8 07-31-2003 08:43 AM
BIND DNS Problems with Zone file and Config Init-0 Linux - Networking 6 07-30-2003 05:58 PM


All times are GMT -5. The time now is 01:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration