LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 12-16-2009, 05:04 PM   #1
blorpton
LQ Newbie
 
Registered: Apr 2009
Location: Poland
Distribution: debianoids
Posts: 14

Rep: Reputation: 0
b43-fwcutter-no connection with WEP encrypted network while WPA network works


Hi!

There is a strange thing going out there in my box, I've tested b43-fwcutter on wpa-psk encrypted network, and there was no problem connecting (my card is broadcom 4318), recently I was trying to connect to WEP encrypted network without success. Network connection tested on other laptops(vista, xp machines)so there is no possibility that the key isn't valid.
Any suggestions? Maybe you have/had similar problem.

cheers,

blorpton
 
Old 12-16-2009, 08:38 PM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
Which distro are you using?

I had a problem with a broadcom 4306 card and ended up using ndiswrapper and a XP driver. The problem is the later distros have native drivers and you need to black list them.


Larry
 
Old 12-17-2009, 01:47 PM   #3
blorpton
LQ Newbie
 
Registered: Apr 2009
Location: Poland
Distribution: debianoids
Posts: 14

Original Poster
Rep: Reputation: 0
hi!

the distro is ubuntu 9.10, had the same problem on debian though...so basicly, you suggest blacklisting native drivers from kernel, hmmmm, but the driver overall works, with wpa, wpa2 it does, but with wep encryption just connects forever resulting lack of connection....

ndiswrapper, on the other hand, worked for me, funny because i never had to download any other drivers than ndiswrapper itself. after compiling the source and modprobing it was working no bother with my 4318 card. This time for some another strange reason, I am unable to compile it, 'make' ends with several errors unable to continue(yes i do have build-essential and header files installed).

cheers for replay;]
 
Old 12-18-2009, 07:28 AM   #4
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
First I am not familiar with ubuntu. I was surprised though from posts I have seen the later broadcom cards seem to work with native drivers. In my experience if you have any errors you will need to take care of them first.


Larry
 
Old 12-18-2009, 07:03 PM   #5
Wifi-Fanatux
Member
 
Registered: Mar 2009
Location: Northwest
Distribution: LAPTOP->DreamStudio & Saline-Debian
Posts: 70

Rep: Reputation: 19
WEP

Not sure if you are using a network manager, but you need to make sure you are using the correct WEP format either passcode or hexidecimal. Try both formats if you are unsure.
 
Old 12-20-2009, 05:57 AM   #6
blorpton
LQ Newbie
 
Registered: Apr 2009
Location: Poland
Distribution: debianoids
Posts: 14

Original Poster
Rep: Reputation: 0
I've tried it all I'm afraid without a result...network manager just connects forever trying to obtain ip address...
as I said before it works with all wpa flavours though.
Anyway, thanx for your posts guys;]
 
Old 01-25-2010, 03:06 AM   #7
blorpton
LQ Newbie
 
Registered: Apr 2009
Location: Poland
Distribution: debianoids
Posts: 14

Original Poster
Rep: Reputation: 0
ooops!

guess like this was my mistake...thing is livebox router, there is a wee button underneath the router, the 'reg' button. while trying to connect i had to press it to register a new connection. ever since i did, it works flawlessly.....thank you very much all for your interest in my post....
cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
b43-fwcutter thxbai Linux - Newbie 1 08-28-2009 08:46 PM
Cannot connect to WEP encrypted network Innervision Linux - Networking 12 08-20-2009 12:35 PM
Accessing WPA PSK encrypted wireless network from linux firewiz87 Linux - Wireless Networking 4 02-21-2008 01:18 AM
bcm4306 no connect but can see WEP router using b43, fwcutter, F8 tnrooster Linux - Wireless Networking 14 02-05-2008 05:14 PM
How to get on a 40 bit WEP encrypted wireless network with an Intersil Prism2 card? msouden Linux - Wireless Networking 1 11-03-2003 08:02 AM


All times are GMT -5. The time now is 05:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration