LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-24-2009, 08:29 AM   #1
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Rep: Reputation: 15
Automatic reconnection of pppoe


Hi! Since I installed Kubuntu, I noticed my pppoe connection (ADSL) is not automatically reconnecting anymore. I used to have Gentoo and when my carrier went away and then came back again, the pppoe connection used to reconnect without I had to do anything. Now I have to sudo pon dsl-provider very often. Is there any way to have it reconnect by itself automatically after my carrier is back?
Thanks!
 
Old 07-25-2009, 05:35 PM   #2
rtg
Member
 
Registered: Aug 2005
Location: Ukraine
Distribution: Ubuntu 9.04
Posts: 99
Blog Entries: 3

Rep: Reputation: 19
Edit /etc/ppp/peers/dsl-provider and add "persist". This will force pppd to reopen the connection if it is terminated.

You can set the number of seconds to wait before renegotiation by "holdoff <sec>" parameter.

If that does not help, please post your dsl-provider file (removing all sensitive information).
 
Old 07-25-2009, 06:23 PM   #3
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
Persist seems to be already there:

Code:
# Minimalistic default options file for DSL/PPPoE connections

noipdefault
defaultroute
replacedefaultroute
hide-password
#lcp-echo-interval 30
#lcp-echo-failure 4
noauth
persist
#mtu 1492
#persist
#maxfail 0
#holdoff 20
plugin rp-pppoe.so eth0
usepeerdns
user <username>
Thanks for your answer!
 
Old 07-26-2009, 03:19 PM   #4
rtg
Member
 
Registered: Aug 2005
Location: Ukraine
Distribution: Ubuntu 9.04
Posts: 99
Blog Entries: 3

Rep: Reputation: 19
Ok, try setting holdoff to some positive value, say, 10 seconds.

You may not be able to connect immediately after disconnect so this will give some time for link to reappear.

Alternatively, set maxfail to 0 that means unlimited reconnection attempts.
 
Old 07-29-2009, 12:53 PM   #5
rtg
Member
 
Registered: Aug 2005
Location: Ukraine
Distribution: Ubuntu 9.04
Posts: 99
Blog Entries: 3

Rep: Reputation: 19
Ticket is on hold for next 24 hours.
Please reply if you have additional questions.
 
Old 07-29-2009, 06:32 PM   #6
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
My carrier is not disappearing any more so I can't test. I'll have to wait till another failure shows.
 
Old 07-31-2009, 03:21 AM   #7
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
Holdoff is not solving the problem, now I'm trying with maxfail 0.
 
Old 07-31-2009, 10:11 AM   #8
New2Linux2
Member
 
Registered: Jan 2004
Location: Arizona
Distribution: Debian
Posts: 134

Rep: Reputation: 22
Not for nothing, but the # before persist needs to be removed to activate that particular bit. Right now it's just a comment, not an active command.
 
Old 07-31-2009, 11:59 AM   #9
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
In fact there is another persist command which is not commented and it's therefore active. Seems the command persist is not sufficient for some reason...
 
Old 07-31-2009, 12:40 PM   #10
New2Linux2
Member
 
Registered: Jan 2004
Location: Arizona
Distribution: Debian
Posts: 134

Rep: Reputation: 22
Quote:
Originally Posted by Luc484 View Post
In fact there is another persist command which is not commented and it's therefore active. Seems the command persist is not sufficient for some reason...
So there is. My eyes must be failing in my old age. :-|
 
Old 08-20-2009, 02:19 AM   #11
Luc484
Member
 
Registered: Dec 2004
Distribution: Kubuntu
Posts: 62

Original Poster
Rep: Reputation: 15
As far as I see, the problem is solved now! Maxfail did the trick!
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pppoe & pppoe-server warning (solved) ggalvan Slackware 0 02-04-2006 05:58 AM
FC4 wireless reconnection issue. rtozer Fedora 7 12-16-2005 02:37 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM
Orinoco Gold fails reconnection to AP-1000 with promiscuous/ allmulti on RedHat 7.3 mc185 Linux - Wireless Networking 2 02-24-2004 02:30 PM
what option disables automatic disconnection/reconnection of the adsl modem baronlynx Linux - Networking 1 01-22-2004 12:29 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration