LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 09-10-2010, 12:28 PM   #1
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
Question automatic internet configuration lost after update


After running a large update and rebooting a few weeks ago, I found that my internet connection had stopped working. My internal network still worked fine though, so it I know it's not the card itself or its configuration.

After a bit of trial and error I discovered that simply running dhclient brings the connection up again, so it appears that something is interfering with the initial dhcp update to my ISP (or something like that; I'm no expert in this area. )

My usual policy in cases like this is to wait through two or three updates in the hopes that it's just a temporary problem, but it's been a while now and subsequent updates haven't fixed it.

I've tried looking around, but I can't come up with search criteria specific enough to narrow it down to my specific situation. I'm not even sure where to begin looking to diagnose the problem, nor do I know which package update(s) could've affected it.

Any suggestions?

I'm not sure what might be useful, but here's the relevant entry in /etc/network/interfaces. I have it configured with a static internal address, with my router as the gateway.

Code:
# The primary network interface
mapping eth0
        script grep
        map eth0

allow-hotplug eth0
iface eth0 inet static
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1
mtu 7200  #7200 is the maximum for this card

auto eth0
 
Old 09-10-2010, 05:59 PM   #2
ComputerErik
Member
 
Registered: Apr 2005
Location: NYC
Distribution: Debian, RHEL
Posts: 268

Rep: Reputation: 42
I don't get what the problem is, you are saying you use dhclient (which implies a DHCP configuration) but your interface configuration points to being a static IP.

Is your intention to have a static IP address on your PC? Is the case that after starting up the computer you will be at a desktop with no internet access? What is the gateway, a home router, in which case my thoughts would run to an IP conflict since it is most likely also doing DHCP in that range.

Also your IP configuration seems a bit off, did you manually set the MTU and the other additional options?
 
Old 09-10-2010, 06:31 PM   #3
traene
Member
 
Registered: Jan 2005
Distribution: Archlinux, Debian, grml
Posts: 210

Rep: Reputation: 33
Can you try to boot up in a debian based live distro? ie. try grml or sidux, and see how they are configured. They should be able to run out of the box without reconfiguring.
 
Old 09-11-2010, 07:55 AM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Original Poster
Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
Sorry if I was unclear here. I'm not really clear on the proper terminology to use. Up until recently everything always got configured automatically and I never had any problem like this (nothing that wasn't related to the underlying card configuration itself at least).

To attempt to make it clearer, I have two desktops, and they are both connected to my router (wired), which is in turn connected to my cable internet box. The router also allows local networking between the systems. I've statically set their respective addresses to 192.168.1.2 and 192.168.1.3 (on the systems themselves and in the router settings), so that they remain constant on my LAN, but the router uses dhcp to configure its connection to my ISP.

All I really know is that ever since I ran an update on system 2 a few weeks ago, it has failed to establish a connection to my ISP on boot-up. Even pinging well-known sites like google.com returns unknown host errors. The local network, including the nfs shares between the two systems, is not effected and works right from the start.

After I run dhclient on the system, the internet connection works also.

System 1 is as yet unaffected by all this and connects just fine. I've held back on running any updates on it since this problem started.

I suppose then that it's more accurate to say that system 2 is unable to automatically establish a connection through my router's gateway address, or something like that. Why dhclient makes it work, I have no idea. This is beyond my previous experience.

As for my local settings, yes, I set it all up myself a few years ago, according to info gained on the net. Honestly, I'm still not sure I understand all of it, but it's worked just fine up till now. What I read said that increasing the mtu should help speed up the LAN. The maximum mtu thing I discovered through trial-and-error; it's an onboard card and it simply won't accept any value higher than that.
 
Old 09-11-2010, 09:37 AM   #5
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,520
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
For diagnostic purposes, please post the output of
Code:
route -n
ping -c3 75.126.162.205
tracert 75.126.162.205
dig linuxquestions.org
cat /etc/resolv.conf
cat /etc/nsswitch.conf
(75.126.162.205 is linuxquestions.org)
 
Old 09-11-2010, 09:56 AM   #6
ComputerErik
Member
 
Registered: Apr 2005
Location: NYC
Distribution: Debian, RHEL
Posts: 268

Rep: Reputation: 42
It sounds like you are missing DNS in /etc/resolv.conf and running dhclient will pull it from the router. Try adding the following line to your network configuration file:

dns-nameservers 192.168.1.1 x.x.x.x

You can replace x.x.x.x with DNS servers you have from you ISP if you know them.
 
1 members found this post helpful.
Old 09-12-2010, 10:37 AM   #7
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Original Poster
Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
Thanks for the responses. My resolv.conf looks like this. zaq is the domain of my ISP.
Code:
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.1
search zaq.ne.jp
The resolv.conf on my other, working machine simply has this:
Code:
domain zaq.ne.jp
search zaq.ne.jp
nameserver 192.168.1.1
route -n shows this. But of course this is after everything is up and working.
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
Ping and traceroute probably won't show anything unusual unless I reboot and lose the connection again. As I said, everything's fine once I run dhclient.

By "network configuration file" you mean /etc/network/interfaces, right? I'll give it a try, but of course it means I'll have to reboot to see if it works.

I don't know what my primary DNS address would be. It doesn't seem to be listed anywhere in my router settings, so I believe it's set to negotiate it automatically. It's kind of hard to tell for sure though, since the setup interface is all in Japanese.
 
Old 09-12-2010, 11:47 AM   #8
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Original Poster
Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
Well, that seems to have done the trick. I added dns-nameservers 192.168.1.1 to my /etc/network/interfaces and rebooted, and it appears to be working again.

I also compared my interface settings to the ones on my other system (which is a bit newer and less crufty), and I saw that it doesn't have a "mapping" section in it. So I assume it was unnecessary and removed it.

My resolv.conf now only shows nameserver 192.168.1.1, which I guess indicates that it's grabbing the address correctly now. I'm assuming it was dhclient that was searching the ISP domain and adding the extra lines.

I'm still curious about what changed that caused it to break, but I suppose it really doesn't matter. It made me clean up my settings a bit in any case.

So unless you see anything else I should worry about, I'm going to call this resolved. Thanks again!
 
  


Reply

Tags
connection, dhclient, dhcp, internet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost internet connection after update drinkymilk Linux - Newbie 2 06-27-2008 02:18 PM
lost (*some*) internet connections after yum update jake* Linux - General 3 12-18-2006 07:22 AM
how to automatic update fc5 from internet deshkavikas Linux - Software 1 10-08-2006 05:00 AM
internet sharing lost after update Suse 9.2 newtuxuser Linux - Networking 6 03-14-2005 05:46 AM
Automatic Re-configuration of X nethook Linux - Software 0 05-18-2004 08:18 AM


All times are GMT -5. The time now is 08:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration