LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 12-23-2003, 12:21 PM   #1
MadTurki
Member
 
Registered: Nov 2003
Location: Toronto
Distribution: RedHat 9, Mandrake 10, OS X
Posts: 114

Rep: Reputation: 15
Auto loading a NIC module in RH9


I'm running RedHat9 and have an Asus a7v600 with a 3com gigabit card builtin that uses the 3c2000 driver. When I boot up my system the card isn't detected untill I run "insmod 3c2000.o" and then it works fine. How can I get this to load automatically? I tried running "depmod -a" and have "alias eth0 3c2000" in my /etc/modules.conf file.

Thanks for your help in advance!
 
Old 12-23-2003, 01:21 PM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
I would think that you could add the command:

/sbin/modprobe 3c2000

to your /etc/rc.d/rc.local would work. This may not be the best way to do it, but for a workaround it should do fine.

Just be sure that the module name is correct.

slight
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Module Auto-Load: module.conf tricks? m_e_perry Linux - Newbie 3 10-07-2004 05:45 PM
Problem with module auto-loading (load on demand) in kernel 2.6.7 (2.6.x too) Cyb3rPr0 Linux - Software 4 07-02-2004 12:57 AM
Problems loading the module dmfe.o for a davicom nic. adz Linux - Networking 15 09-07-2003 09:44 PM
Finding Module Dependencies...(Still loading...still loading..still loading..HANG!!!) Aeudian Linux - General 3 08-11-2003 03:31 PM
Finding Module Dependencies.....(still loading....Still loading....still loading) Aeudian Linux - Newbie 1 07-28-2003 02:27 PM


All times are GMT -5. The time now is 01:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration