LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-01-2006, 01:33 AM   #1
guy_ripper
Member
 
Registered: Oct 2006
Posts: 80

Rep: Reputation: 15
authenticating an ldap server onto itself


Hi Guys,

I've been able to setup an ldap server and it works at the linux client with no problem. However, I want also that my ldap server would leverage LDAP authentication. What I did was the same steps that I did from the clients since the server is Fedora 5 and I went to setup authentication from the gui. However, after restart (to see the effect of change). Named and system messages bus services takes forever to startup during boot time processes. I found out from googling that problem arises from nsswitch.conf which takes time to read from ldap lines. Problem resolved by omitting ldap entry at nsswitch.conf. I need clarification why this is happenning from ldap server and not from the clients. Are there other way to make this thing works?

thanks..... any weird suggestions are welcome...
 
Old 12-01-2006, 02:10 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
I would assume that it is due to the order in which the services are being started. i'd expect that the message bus would start a lot earlier on than slapd, and possibly the same for named. am i right in assuming that if you restart named once you're up and running that it goes just fine? you could easily push slapd further up the rungs in terms of boot priority, but that could theoretically lead into interdependence issues. but essentially the subsystem is trying to reach an ldap server which is not yet running, unlike the clients which obviously just hit the ldap server fine each time.

I'm not aware of any way to fine tune this behaviour to be honest. if you can't move the slapd service up, i'm not sure what your options are - replacing the nsswitch.conf file automatically once slapd starts? but then, servers aren't designed to boot fast, they;re designed to start up once and stay started!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU usage of Processes when authenticating against Ldap on Rehat Enterprise 4 with MP VioletRain Red Hat 4 01-21-2008 04:43 PM
How could I create policies for a Linux LDAP authenticating for Windows clients? HGeneAnthony Linux - General 1 01-26-2007 08:02 AM
Authenticating Against Active Directory LDAP Question pyotr1 Linux - General 2 09-30-2006 06:25 PM
mail server authenticating to ldap zachts Linux - Networking 1 09-27-2005 12:12 PM
LDAP, VSFTPD Not authenticating. dlublink Linux - Networking 3 01-19-2005 06:49 PM


All times are GMT -5. The time now is 12:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration