LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-04-2008, 12:42 PM   #1
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Rep: Reputation: 0
Ath5k doesnt work.. - Atheros AR2413


Hello everybody,

I've a BIG problem with my new Fedora Core 9 (2.6.25).

I have an Atheros card (AR2413) that is supported by madwifi drivers (http://madwifi-project.org/wiki/Chipsets#a2413).. but unfortunately doesn't work with the new ath5k drivers already compiled in the linux kernel (2.6.25).


So, times ago I installed on my slack madwifi 0.9 and my Atheros card worked fine.. but now I tryed to change distro (Fedora 9) and I've some PROBLEMS.. (strange problems).

I enabled on my 2.6.25 kernel these modules:
Networking --->
Wireless --->
Improved wireless configuration API
Generic IEEE 802.11 Networking Stack (mac80211)

and

Device Drivers --->[*] Network device support --->
Wireless LAN --->
Atheros 5xxx wireless cards support

So.. ath5k is now enabled..

I also enabled all kind of algos for cryptology.. (AES TKIP and so on..)

I tryed to connect with wpa_supplicant but.. doesn't work.. So I decided to cut off WPA-PSK from my AP.. So my AP is now setted with no keys.. then I tryed again to connect on my ap:

/sbin/ifconfig wlan0 192.168.0.5
/sbin/route add default gw 192.168.0.1 wlan0
(these command work well)

but then I got again this error from dmesg:

...
wlan0: authenticate with AP MAC_ADDRESS
wlan0: disassociate(reason=3)

So, what's wrong? I'm going crazy..

Someone can help me please?


PS I also saw this from dmesg | grep ath

ath5k_pci 0000:06:02.0 registered as 'phy0'
ath5k phy0 AR2413 chip found

but phy0.. is not in the ifconfig -a output ...

Thanks in advance.

Last edited by dark_access; 11-04-2008 at 01:13 PM.
 
Old 11-04-2008, 01:22 PM   #2
rvo
Member
 
Registered: Sep 2008
Location: Paraguay
Distribution: Slackware
Posts: 31

Rep: Reputation: 15
What about your ESSID? Try iwconfig wlan0 essid [your essid goes here] an see what happens.
 
Old 11-04-2008, 01:22 PM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
You might try:
http://www.linuxforums.org/forum/wir...edora-8-a.html
 
Old 11-04-2008, 01:43 PM   #4
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
@rvo:
already done..

I tryed all... iwlist, iwconfig, wpa_supplicant, AP without key.. and so on..
No kinda results..


@craigevil: already tryed.. it doesn't work.. But I think that ath5k.. is "madwifi"..So I dont need to madwifi...

Or .. am i wrong?
 
Old 11-04-2008, 06:38 PM   #5
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
I tryed again other ways.. but without any kind of success...

Same same same error..

If someone know something about it.. please let me know.

Thanks
 
Old 11-04-2008, 08:53 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
idk about fedora but in sidux ath5k is in the 2.6.27 kernel, madiwifi has to be installed separately.

On my eee I removed madwifi and modprobed ath5k and it just worked
 
Old 11-04-2008, 09:22 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Ath5k has been in high development mode, and I don't know what kernel version it became sort of "stable". You might have to remove ath5k and install madwifi 0.9.4.1 or whatever the final version was. You might be better off switching to the latest stable 2.6 kernel, if you can. I'm running 2.6.27.3 and it seems OK for ath5k.
 
Old 11-05-2008, 07:52 AM   #8
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Quakeboy02 View Post
Ath5k has been in high development mode, and I don't know what kernel version it became sort of "stable". You might have to remove ath5k and install madwifi 0.9.4.1 or whatever the final version was. You might be better off switching to the latest stable 2.6 kernel, if you can. I'm running 2.6.27.3 and it seems OK for ath5k.
thanks for reply.. I tryed to install madwifi from yum (livna mirror) but it doesn't work...

yum install madwifi kmod-madwifi

it gives me some error (no rpm found..)

So, I tryed to install madwifi (0.9.4) from sources but... also here.. my wifi0 doesn't run
during compiling time is ALL OK!! but.. /sbin/iwconfig wlan0 essid "my" doesn't associate my ath to my ap..

What's wrong?

ah.. I've blacklisted ath5k in modprobe.conf after installing madwifi!

Best Regards.

Last edited by dark_access; 11-05-2008 at 10:42 AM.
 
Old 11-05-2008, 11:50 AM   #9
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
I have the same Atheros device, and my solution was to disable (i.e., blacklist) the ath5k and install the ath_hal snapshot (I use madwifi-hal-0.10.5.6-r3698-20080604). Note that my problem was because I was using a AMD 64bit system, and the 64bit support in the stock madwifi driver for the AR24__ EG chips has not yet been merged into the ath5k driver.

By the way, if you use that snapshot, you'll need to patch the calls to iwe_stream_add_event and iwe_stream_add_point in the ieee80211_wireless.c program to include a reference to a iw_request_info structure as the first argument of each call. I just added a static struct iw_request_info iw_info = { 0, 0}; near the top of the program, and a &iw_info as the first argument. (A real kludge, but it works.)
 
Old 11-05-2008, 12:25 PM   #10
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Quote:
So, I tryed to install madwifi (0.9.4) from sources but... also here.. my wifi0 doesn't run
during compiling time is ALL OK!! but.. /sbin/iwconfig wlan0 essid "my" doesn't associate my ath to my ap..

What's wrong?
My guess would be that you've left out some crucial step. Have you done all of the following in this order before giving up?
Code:
sudo make clean
sudo make
sudo make install
sudo modprobe ath_pci
 
Old 11-05-2008, 02:49 PM   #11
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
@ Quakeboy02: sure.. Done that steps..

@ PTrenholme:
But on my slack i installed madwifi from sources and it worked very well!!
I blacklisted ath5k (and with lsmod i cant see ath5k.. so it's blacklisted!)
but... it doesnt work..

So, where I can find madwifi-hal-0.10.5.6-r3698-20080604?

But i don't understand which changes (which patches) has to be made in the ieee80211_wireless.c.

Thanks.
 
Old 11-05-2008, 03:56 PM   #12
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
You do know that with madwifi you get ath0 and now wlan0.
 
Old 11-05-2008, 09:27 PM   #13
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by dark_access View Post
<snip>
@ PTrenholme:
But on my slack i installed madwifi from sources and it worked very well!!
I blacklisted ath5k (and with lsmod i cant see ath5k.. so it's blacklisted!)
but... it doesnt work..

So, where I can find madwifi-hal-0.10.5.6-r3698-20080604?

But i don't understand which changes (which patches) has to be made in the ieee80211_wireless.c.
</snip>
The snapshots are here: http://snapshots.madwifi-project.org...-hal-0.10.5.6/ where, I notice that there are several more recent snapshots.

Just a moment - let me download the November one an see if it compiles without a patch.

Yes, it does.

So, just go to the snapshot directory, grab the last (r3875) file, unpack it (ark works well), and do the make dance steps described above.

Now I'm going to reboot and see what happens . . .

<edit>
And everything seems to be working fine.
</edit>

Last edited by PTrenholme; 11-05-2008 at 09:35 PM.
 
Old 11-07-2008, 12:30 PM   #14
dark_access
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
Hello,

I think I've solved the problem... I tryed to install the newest snapshot (downloaded from the "PTrenholme link") and it seems that it works (tested on 2.6.27 vanilla kernel).. as soon as possible I'll make some tests.. but i think there will be no problems.
 
Old 11-17-2008, 12:22 PM   #15
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Fedora just updated to a 2.6.27 kernel, and I needed to re-compile and install the driver. So, for what it's worth, here's how I did it:
Code:
# cd madwifi-hal-0.10.5.6-r3875-20081105/
# make -s clean
# make -s
Checking requirements... ok.
Checking kernel configuration... ok.
  Building modules, stage 2.
# make -s install
Checking requirements... ok.
Checking kernel configuration... ok.
  Building modules, stage 2.
# modprobe ath_pci
After which my knetworkmanager icon changed from a screen-with-a-red-x to a "connecting" moving icon, and I was soon automatically connected to my wireless WPA2-protected modem. (knetworkmanager because I mostly use KDE.)

Note: I posted this here not so much for the OP who, when last heard from, seems OK, but for others who may access this thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ath5k/Slackware issues mjjzf Linux - Wireless Networking 5 12-15-2008 04:40 PM
Trying to get ATH5k to work C-Sniper Slackware 2 07-02-2008 10:56 AM
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 12:31 PM
help i cant get my Atheros card to freaking work! asilentmurmur Linux - Hardware 1 03-06-2005 11:37 PM
Atheros Super G don't work spoody_goon Linux - Laptop and Netbook 5 09-26-2004 08:05 PM


All times are GMT -5. The time now is 01:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration