LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 04:58 AM   #1
cranium2004
Member
 
Registered: Feb 2004
Distribution: FC4,RHEL4
Posts: 223

Rep: Reputation: 30
arp problem in pinging host


Hello,
I have pc hostA with 192.168.1.100 connected to pc R1 with eth0:10.1.1.1 and eth1:192.168.1.1 via crosscable when i ping from hosta to R1 request packet goes to R1 but R1 generates packets with srcip=0.0.0.0 and destination ip of R1's eth1=192.168.1.1 and hosta unable to receive reply packet from R1. But if i ping from R1 to hosta packet always goes to hosta and receives reply at R1. What can be the reason is that arp cache problem or what else?
When i send ping packet to R1 from hostA, the arp analysis on my both Linux machines shows that when i did arp -a on hosta and found output that
R1(192.168.1.1) at <incomplete> on eth0
and on R1 nothing is displayed.
When i send ping packet to hostA from R1, the arp analysis on my both Linux machines shows that when i did arp -a on
R1 and found output that
Address HWtype HWaddress Flags Mask Iface
hosta ether 00:08:F1:43:62:91 C eth1
and on hosta
Address HWtype HWaddress Flags Mask Iface
R1 ether 00:08:F1:43:61:C1 C eth0

whats wrong in hosta linux machine?
 
Old 05-16-2005, 11:14 PM   #2
mjsurette
Member
 
Registered: May 2005
Distribution: aptosid
Posts: 55

Rep: Reputation: 18
I don't think that arp is where your problem is. My guess is that you have some routing issues, probably on R1. Could you post the result of route -n on each computer?

Mike
 
Old 05-17-2005, 02:10 AM   #3
cranium2004
Member
 
Registered: Feb 2004
Distribution: FC4,RHEL4
Posts: 223

Original Poster
Rep: Reputation: 30
hello
without seeing your reply and thinking my new question is different than this one i posted what you want in
http://www.linuxquestions.org/questi...readid=324265.
Please kindly check that one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange ARP behavior : A linux server responds to all ARP requests Hdvd21 Linux - Networking 4 10-24-2013 06:02 AM
i m getting the error unknown host while im pinging with the host name gunjan thakkar Linux - General 2 12-14-2004 02:19 PM
Installed 2nd BCM5700 NIC, when Pinging on this subnet receive destination host unrea timhe Linux - Networking 2 05-12-2004 10:52 AM
How to create an proxyarp entry in arp table by using arp command? himalayas Linux - Networking 0 06-04-2003 05:14 AM
'Unreachable Host' when pinging with RedHat 7.1. Help! SadTechie Linux - Networking 1 12-03-2001 05:26 PM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration