LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-03-2009, 03:55 PM   #1
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Rep: Reputation: 15
APACHE will not start, can't bind to IP address


The OS is Fedora 9. The network is working. I'm using Firefox over it. I can ping 192.168.1.100 from other machines. However I can't get Apache to start and it seems to be finding a conflict on port 80.

[~]$service httpd start
Starting httpd: (13)Permission denied: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down

[~]$service httpd restart
Stopping httpd: [FAILED]
Starting httpd: (13)Permission denied: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down

[~]$ifconfig
eth0 Link encap:Ethernet HWaddr 00:48:54:8F:16:B8
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::248:54ff:fe8f:16b8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:166 errors:0 dropped:0 overruns:0 frame:0
TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22296 (21.7 KiB) TX bytes:7634 (7.4 KiB)
Interrupt:17 Base address:0xa000

[/]$lsof -i
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
rpcbind 1732 rpc 6u IPv4 4035 UDP *:sunrpc
rpcbind 1732 rpc 7u IPv4 4039 UDP *:rlzdbase
rpcbind 1732 rpc 8u IPv4 4040 TCP *:sunrpc (LISTEN)
rpc.statd 1751 rpcuser 6u IPv4 4149 UDP *:703
rpc.statd 1751 rpcuser 8u IPv4 4155 UDP *:41347
rpc.statd 1751 rpcuser 9u IPv4 4158 TCP *:41515 (LISTEN)
sshd 2015 root 3u IPv6 5331 TCP *:ssh (LISTEN)
sshd 2015 root 4u IPv4 5333 TCP *:ssh (LISTEN)
avahi-dae 2060 avahi 14u IPv4 5508 UDP *:mdns
avahi-dae 2060 avahi 15u IPv4 5509 UDP *:35095
cupsd 2069 root 4u IPv4 5548 TCP linuxserver:ipp (LISTEN)
cupsd 2069 root 6u IPv4 5551 UDP *:ipp

[/]$ss --listening
Recv-Q Send-Q Local Address:Port Peer Address:Port
0 128 *:41515 *:*
0 128 *:sunrpc *:*
0 128 *:ssh *:*
0 128 :::ssh :::*
0 128 127.0.0.1:ipp *:*


Any ideas or suggestion of what to do next?

Last edited by scotthill; 01-03-2009 at 03:57 PM.
 
Old 01-03-2009, 04:41 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
be root, or configure (or disable) selinux correctly. you're getting permissions issues, not conflicts.
 
Old 01-03-2009, 04:50 PM   #3
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
be root, or configure (or disable) selinux correctly. you're getting permissions issues, not conflicts.
SELinux is disabled. I was SU when the commands were issued. What further did you mean when you said "be root".


From the SELinux config file:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
SELINUX=disabled

Last edited by scotthill; 01-03-2009 at 04:57 PM.
 
Old 01-03-2009, 04:59 PM   #4
lighthousekeeper
LQ Newbie
 
Registered: May 2008
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by scotthill View Post
SELinux is disabled. I was SU when the commands were issued. What further did you mean when you said "be root".


From the SELinux config file:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
SELINUX=disabled
command whoami will let you know who you are
netstat -lnp | grep :80 - will list all of another soft listening port 80
and 'su -' will make you a superuser(=root)
regards.
 
Old 01-03-2009, 05:20 PM   #5
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by lighthousekeeper View Post
command whoami will let you know who you are
netstat -lnp | grep :80 - will list all of another soft listening port 80
and 'su -' will make you a superuser(=root)
regards.
[/]$whoami
root



I tried the netstat command. I don't think it found anything:

[/]$netstat -lnp | grep :80
[/]$


What do you think?

I was SU in the listings of the previous posts. Samba is working now. Everything is running well on this system except Apache. Too bad that's the only thing I need to work.

[/]$service httpd restart
Stopping httpd: [FAILED]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down

Last edited by scotthill; 01-03-2009 at 05:28 PM.
 
Old 01-03-2009, 06:00 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
well that's a different error to what you originally posted, so something was different, and if you run netstat i'm sure you'll see the process on the port then. Also chekc the output of dmesg to see if there's anything nasty popping up in there. That's certainly where you'd see the SElinux errors (although you said it's disabled of course)
 
Old 01-03-2009, 06:53 PM   #7
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
well that's a different error to what you originally posted, so something was different, and if you run netstat i'm sure you'll see the process on the port then. Also chekc the output of dmesg to see if there's anything nasty popping up in there. That's certainly where you'd see the SElinux errors (although you said it's disabled of course)
[/]$dmesg | grep SELinux
SELinux: Initializing.
SELinux: Starting in permissive mode
SELinux: Registering netfilter hooks
SELinux: Disabled at runtime.
SELinux: Unregistering netfilter hooks
[/]$

[/]$sestatus
SELinux status: disabled
[/]$

[/]$dmesg | grep :80
[/]$

Nothing is showing on netstat:

[/]$netstat -lnp | grep :80
[/]$

[/]$service httpd restart
Stopping httpd: [FAILED]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down

I tried to start httpd in telinit 2 and then again in telinit 1 and it still comes up with the same problem, "make_sock: could not bind to address 192.168.1.100:80 no listening sockets available, shutting down"

In the httpd.conf file I changed the specified port from :80 to :8015 and in that case Apache started up just fine.

I removed the Apache server using the System->Admin->Add/Remove Software
rebooted and then reinstalled the software and I'm right back to the same problem.
 
Old 01-03-2009, 07:20 PM   #8
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by scotthill View Post
[/]$dmesg | grep SELinux
SELinux: Initializing.
SELinux: Starting in permissive mode
SELinux: Registering netfilter hooks
SELinux: Disabled at runtime.
SELinux: Unregistering netfilter hooks
[/]$

[/]$sestatus
SELinux status: disabled
[/]$

[/]$dmesg | grep :80
[/]$

Nothing is showing on netstat:

[/]$netstat -lnp | grep :80
[/]$

[/]$service httpd restart
Stopping httpd: [FAILED]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down

I tried to start httpd in telinit 2 and then again in telinit 1 and it still comes up with the same problem, "make_sock: could not bind to address 192.168.1.100:80 no listening sockets available, shutting down"

In the httpd.conf file I changed the specified port from :80 to :8015 and in that case Apache started up just fine.

I removed the Apache server using the System->Admin->Add/Remove Software
rebooted and then reinstalled the software and I'm right back to the same problem.
What does /var/log/messages tell you? What do the apache logs tell you?

Try this...in one window perform:
Code:
root@host# tail -f /var/log/messages
And on another window do:

Code:
root@host# service httpd stop
root@host# service httpd start
If that dosen't tell you anything...do the same but with the apache error logs...

either way...post the outcome.

If it works on port 8015 but NOT on 80; that means that something else is using that port...in which case netstat should tell you what is listening on that port...

-C

Last edited by custangro; 01-03-2009 at 07:21 PM.
 
Old 01-03-2009, 08:41 PM   #9
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by custangro View Post
What does /var/log/messages tell you? What do the apache logs tell you?

Try this...in one window perform:
Code:
root@host# tail -f /var/log/messages
And on another window do:

Code:
root@host# service httpd stop
root@host# service httpd start
If that dosen't tell you anything...do the same but with the apache error logs...

either way...post the outcome.

If it works on port 8015 but NOT on 80; that means that something else is using that port...in which case netstat should tell you what is listening on that port...

-C
In the first window after having run the second window:
Code:
[/]$tail -f /var/log/messages
Jan  3 17:23:34 linuxserver gconfd (root-2788): Resolved address "xml:readwrite:/root/.gconf" to a writable configuration source at position 1
Jan  3 17:23:34 linuxserver gconfd (root-2788): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jan  3 17:26:04 linuxserver gconfd (root-2788): GConf server is not in use, shutting down.
Jan  3 17:26:04 linuxserver gconfd (root-2788): Exiting
Jan  3 17:26:32 linuxserver gconfd (root-2878): starting (version 2.22.0), pid 2878 user 'root'
Jan  3 17:26:32 linuxserver gconfd (root-2878): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jan  3 17:26:32 linuxserver gconfd (root-2878): Resolved address "xml:readwrite:/root/.gconf" to a writable configuration source at position 1
Jan  3 17:26:32 linuxserver gconfd (root-2878): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jan  3 17:29:02 linuxserver gconfd (root-2878): GConf server is not in use, shutting down.
Jan  3 17:29:02 linuxserver gconfd (root-2878): Exiting

In the second window
Code:
[/]$service httpd stop
Stopping httpd:                                            [FAILED]
[/]$service httpd start
Starting httpd: (98)Address already in use: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]
[/]$
Netstat grepping port 80=>
Code:
[/]$netstat -lnp | grep :80
[/]$
netstat verbose:
Code:
[/]$netstat -lnp 
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 0.0.0.0:48941               0.0.0.0:*                   LISTEN      1781/rpc.statd      
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1762/rpcbind        
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      2045/sshd           
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      2099/cupsd          
tcp        0      0 :::22                       :::*                        LISTEN      2045/sshd           
udp        0      0 0.0.0.0:665                 0.0.0.0:*                               1762/rpcbind        
udp        0      0 0.0.0.0:54569               0.0.0.0:*                               2090/avahi-daemon:  
udp        0      0 0.0.0.0:40376               0.0.0.0:*                               1781/rpc.statd      
udp        0      0 0.0.0.0:708                 0.0.0.0:*                               1781/rpc.statd      
udp        0      0 0.0.0.0:5353                0.0.0.0:*                               2090/avahi-daemon:  
udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1762/rpcbind        
udp        0      0 0.0.0.0:631                 0.0.0.0:*                               2099/cupsd          
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     15946  2488/pulseaudio     /tmp/.esd-500/socket
unix  2      [ ACC ]     STREAM     LISTENING     15950  2488/pulseaudio     /tmp/pulse-Isuzu/native
unix  2      [ ACC ]     STREAM     LISTENING     3915   1727/audispd        /var/run/audispd_events
unix  2      [ ACC ]     STREAM     LISTENING     4012   1762/rpcbind        /var/run/rpcbind.sock
unix  2      [ ACC ]     STREAM     LISTENING     4291   1829/dbus-daemon    /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     4411   1877/pcscd          /var/run/pcscd.comm
unix  2      [ ACC ]     STREAM     LISTENING     4437   1886/acpid          /var/run/acpid.socket
unix  2      [ ACC ]     STREAM     LISTENING     4467   1895/hald           @/var/run/hald/dbus-15rp3FdQHX
unix  2      [ ACC ]     STREAM     LISTENING     5517   2099/cupsd          /var/run/cups/cups.sock
unix  2      [ ACC ]     STREAM     LISTENING     5854   2177/gdm-simple-sla @/tmp/gdm-session-vLUxrJIR
unix  2      [ ACC ]     STREAM     LISTENING     5472   2090/avahi-daemon:  /var/run/avahi-daemon/socket
unix  2      [ ACC ]     STREAM     LISTENING     5855   2177/gdm-simple-sla @/tmp/gdm-greeter-pMumBvdA
unix  2      [ ACC ]     STREAM     LISTENING     5783   2178/Xorg           /tmp/.X11-unix/X0
unix  2      [ ACC ]     STREAM     LISTENING     14575  2396/gconfd-2       /tmp/orbit-Isuzu/linc-95c-0-2033dd6d97666
unix  2      [ ACC ]     STREAM     LISTENING     5782   2178/Xorg           @/tmp/.X11-unix/X0
unix  2      [ ACC ]     STREAM     LISTENING     14587  2443/gnome-keyring- /tmp/orbit-Isuzu/linc-945-0-2fd24d1c98a10
unix  2      [ ACC ]     STREAM     LISTENING     15158  2443/gnome-keyring- /tmp/keyring-XF7hiE/socket
unix  2      [ ACC ]     STREAM     LISTENING     15160  2443/gnome-keyring- /tmp/keyring-XF7hiE/ssh
unix  2      [ ACC ]     STREAM     LISTENING     15162  2443/gnome-keyring- /tmp/keyring-XF7hiE/socket.pkcs11
unix  2      [ ACC ]     STREAM     LISTENING     15210  2459/ssh-agent      /tmp/ssh-ZmgvhI2444/agent.2444
unix  2      [ ACC ]     STREAM     LISTENING     15191  2454/dbus-daemon    @/tmp/dbus-uDajwDJQQV
unix  2      [ ACC ]     STREAM     LISTENING     15276  2444/gnome-session  /tmp/orbit-Isuzu/linc-98c-0-205a23cd11c07
unix  2      [ ACC ]     STREAM     LISTENING     15281  2444/gnome-session  /tmp/.ICE-unix/2444
unix  2      [ ACC ]     STREAM     LISTENING     15306  2485/gnome-settings /tmp/orbit-Isuzu/linc-9b5-0-548c90c431705
unix  2      [ ACC ]     STREAM     LISTENING     16001  2494/gconf-helper   /tmp/orbit-Isuzu/linc-9be-0-385abd638ef3c
unix  2      [ ACC ]     STREAM     LISTENING     16138  2511/gnome-screensa /tmp/orbit-Isuzu/linc-9c6-0-449bbbd0754fa
unix  2      [ ACC ]     STREAM     LISTENING     16350  2513/metacity       /tmp/orbit-Isuzu/linc-9d1-0-71fc31df6edd8
unix  2      [ ACC ]     STREAM     LISTENING     16365  2516/gnome-panel    /tmp/orbit-Isuzu/linc-9d4-0-3310c26f76a28
unix  2      [ ACC ]     STREAM     LISTENING     16383  2517/nautilus       /tmp/orbit-Isuzu/linc-9d5-0-3310c26f95dbe
unix  2      [ ACC ]     STREAM     LISTENING     16710  2521/bonobo-activat /tmp/orbit-Isuzu/linc-9d9-0-5c69b58717426
unix  2      [ ACC ]     STREAM     LISTENING     16978  2543/nm-applet      /tmp/orbit-Isuzu/linc-9ef-0-3902717f55365
unix  2      [ ACC ]     STREAM     LISTENING     16848  2531/gpk-update-ico /tmp/orbit-Isuzu/linc-9e3-0-7cd74c96acf63
unix  2      [ ACC ]     STREAM     LISTENING     16890  2548/gnome-power-ma /tmp/orbit-Isuzu/linc-9e1-0-3310c26d12cdb
unix  2      [ ACC ]     STREAM     LISTENING     17130  2564/wnck-applet    /tmp/orbit-Isuzu/linc-a04-0-4bcaa183eabe8
unix  2      [ ACC ]     STREAM     LISTENING     17141  2568/trashapplet    /tmp/orbit-Isuzu/linc-a08-0-4bcaa183f1721
unix  2      [ ACC ]     STREAM     LISTENING     17471  2599/notification-a /tmp/orbit-Isuzu/linc-a27-0-324dda5655643
unix  2      [ ACC ]     STREAM     LISTENING     17502  2596/gdm-user-switc /tmp/orbit-Isuzu/linc-a24-0-21ee912c4a5cf
unix  2      [ ACC ]     STREAM     LISTENING     17505  2590/mixer_applet2  /tmp/orbit-Isuzu/linc-a1e-0-21ee912c4ab79
unix  2      [ ACC ]     STREAM     LISTENING     17527  2593/clock-applet   /tmp/orbit-Isuzu/linc-a21-0-21ee912c85cf0
unix  2      [ ACC ]     STREAM     LISTENING     17975  2644/firefox        /tmp/orbit-Isuzu/linc-a54-0-64249d374db19
unix  2      [ ACC ]     STREAM     LISTENING     18798  2740/gnome-terminal /tmp/orbit-Isuzu/linc-ab4-0-3d6e2bbafc3d
unix  2      [ ACC ]     STREAM     LISTENING     19075  2799/bonobo-activat /tmp/orbit-root/linc-aef-0-56bb9d439a011
unix  2      [ ACC ]     STREAM     LISTENING     18124  2671/npviewer.bin   @/org/wrapper/NSPlugins/libflashplayer.so/2644-1
unix  2      [ ACC ]     STREAM     LISTENING     4487   1895/hald           @/var/run/hald/dbus-yDWlaEoOM5
unix  2      [ ACC ]     STREAM     LISTENING     18978  2793/dbus-daemon    @/tmp/dbus-VX9Np8lR3J
unix  2      [ ACC ]     STREAM     LISTENING     15280  2444/gnome-session  @/tmp/.ICE-unix/2444
[/]$
Apache error_log:
Code:
[/etc/httpd/logs]$cat error_log
[Sat Jan 03 14:44:25 2009] [notice] core dump file size limit raised to 4294967295 bytes
[Sat Jan 03 14:44:25 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Jan 03 14:44:25 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jan 03 14:44:25 2009] [notice] Digest: done
[Sat Jan 03 14:44:25 2009] [notice] Apache/2.2.8 (Unix) DAV/2 PHP/5.2.5 configured -- resuming normal operations
[Sat Jan 03 14:54:18 2009] [notice] caught SIGTERM, shutting down
[/etc/httpd/logs]$

Last edited by scotthill; 01-04-2009 at 02:31 AM.
 
Old 01-04-2009, 08:35 AM   #10
lighthousekeeper
LQ Newbie
 
Registered: May 2008
Posts: 7

Rep: Reputation: 0
apache starts by root but than usually switches to user "apache"
check this setting in your htttp.conf, maybe something wrong with it
ps aux | grep http[d] - will exactly show you the user from which apache is working
 
Old 01-04-2009, 03:12 PM   #11
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by lighthousekeeper View Post
apache starts by root but than usually switches to user "apache"
check this setting in your htttp.conf, maybe something wrong with it
ps aux | grep http[d] - will exactly show you the user from which apache is working
Here is the output:

Code:
[/]$service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 192.168.1.100:80
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]
[/]$ps aux | grep http
root     11760  0.0  0.0   4120   692 pts/1    S+   12:10   0:00 grep http
[/]$ps aux | grep httpd
root     11762  0.0  0.0   4120   692 pts/1    S+   12:11   0:00 grep httpd
[/]$
 
Old 01-04-2009, 03:35 PM   #12
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Can you instead post the output of:

# lsof -i4 -nP

This should show if any process is holding open tcp 80.
 
Old 01-05-2009, 12:43 AM   #13
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks for all the suggestions and help. What I've decided to do is to start over on this install. I'm reloading from the distribution disk currently. I hope I can report back to you that all is working.

A friend of mine who is a Linux pro -- having spent most of his life working on Linux systems -- spent a number of hours with me on this problem. He has now given up on my psychotic system. He thinks there is a flaw somewhere that will take longer to find than it would take to reload it.

SH
 
Old 01-05-2009, 03:01 PM   #14
scotthill
LQ Newbie
 
Registered: Jan 2009
Posts: 23

Original Poster
Rep: Reputation: 15
Success!

After reloading to OS from the distribution disks, Apache is now working. I guess we will never know what was wrong. The good news is I can move on with my life now. Thanks.
 
Old 01-05-2009, 03:40 PM   #15
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by scotthill View Post
After reloading to OS from the distribution disks, Apache is now working. I guess we will never know what was wrong. The good news is I can move on with my life now. Thanks.
Sometimes the "Windows Fix" just works

-C
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443 bruvajon Linux - Software 34 11-30-2011 04:08 PM
make_sock: could not bind to address why i cant start my apache instance rajamanickam Linux - Newbie 1 06-09-2008 04:31 PM
bind: Address already in use lejeczek Linux - Kernel 1 11-01-2007 01:48 PM
Could not bind to address 0.0.0.0:80 Linuxn00b Linux - Networking 3 01-23-2006 09:55 AM
bind : Address already in use sheni Linux - Networking 1 11-11-2004 01:41 PM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration