LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-28-2010, 09:19 AM   #1
Phat32
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Rep: Reputation: 0
Apache + SVN Issue


I am having an issue trying to log into my SVN server. I followed:
Setting up a Subversion server using Apache2 - openSUSE

to the letter and when I try to checkin stuff I get:
Code:
MKACTIVITY of '/svn/mohawk/!svn/act/cfad1e8c-3ce7-6a44-9e6d-f9867b419a81': authorization failed: Could not authenticate to server: rejected Basic challenge (http://path)
I changed the config a bit to lock down a dir so it asked when I check out too and I get *changed the URL*:
Code:
OPTIONS of 'http://path': authorization failed: Could not authenticate to server: rejected Basic challenge (http://path)
If I take out the Auth it does work instantly, but I need Auth on the svn

How to I get the login to accept? As I said I followed the guide to the letter, including the user creation.
 
Old 06-28-2010, 10:45 AM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Several good suggestions here:

http://www.experts-exchange.com/Soft..._24339802.html

Specifically:
1. If possible, troubleshoot with a browser located on the server itself (OpenSuSE?). Do NOT try to troubleshoot with a remote client (for example, a remote Windows PC) until you're 100% sure everything is working on the server side.

2. Try using "svn+ssh" instead of "http":
Code:
Rather than use the "http" protocol try "svn+ssh"

So the repo URL would be:

svn+ssh://<username>@<ip_address_of_SVN_Server>:<ssh_port>/<path_to_repo>/


the port can be omitted if it is the SSH default (port 22).
3. Double-check that you're actually using the correct username/password FOR SUBVERSION.

'Hope that helps .. PSM
 
Old 06-28-2010, 11:13 PM   #3
Phat32
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for the reply,

From what I can tell everything is setup correctly. When I remove the Require valid-user field I can check in and out no issues. Its only when its active that it fails. The user file was made as directed in the walkthrough. I have been testing on the box itself to see if it works, I get the same result in it, or in a remote box.

How would I use svn+ssh? Is there more to setup? and how would we use it on a Windows Client? The end result will be on a Windows Client. I am hosting it for my GF's Uni project.

Any thoughts?
 
  


Reply

Tags
apache, basic, rejected, suse11, svn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anon svn read-only over apache: '.svn/entries': No such file hedpe Linux - Software 2 04-29-2009 05:31 AM
Issue with SVN? your_shadow03 Linux - Server 1 12-17-2008 10:55 PM
CruiseControl+SVN Issue !!!! ajeetraina Linux - Server 1 11-01-2008 09:31 PM
SVN timestamp issue kingtermite Linux - Server 3 07-14-2008 03:30 PM
Remote SVN Backup Issue ajeetraina Linux - Server 4 06-29-2007 07:27 AM


All times are GMT -5. The time now is 07:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration