LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-27-2005, 12:44 AM   #16
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118

Well, it could be that port 3128 is a squid proxy, whereas port 5100 is usually used by SOCKS proxies.
 
Old 07-27-2005, 01:06 AM   #17
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
Well, it could be that port 3128 is a squid proxy, whereas port 5100 is usually used by SOCKS proxies.

hello there matir i think its already midnight over there... its taking me quite awhile until my script to be done...

is it ok if you visit my thread after you wake up? ill still post some issues regarding this matter when it gets done.

thank you very much for the help i extremely appreciate it... and more power to you....
 
Old 07-27-2005, 01:21 AM   #18
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
Well, it could be that port 3128 is a squid proxy, whereas port 5100 is usually used by SOCKS proxies.

sorry about this martir,,,,

because i got a new error:

failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

my script is:



$context = stream_context_create(array('http'=>array('proxy'=>'tcp://203.167.109.146:5100')));

$contents = file_get_contents("http://domainname/webpage.htm", false ,$context);
 
Old 07-27-2005, 08:42 AM   #19
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Just changing the port to 5100 won't work unless there's a Socks 4/5 proxy server on that host.
 
Old 07-27-2005, 06:25 PM   #20
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
Just changing the port to 5100 won't work unless there's a Socks 4/5 proxy server on that host.

hi there again matir

i saw some free socks proxy sites would this work? even if the port is not exactly 5100?

the sites are:

http://www.atomintersoft.com/product...y/socks5-list/

http://www.samair.ru/proxy/socks.htm


thanks
 
Old 07-27-2005, 07:46 PM   #21
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
You just need to make sure its pointed to a valid proxy.
 
Old 07-27-2005, 08:15 PM   #22
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
You just need to make sure its pointed to a valid proxy.
ive tried several socks proxies listed but i keep on getting this warning:

Warning: file_get_contents(http://www.yahoo.com) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond


my code is:

<?

$context = stream_context_create(array('http'=>array('proxy'=>'80.108.112.111:32167')));

$contents = file_get_contents("http://www.yahoo.com", false ,$context);


?>

socks4/5 i tried were:

201.235.78.20:1080 socks 4/5 Argentina
200.114.224.112:1080 socks 4/5 Argentina
200.126.186.153:1080 socks 4/5 Argentina
84.112.18.48:1080 socks 4/5 Austria
80.108.4.231:1080 socks 4/5 Austria
80.108.28.208:1027 socks 4/5 Austria
80.108.112.111:32167 socks 4/5 Austria


i tried them all, but all of them went in vain....
 
Old 07-27-2005, 08:51 PM   #23
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
hrrm. have you tried any http proxies?

And what version of PHP are you running?
 
Old 07-27-2005, 09:00 PM   #24
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
hrrm. have you tried any http proxies?

And what version of PHP are you running?

i have PHP 5 here......


i tried using http proxies my code is:


<?


$context = stream_context_create(array('http'=>array('proxy'=>'http://82.229.128.171:8080')));

$contents = file_get_contents("http://www.yahoo.com", false ,$context);




?>


i got a warning that says:


Warning: file_get_contents(http://www.yahoo.com) [function.file-get-contents]: failed to open stream: Unable to find the socket transport "http" - did you forget to enable it when you configured PHP?
 
Old 07-27-2005, 09:02 PM   #25
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Try removing the http:// from the front of the proxy name.
 
Old 07-27-2005, 09:05 PM   #26
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
Try removing the http:// from the front of the proxy name.


i did that my code now is:


<?


$context = stream_context_create(array('http'=>array('proxy'=>'82.229.128.171:8080')));

$contents = file_get_contents("http://www.yahoo.com", false ,$context);




?>


warning says:

Warning: file_get_contents(http://www.yahoo.com) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
 
Old 07-27-2005, 09:15 PM   #27
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Try taking a look at the information on this page: http://livedocs.php.mirrors.powertri.../wrappers.html
 
Old 07-27-2005, 09:43 PM   #28
spandau
LQ Newbie
 
Registered: Jul 2004
Location: Philippines
Distribution: NA
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Matir
Try taking a look at the information on this page: http://livedocs.php.mirrors.powertri.../wrappers.html
ummm... im sorry matir but im a little bit lost here regarding php wrappers...............

i dont know where in the document would i find my answer............help
 
Old 09-01-2005, 12:39 AM   #29
kaverong
LQ Newbie
 
Registered: Sep 2004
Location: Philippines
Distribution: CentOS, Gentoo, Ubuntu, Redhat, Fedora. FreeBSD
Posts: 13

Rep: Reputation: 0
Hi Guys,

I also get a
403 Forbidden error ... Port 443
only when I use https

I'm running a virtual host and I use SELinux, the same problem would not be encountered whenever i disable SELinux.

my document root is /www/html wherein /www is a mounted disk partition.

i get this error in my log/messages

...audiit(1125570534.322:0): avc: denied { getattr } for pid=26442 comm=httpd path=/www dev=hda8 ino=2 scontext=root:system_r:httpd_t tcontext=system_ubject_r:file_t tclass=dir



please help

Last edited by kaverong; 09-01-2005 at 05:24 AM.
 
Old 09-01-2005, 06:06 PM   #30
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Forbidden Errors (SELinux)

You may experience a "forbidden error" when attempting to access a users public web site (http://localhost/~alice), this is generally because the permissions are either set incorrectly, or SELinux is set to "Enforcing" mode which blocks the standard suexec call needed by the Apache server. Common error is the "/home/username" permissions.

To temporarily disable SELinux so you can test the access permissions, type "setenforce 0" at the command prompt. Typing "setenforce 1" sets SELinux back to Enforcing mode.

Use the following commands to permanently adjust the SELinux file security context so Apache can access user's public web sites.

Code:
### SELinux ONLY - Enable User Website
[bash]# setsebool -P httpd_enable_homedirs true
[bash]# chcon -v -R -h -u user_u -t httpd_user_content_t /home/*/public_html

### SELinux ONLY - Disable User Website
[bash]# setsebool -P httpd_enable_homedirs false
[bash]# chcon -v -R -h -u user_u -t user_home_t /home/*/public_html
http://www.brennan.id.au/13-Apache_W...ver.html#users

just my ...


Last edited by win32sux; 09-01-2005 at 06:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HTTP 403 (Forbidden) error lothario Fedora 6 02-08-2005 04:43 AM
Error 403 Forbidden access in Apache anoop_cn Linux - Software 1 09-21-2004 09:32 AM
apache error, 403 forbidden afrodocter Linux - Software 6 08-09-2004 08:35 PM
I Fixed Apache 403 Forbidden Problem, but how? shosterman Linux - Newbie 2 01-26-2004 10:33 AM
apache 403 error forbidden? bulliver Linux - General 4 01-31-2003 07:47 AM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration