LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 04-11-2006, 06:11 PM   #1
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Rep: Reputation: 30
Apache + Mod_proxy ProxyPass


Hi
could anybody used ProxyPass before give me a hint about ProxyPass and the Virtual Host
here is my conf files
=====================================================
part of httpd.conf
===================
ProxyPass /anything balancer://mycluster nofailover=Off lbmethod=byrequests
<Proxy balancer://mycluster>
BalancerMember http://apache1/app
BalancerMember http://apache2/app
Order Deny,Allow
Deny from none
Allow from all
</Proxy>
===================================================
part of conf/extra/httpd-ssl.conf
================================
NameVirtualHost *:443
<VirtualHost _default_:443>
SSLProxyEngine on
#General setup for the virtual host
DocumentRoot "/usr/apache-ssl/htdocs"
ServerAdmin root@balancer
ErrorLog /usr/apache-ssl/logs/error_log
TransferLog /usr/apache-ssl/logs/access_log

ProxyPass /anything balancer://mycluster nofailover=Off lbmethod=byrequests
<Proxy balancer://mycluster>
BalancerMember https://apache1/app
BalancerMember https://apache2/app
Order Deny,Allow
Deny from none
Allow from all
</Proxy>
#Alot of SSL Engine Options and so on:
</VirtualHost>
========================================
My problem is
when I hit http://balancer/anything or httpS://balancer/anything
it always give me whatever in the main conf file httpd.conf
I assume that it suppose to switch when I ask for HTTPS
==========================================================
it semes to me like ProxyPass in httpd.conf Overrides the
one in conf/extra/httpd-ssl.conf
or there is something missing in these configurations?
=============
Any suggestions?
Thanks
 
Old 04-14-2006, 08:52 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
I think you will need to create another virtualhost for port 80 and then put the http proxy configuration inside that.
 
Old 04-14-2006, 09:57 PM   #3
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
yea thanks it all worked out, i was going to post back here to answer the question.

http://www.yourhowto.org/component/o...id,30/catid,5/
 
  


Reply

Tags
proxy, ssl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache + Mod_proxy "ProxyPass" ziox Linux - Networking 0 04-11-2006 11:25 AM
Apache 1.3 mod_proxy no cache mago Linux - Software 0 04-07-2006 01:39 PM
Apache proxypass url prob collen Linux - Software 0 10-14-2005 07:59 AM
apache proxypass, or lighttpd php belorion Linux - General 2 07-15-2005 11:07 AM
Apache ProxyPass/VirtualHost question lil_drummaboy Linux - Networking 2 11-10-2004 12:53 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration