LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 07-21-2006, 03:46 AM   #1
myq
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
apache default webpage is blank on ubuntu


Help please.

After installing Apache2 while running the xubuntu 6.06 live CD, the default apache webpage is blank.

I'm running on the xubuntu 6.06 (Dapper Drake) live CD to trial if this is an appropriate distribution for me (I've previously been running FC). The same problem occurs with the ubuntu 6.06 live CD.

I tried installing the apache2 package using Synaptic, and it seems to setup correctly, i.e. I can access the web server both from the localhost and via another PC.

However, the default Apache2 webpage is blank.

Initially, after entering "localhost" as the URL on firefox, I see a directory listing containing one directory "apache2_default/". If I click on apache2_directory/ the brower will show a blank page.

If I "cd /var/www/apache2_default", and manually fire-up firefox with "firefox index.html.en", then I correctly see the default apache webpage.

Any ideas?

Thanks!

Mike
 
Old 07-21-2006, 04:36 AM   #2
tets
LQ Newbie
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Debian
Posts: 22

Rep: Reputation: 15
I think default "DocumentRoot" directive is set to "/var/www/". Apache looks into this directory, not in "/var/www/apache2_default", so it returns nothing. Put something in "/var/www/".

Also, you may edit the file "/etc/apache2/sites-enabled/000-default".

Tets :-)
 
Old 07-21-2006, 05:04 AM   #3
myq
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tets
I think default "DocumentRoot" directive is set to "/var/www/". Apache looks into this directory, not in "/var/www/apache2_default", so it returns nothing. Put something in "/var/www/".

Also, you may edit the file "/etc/apache2/sites-enabled/000-default".

Tets :-)
Thanks for your help.

I tried copying the contents of /var/www/apache2_default to /var/www, but I get the same blank browser page. But, this time I didn't see the directory listing at the start. I suppose this is expected.

000-default is already linked to /etc/apache2/sites-available/default.

I haven't seen this problem reported elsewhere, so maybe it's something related to my setup. Maybe it has something to do with running from the Live CD.

I think I'll have to bite the bullet, and try installing xubuntu on a hard drive, then installing apache2 over that.

I'm all ears for any other ideas.

Thanks

Mike
 
  


Reply

Tags
apache2, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up a webpage on apache metallica1973 Linux - Software 2 04-12-2006 09:05 PM
Not able to access webpage on apache krishvij Linux - Networking 2 01-27-2006 04:59 AM
Can Apache host more than one webpage? Jestrik Linux - Networking 2 03-29-2004 05:15 PM
i cant change the default webpage to my own yoaliens3000 Mandriva 2 11-03-2003 08:08 AM
Pushing a default webpage to users facroft General 0 07-23-2001 08:28 AM


All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration