LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-11-2005, 11:13 PM   #1
wezhousheng
LQ Newbie
 
Registered: Apr 2005
Location: china
Posts: 21

Rep: Reputation: 15
apache 403 forbidden?


hi.i'm a newbie to apache
but there are some problems with my apache .

when i start the httpd service it come with this .
Code:
stop httpd:                                               [  OK  ]
start httpd:[Thu May 12 11:01:03 2005] [warn] The Alias directive in /etc/httpd/
conf/httpd.conf at line 577 will probably never match because it overlaps an earlier AliasMatch.
                                                           [  OK  ]

then i type 127.0.0.1 in the firefox it appears:
Code:
Forbidden

You don't have permission to access /index.html on this server.
Apache/2.0.52 (Fedora) Server at shiyici Port 80
is there some wrong with my service name"shiyici" or others?
i'm useing FC3 localhost.localdomain 2.6.11-1.14_FC3
 
Old 05-12-2005, 05:24 AM   #2
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Hello!
Post here what do you have in "httpd.conf" in line 577. Mmmm... and look if you have another the same alias in "httpd.conf".
Also look in httpd log files.
 
Old 05-12-2005, 07:25 AM   #3
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,438

Rep: Reputation: 103Reputation: 103
take a look at the permissions of the index.html file in the DocumentRoot
ls -l /path/to/index.html

Last edited by j-ray; 05-12-2005 at 07:27 AM.
 
Old 05-12-2005, 10:01 AM   #4
wezhousheng
LQ Newbie
 
Registered: Apr 2005
Location: china
Posts: 21

Original Poster
Rep: Reputation: 15
but i've change the index.html to "777" and it didn't work
 
Old 05-12-2005, 08:31 PM   #5
shubb
Member
 
Registered: Oct 2003
Location: San Francisco
Distribution: Slackware 13.37
Posts: 150

Rep: Reputation: 16
Can you post the section of your httpd.conf file that the error references? It looks like you are using virtual servers, right? Depending on how you specified the virtual server (IP or domain name) you might not be matching a virtual server.
 
Old 05-13-2005, 01:15 AM   #6
wezhousheng
LQ Newbie
 
Registered: Apr 2005
Location: china
Posts: 21

Original Poster
Rep: Reputation: 15
it's the codes from line 577 of httpd.conf
Code:
Alias /manual "/var/www/manual"

<IfModule mod_dav_fs.c>
    # Location of the WebDAV lock database.
    DAVLockDB /var/lib/dav/lockdb
</IfModule>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache: 403 forbidden johnty01 Linux - Networking 5 04-05-2008 03:20 PM
apache error, 403 forbidden afrodocter Linux - Software 6 08-09-2004 09:35 PM
Apache 403 Forbidden mrmike Linux - Newbie 3 07-10-2004 12:31 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 06:30 AM
Apache 403 Forbidden quozt Linux - Networking 10 02-24-2004 05:59 PM


All times are GMT -5. The time now is 05:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration