LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-26-2006, 04:29 AM   #1
kaltwasser
LQ Newbie
 
Registered: May 2006
Posts: 13

Rep: Reputation: 0
Talking Apache 2.2 Index.html / configure httpd.conf file


First I just want to thank everyone who helps others in this forum. We all need help from time to time.

Ok this should be easy for someone with the knowledge of configuring the Apache 2.2 server file httpd.conf

All I want to do is get my index.html page up and running on my Fedora 5 server. But I'm not understanding what parts of the "httpd.conf" file I need to configure. I got my domain name up and running just need to have it pin point to my index.html page.

I have my Index.html file in this directory "/var/www/html/index.html"

I don't know what I'm supposed to enable or disable in the httpd.conf and edit. I've looked online at documentation but it has got me stumped.

Any help I would greatly appreciate thanks.
 
Old 07-26-2006, 06:05 AM   #2
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
You need to check two directives:

DocumentRoot - this should be set to the base directory containing your website, /var/www/html in your case
DirectoryIndex - this directive is processed when a directory is requested. The first filename that matches is returned. Make sure index.html appears in the list - although it should be there by default in a standard installation

Note that capitalisation matters - Index.html is NOT the same as index.html. Web conventions generally stick to lowercase.
 
Old 07-26-2006, 12:33 PM   #3
kaltwasser
LQ Newbie
 
Registered: May 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the reply cdhgee.

I already have the Document Root set to my path /var/www/html & Directory index to Index.html with the capitalisation. It still won't work. On the page it say's this cdhgee.

If you are the website administrator:

You may now add content to the directory /var/www/html/. Note that until you do so, people visiting your website will see this page, and not your content. To prevent this page from ever being used, follow the instructions in the file /etc/httpd/conf.d/welcome.conf


I've follow the instructions using the comments # the /etc/httpd/conf.d/welcome.conf says this

#
# This configuration file enables the default "Welcome"
# page if there is no default index page present for
# the root URL. To disable the Welcome page, comment
# out all the lines below.
#
#<LocationMatch "^/+$">
# Options -Indexes
# ErrorDocument 403 /error/noindex.html
#</LocationMatch>


Note that I've put comments in like it says to. so without the comments it would look like this.

#
# This configuration file enables the default "Welcome"
# page if there is no default index page present for
# the root URL. To disable the Welcome page, comment
# out all the lines below.
#
<LocationMatch "^/+$">
Options -Indexes
ErrorDocument 403 /error/noindex.html
</LocationMatch>


I hope you can help me with this cus I'm stumped. I thank you who reply vary much.
 
Old 07-26-2006, 12:43 PM   #4
pnellesen
Member
 
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
I'll ask what might be a dumb question: Exactly what do you see in your browser when you try to load the page?

Last edited by pnellesen; 07-26-2006 at 12:45 PM.
 
Old 07-26-2006, 01:49 PM   #5
kaltwasser
LQ Newbie
 
Registered: May 2006
Posts: 13

Original Poster
Rep: Reputation: 0
No its not a dumb question pnellesen. Try and see click me

you should see the Fedora Core Test Page. Let me know please thanks
 
Old 07-26-2006, 02:54 PM   #6
kaltwasser
LQ Newbie
 
Registered: May 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Ok I figured it out. I just want to let you all know this ok.

I put Index.html with the capitalisation and edit my httpd.conf file with the capitalisation. I recommend using lower case so you don't run into problems.

I changed my Index.html file to index.html and my httpd.conf file to lower case for the DirectoryIndex to index.html

BAM it came up just fine.

I want to thank you all who gave me a reply to help me with my problem and you did. We worked together and now we all know what to do when this happens to us. Thanks Kaltwasser

Feel free to check out my site its under construction right now but if you want to see it click me.
 
Old 07-26-2006, 03:10 PM   #7
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I don't want to put a dampener on things, but that link won't load.

I can't ping the address either. Do you have it in a nameserver?

Edit - actually, I can ping spucke.com, but not www.spucke.com. However, trying to load spucke.com in by browser times out.

Rgds

Last edited by billymayday; 07-26-2006 at 03:12 PM.
 
Old 07-26-2006, 09:48 PM   #8
pnellesen
Member
 
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
FWIW, I'm seeing the same thing as billymayday... If I try using the IP (HERE), I'm seeing "Error 400 - Bad Request"
 
Old 07-27-2006, 03:05 AM   #9
kaltwasser
LQ Newbie
 
Registered: May 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Well thats not good. I will have to check all my settings.

Thanks for letting me know.
 
Old 07-27-2006, 03:20 AM   #10
nestedrana
LQ Newbie
 
Registered: Jul 2006
Location: pakistan
Distribution: redhat AS4
Posts: 3

Rep: Reputation: 0
Smile neeed help

hello geeks and experts!!

i m new here in the LQ..even dont know how to put up my first query!..anyway after installing REDHAT linux AS4 . i m facing continious problems in configuring apache server...
whenever i m viewing my page in browser...it displays APACHE test page!!!!

help me pls...i m set all the path correctly of document root ...thanks in advance
 
Old 07-27-2006, 03:45 AM   #11
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
nestredrana, welcome to the list.

Make a point in future of not asking new questions in existing lists, because it gets everything confused. You can simply start a new post. You select the relevant forum from the toolbar under the penguins and you should see an option to start a new thread.

Now, do you have a file called index.html in your documentroot directory? To be safe, make sure there isn't another file with a similar name there.
 
Old 07-27-2006, 05:16 AM   #12
siva_shankar
LQ Newbie
 
Registered: Jul 2006
Posts: 3

Rep: Reputation: 0
have you configured this apache through webmin or simply extracted from rpm package any thing it may just check that index.html which may be in other keyrings that is case sensitive "/var/www/html/index.html" but in linux it take default extension as index.htm better you can try with index.htm
 
Old 07-28-2006, 06:07 AM   #13
nestedrana
LQ Newbie
 
Registered: Jul 2006
Location: pakistan
Distribution: redhat AS4
Posts: 3

Rep: Reputation: 0
httpd :(

ok ..thanks for your suggestions..
billymayday , i have checked my document root as well as document directory..still i see this test page :'(
 
Old 07-28-2006, 06:22 AM   #14
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Are you sure there aren't any typos, case issues (ie Inded not index) and so on?
 
Old 07-28-2006, 07:47 AM   #15
nestedrana
LQ Newbie
 
Registered: Jul 2006
Location: pakistan
Distribution: redhat AS4
Posts: 3

Rep: Reputation: 0
even i have changed my configuration file by overwriting the orignal one..still the same problem..no case sensitive issue yet..everything is ok..do u think i need to reinstall AS4??
 
  


Reply

Tags
httpd, page, pls


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache httpd.conf file?? matux Mandriva 2 01-28-2005 09:20 AM
Apache problem - cannot get index.html file to show nebloof Linux - Software 3 01-15-2005 10:32 PM
Fedora 1, Apache, httpd.conf file Turner Linux - Newbie 2 07-07-2004 12:11 PM
Apache 2.0 search for index.html file pawlub Linux - Software 2 10-28-2003 10:03 AM
Red Hat Linux 8 Apache index.html file muhammade Linux - General 10 02-11-2003 11:30 AM


All times are GMT -5. The time now is 03:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration