LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Annoying SUSE 9.2 Network issue (http://www.linuxquestions.org/questions/linux-networking-3/annoying-suse-9-2-network-issue-299158/)

Skywing 03-08-2005 09:58 AM

Annoying SUSE 9.2 Network issue
 
hey guys, having a slight issue with my new SUSE install, my wireless card is configured as eth0 and my intel pro gigabit is eth1, im using my wired connection much more often than my wireless, but for some reason even when its plugged in i dont have internet access, it only works when i go into YaST and remove the wireless card from my configuration. once the wireless is removed, internet works fine, however, once its added again, i lose internet, for some reason it think that the wireless is the only network device and its not switching over to the gigabit when theres no IP for it. anyone have a solution for me? im really liking suse and dont want this one issue to kill it for me. thanks.

nyguy 03-08-2005 10:33 AM

Perhaps an answer...
 
Hi,

I'm new to Linux and SuSE as well, and installed on my Thinkpad that has both wireless and wire LAN.

Two things to recommend.

1. I found (through searching this site) that in the YaST settings, you need to specify the wire based LAN connection to activate only manually or when hotplugged (I think that there was an option as well to activate only when the cable was plugged in).

2. Learn the commands 'ifup' and 'ifdown'. For example, when you want to run the wireless card (mine is at eth1), type in at the command line 'ifup eth1'. This starts the wireless card and the DHCP associated with it. If you want to turn off the wire based lan (mine is eth0), I type 'ifdown eth0'


Hope this helps

Skywing 03-08-2005 10:38 AM

i have it on my thinkpad as well, didnt see any of those options in YaST, guess ill have to dig deeper, ill give those a try, thanks.

nyguy 03-08-2005 10:41 AM

try in Yast

Network Devices
Network Card
Advanced
Detailed Settings

Device Activation dropdown

Skywing 03-08-2005 11:57 AM

Quote:

Originally posted by nyguy
try in Yast

Network Devices
Network Card
Advanced
Detailed Settings

Device Activation dropdown

changed my wireless card to manual in there, everything works PERFECTLY!

thanks alot!


All times are GMT -5. The time now is 07:38 PM.