LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Am I missing something? (http://www.linuxquestions.org/questions/linux-networking-3/am-i-missing-something-216755/)

brent1a 08-12-2004 12:13 PM

Am I missing something?
 
I am not trying to be negative here and this is just my observation but it seems as though if someone connects to the internet thru DSL then they are screwed for a connection in any linux distro.
For instance, I tried SuSE 9.1 about 4 months ago when it was released and I could not connect for the life of me. Here is my connection info: I have a static IP running on a MSAFD TCP/IP network protocol piped thru a dsl modem connected to my Linksys NC100 Fast Ethernet Adapter.
The only thing I could figure out was that direct connect static IP DSL isn't supported by the Linux kernel at all and it sounds like it may well never be. I live on the internet and so far, this is why I haven't migrated. Even customer service at Novell/SuSE doesn't know, they simply point me in the direction of a gazillion forums.

bastard23 08-12-2004 12:58 PM

What is MSAFD? (All I can gleen from google is that it is either a programming interface comparable to sockets, or that it implements sockets.)

What makes the "MSAFD TCP/IP" network special. Which DSL router is it? Is it bridging or routing the IP traffic? What ISP are you trying to connect to?

Most ISPs use pretty standard networking technology, so some pointers on what is special would be useful for trying to help get linux connected.

stickman 08-12-2004 01:25 PM

Re: Am I missing something?
 
Quote:

Originally posted by brent1a
The only thing I could figure out was that direct connect static IP DSL isn't supported by the Linux kernel at all and it sounds like it may well never be. I live on the internet and so far, this is why I haven't migrated. Even customer service at Novell/SuSE doesn't know, they simply point me in the direction of a gazillion forums.
I've used several DSL providers (and several different modems), and the first thing that I did each time is test the connectivity with my SuSE and OpenBSD laptops. I've never had any issues with static IP assignments. In fact, I selected each ISP based on the fact that they gave out static IP addresses.

Do you have any specific error messages that you can relay? Info on your specific setup might also be helpful.

brent1a 08-12-2004 01:46 PM

I have no idea what makes it special but I will fill you in with as much info as I can. First, I live on the outskirts of a small town (part of a greater farming community) with a pop. of less than 100. Since all the farmers in the area wanted DSL they installed a server somewhere in the area so I know I'm not too far away from it. The actual dsl service is great but the support is lacking. What I've come to know is that my service does not utilise PPPOE or ATM as it does not connect with a password (I have a static IP). I found the 'MSAFD protocol' under system info in MS Office. As far as I know I have direct connect/always on meaning: DSL Server>House>DSL Modem>NIC. In windows I input the dns and subnet and whathavya and that is all. I understand linux is more complicated than windows or OS X but this much more complicated? I don't know how I can explain my connection any simpler.
Thanks for all your help though.

brent1a 08-12-2004 01:48 PM

Stickman-
I never got an error message, the system never attempted to connect. I'd go thru Yast and it would recognize my NIC and thats it. You either had to chose PPPOE or ATM to set up your internet, it had no other options. I tried every possible config thru Yast I could think of and nothing worked.

gojamiegirl 08-12-2004 02:40 PM

I have used dsl and cable with linux and dsl is a bit more difficult for me. To use PPPOE I had to install rp-pppoe (I am using urpmi on Mandrake 10). It's been a long time since I've used dsl so I may have forgot stuff

on the command line as root:

# urpmi rp-ppoe

Then run rp-pppoe and it should ask you for username etc and then log you in

Sorry if I'm not much help

jbeiter 08-12-2004 03:02 PM

Sorry if I'm completely misunderstanding your setup, but shouldn't this be as simple as configuring your ethernet adapter with the proper address, mask, and default route?

I've never used suse but redhat's config is in /etc/sysconfig/network-scripts/ifcfg-eth0

or on the commandline using ifconfig

I have DSL into a telco supplied modem, then a linksys hub with multiple ports into the house. The linksys connects to verizon via ppoe, then I have DHCP on the hub that takes care of the rest of the house.

arno 08-12-2004 03:58 PM

You say "in windows I input the dns and subnet and whathavya and that is all" and probably your ip and default gw or do you use dhcp to get those addresses in windows.

as jbeiter said you should setup your network connection and NOT your internet connection.
with yast control center

brent1a 08-13-2004 12:29 AM

Quote "I've used several DSL providers (and several different modems), and the first thing that I did each time is test the connectivity with my SuSE and OpenBSD laptops. I've never had any issues with static IP assignments. In fact, I selected each ISP based on the fact that they gave out static IP addresses."

Thats the problem when setting up my network connection thru Yast even a static ip was burdoned by pppoe dhcp &/or atm required options. When I tried to set up my network it had to be one of 2 or 3 types of network protocols. There was no straight static IP option with which I could bypass other stuff.

Quote "Sorry if I'm completely misunderstanding your setup, but shouldn't this be as simple as configuring your ethernet adapter with the proper address, mask, and default route?"

I don't know. SuSE had recognized my NIC OK and as far as I can tell (thru windows) my NIC doesn't need that info configured on it. That is handled by the OS. Also at one point I used to have an Intel USB Network Adapter which wasn't a card at all. Is that what the problem is? Is linux the complete opposite of this because this is the first I've heard of it.

Quote "as jbeiter said you should setup your network connection and NOT your internet connection with yast control center."

If I remember right they were two different options and obviously I would have had to be setting up my network connection. They are two completely different things.

Another thing is I have no hubs or routers in my house or connected to my computer. It's just my phone line connected to a DSL modem.

Now another question: If DSL is outdated (even though I just got my 1500 bandwidth only about 5 months ago) what kind of internet connection do you all have that makes connecting to the net thru linux so easy?

brent1a 08-13-2004 09:58 AM

Well, I finally know now-

Quote-
MSAFD TCP/IP is a proprietary protocol from Microsoft which cannot be
used with Linux.

What DSL Modem (manufacturer and model) do you have. With this information we will see if we can help you.


Thank You!

Novell, Inc., the leading provider of Information Solutions
Customer Response Center

Between my dumb hick provider and my 4.5 y/o computer I'm just screwed.
Thanks for all of your help though.

ugge 08-13-2004 04:44 PM

As far as I can tell from my search for MSAFD it's only a dll used in windows used with sockets, that is internal communication.

I would say that you are complicating the task of setting up your internet connection. As you connect your network card to your DSL modem using ethernet the only thing you would have to do is to set up a static IP on you NIC (YaST - Network Devices - Network Card), not the setting for DSL devices (YaST - Network Devices - DSL).
This later setting is used when your DSL modem are connected directly to your computer using an internal bus like PCI, PCMCIA or an external like USB.

brent1a 08-14-2004 03:20 AM

I remember that I had tried that, got nothing. I remember to be connected to the net you had to run that small program that would have a lightning icon on if you were connected or something. Like I said I tried everything. With protocols and without. According to my providers and my system Windows doesn't set a static IP to my NIC. Thats why I am confused. I don't understand why you have to do it or how you do it for Linux.

arno 08-14-2004 04:10 AM

Brent1a,

Have a look at this site it give's you some information about dsl connections and isp providers, you will notice that there are different ways to make a connection it all depends on your isp and the type of modem and connection type.
Have a good read.

http://www.tldp.org/HOWTO/DSL-HOWTO/configure.html


All times are GMT -5. The time now is 09:06 AM.