LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-25-2001, 08:45 AM   #1
mswebs
LQ Newbie
 
Registered: Oct 2001
Location: Atlanta, GA
Posts: 5

Rep: Reputation: 0
Question Alias directive in Apache 1.3.22


Hopefully this is a simple question. I have a directory that is called docs, which is not in my regular DoumentRoot of my website. I have created and Alias that points to like so:

Alias /docs/ “/usr/local/docs/”

This works fine as long as I type: www.mydomain.com/docs/ but if I of course only type: www.mydomain.com/docs it does not work. I read the information that protein to the mod_alias directive, which states that if you Alias has a trailing / it is required for the end-user to type in exactly that way. I thought to myself that this is understandable, but I need to be able to except it URL without the trailing / as well. I then went back in the conf file that defines the Alias and added another Alias right under that one without the trailing /. In my thinking this should work, but for some reason it does not. I then just modified the original Alias to not include the trailing /, but that does not seem to work either.

I’m not sure if I am explaining this right or not, but to make a long story short, I would like for below statements to get to the same place:

www.mydomain.com/docs/
www.mydomain.com/docs

The only difference is the trailing “/”. There has got to be something simple, because I have put entirely to much time in trying to figure this out. Please Help!!!!!!
 
Old 08-01-2003, 11:13 AM   #2
XxAndyxX
Member
 
Registered: Mar 2003
Location: Houston, TX
Distribution: RedHat 8.0
Posts: 79

Rep: Reputation: 15
If you read your httpd.conf file is says,

'Note that if you include a trailing / on fakename then the server will require it to be present in the URL. So "/icons" isn't aliased in this example, only "/icons/". If the fakename is slash-terminated, then the realname must also be slash terminated, and if the fakename omits the trailing slash, the realname must also omit it.'

So you need to put both,

Alias /docs/ “/usr/local/docs/”
Alias /docs “/usr/local/docs”

Hope this helps
 
Old 08-01-2003, 02:09 PM   #3
stickman
Senior Member
 
Registered: Sep 2002
Location: Nashville, TN
Posts: 1,552

Rep: Reputation: 53
Or you could use the Options directive to specify Indexes. That way you don't have to keep creating double aliases for everything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ServerTokens Directive Apache with SLOX4.1 sln Linux - Security 1 05-31-2005 12:52 PM
apache User directive merchtemeagle Linux - Software 2 03-07-2005 03:42 PM
Apache 'Listen' directive doesn't work robbiemorgan Linux - Software 0 11-22-2004 11:49 AM
"modprobe config already contains alias directive", must reconfigure at restart Desert Linux - Wireless Networking 1 07-22-2004 07:43 PM
Apache Directive sopiaz57 Linux - Security 2 12-09-2003 01:32 PM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration