LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-20-2007, 11:43 PM   #1
eerpini
Member
 
Registered: Mar 2007
Posts: 36

Rep: Reputation: 15
Airtel Gprs+ Linux + Phone = Internet


METHOD FOR ENABLING A NET CONNECTION USING AIRTEL GPRS CONNECTION ON LINUX ( MAINLY FEDORA)


PREREQUISITES
-> u shud have a USB cable to connect ur phone to the laptop/system
-> u shud know the product ID(PID) and the vendor ID(VID) of ur phone ,
(for newbies ,as was the case with me ,a good method to do this is to check it out in some other OS like windows
).
-> check whether ur phone shows the USB connected symbol on connecting.....



FIRST STEP:
run this command on the terminal
: /sbin/modprobe usbserial vendor=0x<VID> product=0x<PID>
next follow the second step.........


SECOND STEP:
run the command :wvdialconf create , on the terminal , it will show the output as following,

[root@localhost ~]# wvdialconf create
Scanning your serial ports for a modem.

Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to create.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


now this shows that i have a modem connected on the port /dev/ttyACM0
now use this and substitute in the script in third step , ..........




THIRD STEP:
PASTE THE BELOW SCRIPT IN THE FILE etc/wvdial.conf ( delete any earlier existing scripts)and .........


[Dialer Defaults]
Modem = <the modem port recognised on running the command: wvdialconf create , on the terminal>
Baud = 230400
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = *99***1#
Username = A
Password = B
Stupid Mode = 1


[B]FOURTH STEP:[\B]

open terminal with root permissions and run the command : wvdial.

the output for a successfull connection shud be as follows :


[root@localhost ~]# wvdial
--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer bg] does not exist in wvdial.conf.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Mon May 21 09:44:10 2007
--> pid of pppd: 3748
--> Using interface ppp0
--> pppd: Modem
--> pppd: Modem
--> pppd: Modem
--> local IP address 10.154.32.5
--> pppd: Modem
--> remote IP address 10.6.6.6
--> pppd: Modem
--> primary DNS address 202.56.250.5
--> pppd: Modem
--> secondary DNS address 202.56.250.6
--> pppd: Modem


now u shud be able to connect with 75 % certainity, and i think u can get help for the remaining 25 % from some of the forums , please read the notes below , they are important ,........

NOTE 1:there is even another problem that might arise , even if wvdial shows a connected modem , but u are not able to
open any website ,........
then do this after connecting paste the following script in the /etc/resolv.conf file:

service named start
nameserver 202.56.250.5
nameserver 202.56.250.6

NOTE 2: there is yet another problem , the airtel provides two numbers , one is *99# and the other is *99***1# , the latter worked in my case if it does not work in ur case use the number *99#,

NOTE 3:
THE CONFIGURATION I USED WAS

laptop: HP nx7400
Linux Distribution: Fedora Core 6 (ZOD)
phone: NOKIA 7610


reference : my main referance were the posts on this forum , think.digit.com ,and the thread was: Fedora Core 5+Nokia 6070+CA 42+Airtel GPRS
( i am sorry i am not able to qoute the exact web address here );





if this was helpful i will feel happy ,, .. please tell me if there is any new problem ,.... we will work to solve it ,

AND IF ANYONE FINDS A SIMILAR IMPLEMENTATION BUT USING A BLUETOOTH PORT THEN REPORT/POST IT HERE.........
 
Old 11-22-2007, 11:22 AM   #2
lsropia
Member
 
Registered: Dec 2002
Distribution: RedHat
Posts: 30

Rep: Reputation: 15
GPRS on BSNL Cellone

I did everything mentioned, the modem gets initialised but doesnot give me IP to connect to internet. System: FC8 on Lenovo laptop and also on Desktop with N70 through USB cable.

Here is my wdial.conf:, created with wvdialconf create
==================================================================================
[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
SetVolume = 0
Username = user
Password = user
Phone = *99***1#

[Modem0]
Stupid Mode = 1
Dial Command = ATDT
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = ATM0
FlowControl = CRTSCTS
==================================================================================

With wvdial, I get following output:
=====================================
[root@localhost ~]# wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> PPP negotiation detected.
--> Starting pppd at Thu Nov 22 22:47:19 2007
--> Pid of pppd: 4410
--> Using interface ppp1
--> pppd: [08]u3 [08]u3 [08]~3
--> pppd: [08]u3 [08]u3 [08]~3
--> pppd: [08]u3 [08]u3 [08]~3
--> pppd: [08]u3 [08]u3 [08]~3
--> pppd: [08]u3 [08]u3 [08]~3
--> pppd: [08]u3 [08]u3 [08]~3
--> Disconnecting at Thu Nov 22 22:47:26 2007
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
=====================================

The above output keeps repeating until killed with Ctrl+C. The modem hangs with exit code = 16.

Phone = *99***1#, is confirmed with BSNL.


Please help.
 
Old 11-23-2007, 04:27 AM   #3
eerpini
Member
 
Registered: Mar 2007
Posts: 36

Original Poster
Rep: Reputation: 15
just try changing the wvdial.conf file

hey i think u should try changing the wvdial.conf file, .... and i can't say it is entirely because of the config file, ... this happens to me also , ..... may be because of the server problem or something ......
just replace the contents of your wvdial.conf with the following,.......

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = *99***1#
Username = A
Password = B
Stupid Mode = 1



adn try connecting again , ... i will be installing Fedora 8 soon , so if it is really any problem with Fedora 8 i will let u know !
 
Old 11-24-2007, 12:58 AM   #4
lsropia
Member
 
Registered: Dec 2002
Distribution: RedHat
Posts: 30

Rep: Reputation: 15
Changed as per your parameters. No Change, Still not connecting.

----------------------------------------------------------------------------
[root@localhost obex]# wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99***#
--> Waiting for carrier.
ATDT*99***#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Nov 24 12:25:34 2007
--> Pid of pppd: 7398
--> Using interface ppp0
--> pppd: xE�[08][08]=�[08]
--> pppd: xE�[08][08]=�[08]
--> pppd: xE�[08][08]=�[08]
--> pppd: xE�[08][08]=�[08]
--> pppd: xE�[08][08]=�[08]
--> pppd: xE�[08][08]=�[08]
--> Disconnecting at Sat Nov 24 12:25:41 2007
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
----------------------------------------------------------------------------

and the N70/ wvdial continuously try connecting and above message is the output until killed with Ctrl+C.
 
Old 11-24-2007, 05:55 AM   #5
lsropia
Member
 
Registered: Dec 2002
Distribution: RedHat
Posts: 30

Rep: Reputation: 15
This is done for now. However, I am expecting some other problem after I try my application with N70. I will contact again then.

The problem is solved with one additional Init string, found with the search on internet. It took about 10 days to get the problem solved, so, the right thing is needed from the begining.
================================================================
[Dialer Defaults]
Stupid Mode = on
Modem = /dev/ttyACM0
Baud = 57600
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = ATM0
################################################
INIT5 = AT+CGDCONT=1,"IP","gprswest.cellone.in"
################################################
Phone = *99***1#
Username = internet
Password = bsnl
ISDN = 0
Modem Type = Analog Modem
Auto Reconnect = on
Carrier Check = no
Dial Command = ATDP
================================================================

Of course, many of the parameters are not needed, but provided, neverthless.

The same can be generated through GUI by:
1. System->Administration->Network; and supply root password.
2. In the Network Configuration window; click Hardware tab:
While in the Hardware Tab, Click New; and now in the new Choose Hardware Type window;
set Hardware Type = Modem and select OK
3. In the Modem Configuration Window; select as below
Modem device = /dev/ttyACM0 ( correct /dev/input/ttyACM0 as /dev/ttyACM0)
Baud rate = 460800
Flow control = Hardware (CRTSCTS)
Rest of the selections are not important.
now Select OK.
This will create Generic Modem in Network Configuration->Hardware tab.
4. In the Network Configuration window; click Devices tab:
While in the Devices Tab Click New, and in the Select Device Type window click Modem connection
and Click Forward
In the Select Provider window, set these parameters:
Phone Number = *99***1# (Leave Prefix and Area code blank)
Provider name = BSNL
Login name = A
Password = B
and Click Forward
In the IP Settings window; nothing to be selected here, so click Forward
In the Create Dialup Connection window; click Apply.
This will create new BSNL network in inactive state.
5. In the Network Configuration window; click on the newly created BSNL network so as to select it, and then click Edit.
This opens Modem Dialup Configuration window with several tabs, we will edit only which are needed.
In the Advanced tab, set
Modem initialization string = AT+CGDCONT=1,"IP","gprswest.cellone.in"
and select OK.
Now in the Network Configuration window; click Activate, to activate the newly configured GPRS modem.
6. It has worked for me, and should work for you too. You may have to Activate and Deactivate two times in order that internet browsing is possible.
 
Old 12-09-2007, 10:43 AM   #6
gopi.d
Member
 
Registered: Feb 2006
Location: India
Distribution: Slackware 12, Fedora 7, Kubuntu-7.04
Posts: 172

Rep: Reputation: 30
hi guys i have tried this on my airtel connection and sony ericsson w850i mobile the connection was up but i was not able to browse. the same happened in windows too but i was able to browse after i had entered the proxy settings in my browser. is it required to put proxy settings in browser for linux.
 
Old 12-22-2007, 01:31 AM   #7
lsropia
Member
 
Registered: Dec 2002
Distribution: RedHat
Posts: 30

Rep: Reputation: 15
No. I do not think, Proxy settings are needed in Linux.

At least, my browsing was possible without having to put in any proxy settings on FC8, through N70 USB cable on 3000 N100.

Has anyone sent/ received SMS through N70 on FC8 with kannel.

I will appreciate any help.
 
Old 04-05-2008, 07:09 PM   #8
abimatrix
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
Thumbs up finally it got connected

Quote:
Originally Posted by lsropia View Post
No. I do not think, Proxy settings are needed in Linux.

At least, my browsing was possible without having to put in any proxy settings on FC8, through N70 USB cable on 3000 N100.

Has anyone sent/ received SMS through N70 on FC8 with kannel.

I will appreciate any help.


Hi friends,
eerpini have gave us complete configuration details, In that configuration we have to add
INIT5 = AT+CGDCONT=1,"IP","airtelgprs.com" as said by lsropia
The above line is added to rectify the pppd exit error


My configuration file is
[Dialer Defaults]
Modem = /dev/ttyACM0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
INIT5 = AT+CGDCONT=1,"IP","airtelgprs.com"
Stupid Mode = 1
Modem Type = USB Modem
Phone = *99#
ISDN = 0
Username = a
Password = b
Baud = 460800

Then we no need to add proxies, as eerpini said we have to add
lines in /etc/resolv.conf file as below

service named start
nameserver 202.56.250.5
nameserver 202.56.250.6

Airtel gprs works for me in Fedora core 8. I have tested it with my nokia 5700 only for airtel.


Thanks for all your great ideas.

"Human Knowledge Belongs to the World"
 
Old 04-17-2008, 09:30 AM   #9
salvadorsing
LQ Newbie
 
Registered: Mar 2007
Location: Kuching
Distribution: Ubuntu 7.04
Posts: 17

Rep: Reputation: 0
I'm currently using ubuntu 7.04 dual boot with a XP on my Dell Inspiron 640m. Before this i have a dsl connection at home so this wasn't really a problem. But recently i was sent outstationed. so i need to start using my N73 as my modem.
Using it with my XP with PC suite is totally no problem. But using Fresh Installed Ubuntu with no Internet is a pain. But i found out something like wvdialconf and wvdial and it seems that there is a hope. but it kept showing things like this:-

salvador@sal02:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Segmentation fault (core dumped)
salvador@sal02:~$ sudo wvdial
Segmentation fault (core dumped)

I just kept showing this error msg "Segmentation fault (core dumped)" don't know what's really about. can anyone help me on this or teach me how to crack down this error? For your info, i tried switching all the usb ports to see whether it is the cause, still same problem.

The wvdial.conf settings i changed only the
INIT5 = AT+CGDCONT=1,"IP","Diginet"


Any Idea?
 
Old 04-21-2008, 11:29 PM   #10
abimatrix
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
Segmentation problem

Quote:
Originally Posted by salvadorsing View Post
I'm currently using ubuntu 7.04 dual boot with a XP on my Dell Inspiron 640m. Before this i have a dsl connection at home so this wasn't really a problem. But recently i was sent outstationed. so i need to start using my N73 as my modem.
Using it with my XP with PC suite is totally no problem. But using Fresh Installed Ubuntu with no Internet is a pain. But i found out something like wvdialconf and wvdial and it seems that there is a hope. but it kept showing things like this:-

salvador@sal02:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Segmentation fault (core dumped)
salvador@sal02:~$ sudo wvdial
Segmentation fault (core dumped)

I just kept showing this error msg "Segmentation fault (core dumped)" don't know what's really about. can anyone help me on this or teach me how to crack down this error? For your info, i tried switching all the usb ports to see whether it is the cause, still same problem.

The wvdial.conf settings i changed only the
INIT5 = AT+CGDCONT=1,"IP","Diginet"


Any Idea?
I think u can visit the below link for this error recovery.
http://forums.gentoo.org/viewtopic-p...45571e5015929c
 
Old 10-29-2008, 11:09 PM   #11
Aninya
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Third step is not saved by os.

Quote:
Originally Posted by eerpini View Post
METHOD FOR ENABLING A NET CONNECTION USING AIRTEL GPRS CONNECTION ON LINUX ( MAINLY FEDORA)


PREREQUISITES
-> u shud have a USB cable to connect ur phone to the laptop/system
-> u shud know the product ID(PID) and the vendor ID(VID) of ur phone ,
(for newbies ,as was the case with me ,a good method to do this is to check it out in some other OS like windows
).
-> check whether ur phone shows the USB connected symbol on connecting.....



FIRST STEP:
run this command on the terminal
: /sbin/modprobe usbserial vendor=0x<VID> product=0x<PID>
next follow the second step.........


SECOND STEP:
run the command :wvdialconf create , on the terminal , it will show the output as following,

[root@localhost ~]# wvdialconf create
Scanning your serial ports for a modem.

Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to create.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"


now this shows that i have a modem connected on the port /dev/ttyACM0
now use this and substitute in the script in third step , ..........




THIRD STEP:
PASTE THE BELOW SCRIPT IN THE FILE etc/wvdial.conf ( delete any earlier existing scripts)and .........


[Dialer Defaults]
Modem = <the modem port recognised on running the command: wvdialconf create , on the terminal>
Baud = 230400
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = *99***1#
Username = A
Password = B
Stupid Mode = 1


[B]FOURTH STEP:[\B]

open terminal with root permissions and run the command : wvdial.

the output for a successfull connection shud be as follows :


[root@localhost ~]# wvdial
--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer bg] does not exist in wvdial.conf.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Mon May 21 09:44:10 2007
--> pid of pppd: 3748
--> Using interface ppp0
--> pppd: Modem
--> pppd: Modem
--> pppd: Modem
--> local IP address 10.154.32.5
--> pppd: Modem
--> remote IP address 10.6.6.6
--> pppd: Modem
--> primary DNS address 202.56.250.5
--> pppd: Modem
--> secondary DNS address 202.56.250.6
--> pppd: Modem


now u shud be able to connect with 75 % certainity, and i think u can get help for the remaining 25 % from some of the forums , please read the notes below , they are important ,........

NOTE 1:there is even another problem that might arise , even if wvdial shows a connected modem , but u are not able to
open any website ,........
then do this after connecting paste the following script in the /etc/resolv.conf file:

service named start
nameserver 202.56.250.5
nameserver 202.56.250.6

NOTE 2: there is yet another problem , the airtel provides two numbers , one is *99# and the other is *99***1# , the latter worked in my case if it does not work in ur case use the number *99#,

NOTE 3:
THE CONFIGURATION I USED WAS

laptop: HP nx7400
Linux Distribution: Fedora Core 6 (ZOD)
phone: NOKIA 7610


reference : my main referance were the posts on this forum , think.digit.com ,and the thread was: Fedora Core 5+Nokia 6070+CA 42+Airtel GPRS
( i am sorry i am not able to qoute the exact web address here );





if this was helpful i will feel happy ,, .. please tell me if there is any new problem ,.... we will work to solve it ,

AND IF ANYONE FINDS A SIMILAR IMPLEMENTATION BUT USING A BLUETOOTH PORT THEN REPORT/POST IT HERE.........

Hi,
1. i've done wat u said. but when i type script of third step and try to save is a msg is displayed that, " u do not have permission to save it". wat could i do??? bcoz i am a administrator.
2. and in fourth step wat do u mean by ''open terminal by roote permission', here wat is meant by root permission??
 
Old 10-30-2008, 11:21 PM   #12
eerpini
Member
 
Registered: Mar 2007
Posts: 36

Original Poster
Rep: Reputation: 15
Talking edit the file /etc/wvdial.conf as root

Aninya this is probably becuase you do not have the permissions for editing the given file you can do this :

# sudo gedit /etc/wvdial.conf

you will be asked for your password and that is done , you should be able to edit the file successfully .

And in the final step , what i mean is run the command as the root user like :

# sudo wvdial

I am extremely sorry for using such lame language in the initial post , it was a long time ago that i wrote the howto and i was really a novice back then ;-), hope u find this useful !


Thanks
Satish
 
Old 10-30-2008, 11:32 PM   #13
eerpini
Member
 
Registered: Mar 2007
Posts: 36

Original Poster
Rep: Reputation: 15
And for the information of the other interested people , i had also long ago configure my phone to access GPRS via the bluetooth and it works great . There is a small difference between the to methods :


Step 1 :
scan for the bluetooth device using "hcitool scan " and from the results displayed note down the bluetooth address , mine looks like :

00:18:8D:8E:10:10

Step 2 :
bind the address to a device node . When we connect to the phone using USB , we have the phone attached to /dev/ttyACM0 , similary we need to attach the phone to the device node /dev/rfcomm0 and bind it in channel 1 , which is the channel for running GPRS services , the command to be run to do this is :

rfcomm bind rfcomm0 00:18:8D:8E:10:10 1




Step 3 :

edit the file /etc/wvdial.conf file and make the foolwing changes , while keeping everything else as in a USB/serial based connection :

Modem = /dev/rfcomm0


Step 4:
run wvdial and if necessary add the nameserver information to /etc/resolv.conf and you can now successfully browse the internet .

note : My wvdial.conf file looks like this :

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = *99***1#
Modem = /dev/rfcomm0
Username = A
Password = B
Baud = 460800

Hope this helps ! ;-)
 
Old 09-18-2009, 08:59 AM   #14
shobhitsharda
LQ Newbie
 
Registered: May 2009
Location: kollam,India
Distribution: ubuntu
Posts: 22

Rep: Reputation: 15
hi,
thank you for providing this information.I am glad this did work with many,but did not work for me.
I am using samsung SGH-L700 airtel gprs and want to connect in ubuntu9.04, above code is showing me the following error
(b/w : i am able to connect in windows vista and dialing no which i have to use is *99***1#)

–> WvDial: Internet dialer version 1.60
–> Cannot get information for serial port.
–> Initializing modem.
–> Sending: AT+CGDCONT=1,”IP”,”airtelgprs.com”,”",0,0
AT+CGDCONT=1,”IP”,”airtelgprs.com”,”",0,0
OK
–> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
–> Modem initialized.
–> Sending: ATDT*99***1#
–> Waiting for carrier.
ATDT*99***1#
CONNECT
–> Carrier detected. Starting PPP immediately.
–> Starting pppd at Fri Sep 18 19:13:08 2009
–> Pid of pppd: 8077
–> Disconnecting at Fri Sep 18 19:13:09 2009
–> The PPP daemon has died: pppd options error (exit code = 2)
–> man pppd explains pppd error codes in more detail.
–> I guess that’s it for now, exiting
–> The PPP daemon has died. (exit code = 2)

I coudn’t find any solution to this “exit code =2 ”

kindly help me out
thnx in advance…
 
Old 10-27-2011, 09:15 AM   #15
vijaynarayankutty
LQ Newbie
 
Registered: Oct 2011
Posts: 1

Rep: Reputation: Disabled
Am also having the same problem
 
  


Reply

Tags
airtel, connection


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I connect to airtel GPRS internet via Nokia 6070 DKU-5 cable ? deepumnit Fedora 2 02-17-2007 11:42 PM
unable to use lg kg200 with airtel gprs on linux aki_scorpion Linux - Wireless Networking 0 01-11-2007 04:49 AM
gprs via airtel linux settings for motorola l7 kenlitting Linux - Software 2 11-16-2006 12:25 AM
airtel gprs in Linux using T630 USB Cable samirlinux Linux - Software 0 09-23-2005 09:57 AM


All times are GMT -5. The time now is 05:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration