LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   after re-create tftp dir, tftp doesn't work anymore (http://www.linuxquestions.org/questions/linux-networking-3/after-re-create-tftp-dir-tftp-doesnt-work-anymore-599902/)

lastguy 11-15-2007 01:42 PM

after re-create tftp dir, tftp doesn't work anymore
 
Hi, Thanks for help and I think this may be a general problem.
1. My tftp used to works on two Fedora 6, my cfg files are:
$ cat /etc/xinetd.d/tftp
service tftp
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -m /etc/tftpremap /tftpboot -c
per_source = 11
cps = 100 2
flags = IPv4
}

2. My colleague mv /tftpboot /tftpboot_backup, re-mkdir /tftpboot on one Fedora 6, then tftp doesn't work or we can't use another embedded linux to get file from it. Then he found Fedora 6 uses ipv6 from ifconfig and disabled it (In fact in system service ipv6 is disabled, but he used to see such problem). As no help, I then follows what on a web told us completely to disable ipv6. no luck.
Now I get one Failed msg as below:
$ sudo service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... failed.
[ FAILED ]

3. My question is why recreate a /tftpboot can lead to failture of tftp? may be Fedora uses a link internally that is not dynamically updated? How can I get it back?
thanks alot. waiting.

rojak 11-15-2007 11:33 PM

Not much help, but just a few hints:
I presume you also changed the server_args in /etc/xinetd/tftp into your new tftpboot
and restart the xinetd server?
If yes, then perhaps the access rights of tftpboot are different?

lastguy 11-16-2007 03:33 PM

thanks I erase and install both inetd/tftp-server and they work now.
Incase others face same problem, my solution is to remove the tftp file, use yum to erase both, install both, the tftp file would be automatically generated, edit it to change disable to no, restart, works.


All times are GMT -5. The time now is 09:40 AM.