LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-09-2003, 01:35 PM   #1
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
ADSL Connection is fine, but can't browse the internet.


Hi....

I'm using an Alcatel Speedtouch USB modem to connect my Mandrake Linux 9.1 OS to my ISP.

The connection seems to be fine.... I can ping the local and remote IP addresses that pppd gives back in /var/log/messages.
All my configuration seems to be correct, from what I've read in various HOWTOs and other forums.

However I can't browse the internet with any of the internet browsers, e.g. Konqueror. I do not have a firewall installed.

Any ideas?
JustOne

And by the way. I can browse the internet through my home ethernet network, from an internet connection that is shared from another PC. I just can't browse when I'm trying to connect directly with my ADSL USB modem.

Last edited by JustOne; 07-09-2003 at 01:38 PM.
 
Old 07-09-2003, 02:25 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
If you can ping by a site IP address and not by it's name, then you need to add your ISP's DNS server to your /etc/resolv.conf.
 
Old 07-09-2003, 04:36 PM   #3
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
Wrong connection...

I tried to add a

"search myisp.com"

to my resolv.config file, where the two nameservers for my isp also sit. But everytime I tried to ping it by its name I get the following message:

From 192.168.0.1 icmp_seq=1 Destination Host Unreachable

It seems to successfully translate the isp's domain name into a decimal dot IP address.

The resolv.config file is also altered after I do this. It changes my nameservers to 127.0.0.1 and 192.168.0.1???? These are both local.

I think it's getting confused about how I get to the internet. Sometimes I connect through a home network, where the gateway to the www is 192.168.0.1, and I can do this successfully, but I won't be able to do this all the time... and I'll sometimes need to connect with my USB adsl modem (which I believe is working fine at the moment)
 
Old 07-10-2003, 06:41 AM   #4
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
Any ideas?

Any ideas anyone?
 
Old 07-10-2003, 07:17 AM   #5
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
Have you tried to change the defalt gateway?
 
Old 07-10-2003, 07:30 AM   #6
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
Default Gateway?

I haven't tried that! Didn't know there was one.... how do I change the default gateway?
 
Old 07-10-2003, 07:35 AM   #7
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
You said that you could connect through you internal net work. How is that setup? Do you have MS connection sharing or do you run sometype of proxy server?
 
Old 07-10-2003, 07:38 AM   #8
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
I have Microsoft connection sharing provided by Windows ME desktop. When I connect through my desktop, I go through the gateway 192.168.0.1.

So this must be defaulted on my Linux laptop?
 
Old 07-10-2003, 08:06 AM   #9
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
You said that you could connect through you internal net work. How is that setup? Do you have MS connection sharing or do you run sometype of proxy server?
 
Old 07-10-2003, 08:15 AM   #10
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
My internal net setup:

I have two computers.

A desktop running Windows ME is set up to share an internet connection with my laptop which is running Mandrake Linux 9.1.
The internet sharing connection is provided by Microsoft Internet Connection Sharing through Windows ME.

The Windows ME desktop is assigned IP 192.168.0.1 and is the gateway to the web for the laptop, whch is assigned IP 192.168.0.2.

They communicate over ethernet, using a crossover ethernet cable, and should be connected at 100Mbps but I haven't actually verified this.

The modem connected to my desktop is a Speedtouch USB modem providing a 1/2 Mbps connection. This is what I'll use to connect directly from my laptop from time to time when I can't use my shared connection.

Thanks for your help, tangle

Last edited by JustOne; 07-10-2003 at 09:03 AM.
 
Old 07-10-2003, 09:34 AM   #11
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
OK, the last version of Mandrake I used was 8.2. There was a Control Center or something like that. In that there is a place to setup the internet. I is a wizard and it will walk you through. I would use that and put the DSL modem as the device that connects to the internet. This is the easiest way to do it.

Here latley I have used Slackware and have got away from Mandrake almost all together (have one MD box left). So if you wanted to manually edit the config files there should be a directory /etc/sysconfig. In it there are some scripts that that are named after network devices. I am not sure about which one you need to edit, but I would guess it is named ppoe.conf or something like that. They are usually named as the name of you network device. In the file the is a place that says "gateway =", this is where you want to put 127.0.0.1(I think).

If you wanted to share that connection you could do it through the control center too. Other than that I am out of ideas since I am not infront of the PC.
 
Old 07-12-2003, 07:01 PM   #12
JustOne
LQ Newbie
 
Registered: Jul 2003
Location: United Kingdom
Distribution: Mandrake 9.1
Posts: 8

Original Poster
Rep: Reputation: 0
THE SOLUTION!

The solution is to unplug the network cable from the laptop.

This works because this way you ensure that the internet connection sharing on the Windows ME computer doesn't keep changing the /etc/resolv.conf file (due to DHCP). It will do this even if you disable internet connection sharing in Windows ME.

By unplugging the cable, the system checks the peer on the ADSL connection instead and /etc/resolv.conf will be modified to contain your ISP's nameservers.

It's as simple as that!

The Moral of the Story: Make sure you don't have too many peers supplying your machine with a DNS, because /etc/resolv.conf is usually overwritten and not appended to in my experience.

Last edited by JustOne; 07-12-2003 at 07:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot establish adsl internet connection pat@studio Linux - Networking 2 05-11-2005 02:08 PM
HELP!! No adsl internet connection dvy834 Linux - Newbie 1 04-19-2004 06:38 PM
ADSL internet connection mrstirs Linux - Networking 0 02-20-2004 09:26 AM
please help me with my wireless adsl internet connection. wimva Linux - Newbie 1 11-20-2003 09:53 AM
PPPoE ADSL internet connection EL Nino Linux - Networking 2 02-04-2003 09:47 PM


All times are GMT -5. The time now is 03:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration